< <
OUR NETWORK:TiVo Community TechLore Explore3DTV DVRplayground Dijit Community See all... About UsAdvertiseContact Us

Configuring NETGEAR WGR614L As A Wireless Client Bridge with OpenWRT Firmware

You can now configure the WGR614L router as a wireless client bridge using OpenWRT firmware - read on to learn how!

I have already written one article about how to configure the WGR614L as a client bridge using the DD-WRT firmware, and as such, I won't repeat the background information here.  If you're interested in learning more about what a wireless client bridge is and how it works, please click here.

It is worth noting that there is no GUI (graphical user interface) for OpenWRT through which you can configure the board as a wireless client bridge.  You must have a serial cable to access the console, and these instructions assume you are set up this way.

First, you must install OpenWRT onto your router.  After booting the board, you will need to edit the following configuration files as described below.  The items in bold italics are the lines that need to be changed.

Changes to OpenWRT Configuration Files

1. /etc/config/wireless:

config wifi-device wl0

option type broadcom

option channel 5

# disable radio to prevent an open ap after reflashing:

option disabled 0

config wifi-iface

option device wl0

option mode sta

option ssid AnyAP_SSID

option encryption none

2 . /etc/config/network:

#### VLAN configuration

config switch eth0

option vlan0 "1 2 3 4 5*"

option vlan1 "0 5"

#### Loopback configuration

config interface loopback

option ifname "lo"

option proto static

option ipaddr 127.0.0.1

option netmask 255.0.0.0

#### LAN configuration

config interface lan

option type bridge

option ifname "eth0.0"

option proto 'static'

option ipaddr '10.0.0.1'

option netmask '255.255.255.0'

option gateway ''

option dns ''

#### WAN configuration

config interface wan

option ifname "eth0.1"

option ifname "wl0"

option proto dhcp

Finishing the Configuration Settings

After doing these changes you should reboot the system. Congratulations, your board is now successfully configured as a Wireless Client Bridge.

Your WGR614L will be connected to the AP AnyAP_SSID (you can also change the name.)

Any kind of feedback regarding this article is always appreciated.


Quick Links

Using a Serial Cable with the WGR614L and Windows

Tags : openwrtwireless client bridge

Add Your Reply

(will not be displayed)

Email me when comments are added to this thread

 
 

Please log in or register to participate in this community!

Log In

Remember

Not a member? Sign up!

Did you forget your password?

You can also log in using OpenID.

close this window
close this window