DD-WRT Kong Mod Info

NOTE: The info here is deprecated and only applies to my old K26 builds. Things have changed as I'm a member of the dd-wrt dev team now. I have merged all features into mainline dd-wrt. Current Kong builds are now regular dd-wrt builds, the only main difference is, that my releases are no regular snapshots. Every kong release receives testing before beeing published. Thus you can always be sure, that flashing has been tested and won't brick due to a software bug, which can happen on untested nightly dd-wrt builds.

 

DD-WRT Kong Mod is a dd-wrt re-build for broadcom 47xx units with >=8MB flash. For a list of supported models checkout the Readme.

This build in myopenrouter download section is not for 60K/64K NVRAM Units, to find the exact build read the Readme.

WNR3500L V2 [Dual Radio] Builds not yet available.

 

Compared to dd-wrt std_ftp_nas it removes following features:

  • chillispot/hotspot
  • a few themes
  • sftpserver ( use scp instead )

Compared to dd-wrt std_ftp_nas build it currently includes the following features:

OpenVPN and MiniDLNA Build:

  • network speed optimization (Benchmark)
  • general speed optimizations (compiled using -O2)
  • opkg optware package management tool
  • large file support samba, console utils
  • inotify support
  • kernel futex support
  • fpu support for optware packages
  • kernel rt mutex
  • lower default TX power for greater stability
  • 3/4G Modem support
  • full featured uClibc for better optware compatibility
  • sd-idle included (usb disk spindown, see tutorials how to enable it)
  • advanced usb drive automount, with swap support
  • drive umount using SES / AOSS / EZ-SETUP / WPS Button
  • clean umount at reboot

MiniDLNA Build:

  • DLNA Media Server for DLNA/UPnP-AV Clients (XBox, TVs...)

OpenVPN:

  • xl2tpd with kernel driver (better throughput)
  • zabbix enterprise monitoring client (Screenshot)
  • proxy with adblocking/filtering in transparent or nontransparent mode (Screenshot)

KingKong Build (only Asus RT-N16):

  • includes all features + voip

Automount: My builds include a completely redesigned automount.

By default all disks are mounted to /tmp/mnt/disc_part.

If a partition is labeled Optware it will be mounted to /opt, if it is labeled Jffs it is mounted to /jffs, if it is labeled Mnt it is mounted to /mnt.

You can override this behaviour by supplying the uuid of a partition in the webinterface this will override default and mount by label strategy.

Umount through SES/WPS Button works the following way:

Enable Use SES Button to remove drives in section Services->USB of the web interface

Now when you press the button the power light will go off indicating the start of the umount process. Once the light blinks twice umount is complete and the power light will go on again. Now all of your partitions have been umounted, including swap.

After that you can safely remove your drives. If you have multiple drives (e.g. a,b,c) you have to disconnect all of them and attach the ones you need again (e.g. a,b). There is no option right now to selectively umount certain partitions/drives. But as most users probably use only one drive this should work for the majority.

 

Note: Sourcecode modifications are directly forwarded to the individual maintainers and can be retrieved using their scm's or their bug trackers.

Tags: 

macleod
macleod's picture
Can I upgrade to Kong from

Can I upgrade to Kong from Mega?

DD-WRT v24-sp2 (07/18/10) big
(SVN revision 14826M NEWD-2 K2.6 Eko)

kt_haddock
kt_haddock's picture
Yes you can through web-gui,

Yes you can through web-gui, Do a nvram reset after update.

Brocili
Brocili's picture
pffft

pffft
well
i installed;

Router Name
DD-WRT
Router Model
Netgear WNR3500v2/U/L
Firmware Version
DD-WRT v24-sp2 (04/11/11) vpnkong - build 16774M

but it seems the usb port on the router is DEAD
when i put in a HD no LED's flash
a USB stick also no leds or anything

im sure its not the drive or stick sisce i tested them in a "normal" USB port

i did the 30-30-30 reset but no dice

i want to do the OPTware install thingy but then i really need the USB drive

surfing the boards for is VERY timeconsuming since the info around is fragmented to say the least

i went for this KONG mod because this said USB support was enabled by default AND it was succesfully tested on a WNR3500L

but it seems the USB port is simply dead

anyone have any tips?

or (preferably) a working configuration?

WNR3500L
firmware type and build??

thanks

Denis
Denis's picture
Hello! In updated version

Hello! In updated version from 20.04.2011 OpenVpn works simply blazing

USB printer support doesn't work at all. In you previous firmwares everthing was great!

TeHashX
TeHashX's picture
Hi, I want to try this

Hi, I want to try this firmware but I prefer the original asus RT-N16, it is possible to add miniDLNA server to original asus firmware 1.0.2.3?
I hope that works to stream videos from usb drive connected to my router to my samsung LE32C550 tv.
THX

Lamoboy
Lamoboy's picture
Does this firmware have the

Does this firmware have the Dual WAN support?

jondlou
jondlou's picture
Hi Kong, is it possible or

Hi Kong, is it possible or impossible with the E3000 to move the Privoxy portion into the DLNA version? I think it would be a huge improvement for more users that are initially switching to your build. I use Pixelserv and I can tell Privoxy would be a good solution.

eTaurus
eTaurus's picture
Hi Kong,

Hi Kong,
would it be possible to add 3G-modem support to your mod? It would be the killer mod for me then.

Thanks,

eTaurus

skykingstlmo
skykingstlmo's picture
Hi Kong,

Hi Kong,
I have been trying for two weeks to get DD-WRT V24 to build from source. I am targeting the WNR3500L. My build system is 64 bit Unbuntu 9.10. I have downloaded the current toolchains from DD-WRT.com and source code but cannot get it to build. I have followed the "tutorial on building DD-WRT" with no success. What build system and toolchains are you using? Can you give me any suggestions?
Thanks in advance.
Skykingstlmo

kugar
kugar's picture
Does this release support

Does this release support ipv6 ?

Kong
Kong's picture
@jondlou,

@jondlou,

unfortunately minidlna and privoxy are rather large binaries, therefore they won't fit in the same build unless one has a Asus RT-N16, since I don't own a unit with >8MB flash I don't create a kingkong build:-)
I I get my hands on a new router I'll fit in some more stuff.

jondlou
jondlou's picture
@Kong: Sounds like a deal.

@Kong: Sounds like a deal. Give me until mid-July and you will receive your own RT-N16 to keep. I will order my own so we can test it too. Thank you...

Take care,

Jonathan

firefox98
firefox98's picture
Hi Kong,

Hi Kong,

I just bought a netgear 3500L which runs your mod perfectly.
I have another old router, WRT54GS v2, which has Broadcom BCM4712 @ 216 MHz 32 MB 8 MB, I am wondering if I could flash you mod on it since it meets the requirements.
Already googled, no results.

Thanks!

Kong
Kong's picture
Hi firefox98,

Hi firefox98,

no this is an old unit with previous corerev. Those are not supported anymore through this build. The minidlna build would be to much for this unit anyways, since it only has 32MB ram

Chill
Chill's picture
Hi Kong,

Hi Kong,

Searching online led me to this link and I would like to ask you if your kong mod will work on my generic router.

The details are as follows:
CPU Model - Broadcom BCM5354 chip rev 3
CPU Clock - 240 MHz
RAM: - 32 Mb DDR
Flash Memory: - 16 Mb
builtin USB
running DD-WRT v24-sp2 (12/24/10) mega - build 15962

Right now, the unit is acting as WAP with 2 BSSIDs, one for my internal network and another one for public (I am broadcasting my internet for students who wants to connect to the internet for school works). SNMP is running and is linked to odmon.com for monitoring purposes.

Your inputs are highly appreciated

More power to you and this website

kt_haddock
kt_haddock's picture
It's only to:

It's only to:
Netgear WNR3500L, Asus RT-N16, Linksys WRT610N V1/V2 and E3000 special fw

GorbyRulez
GorbyRulez's picture
Does Kong Mod support IPv6?

Does Kong Mod support IPv6? I have it selected in options but Vuze displays only IPv4 connection status as OK. When I bypass the router and go direct from my PC it does show IPv6 as active and connected, so I know my Vuze config and my ISP supports it.

Is it because the router itself (Netgear WNR3500L) lacks this ability?

Enquiring minds need to know...
Gorb

jondlou
jondlou's picture
I think DD-WRT or a developer

I think DD-WRT or a developer even, could implement native IPV6 support like Victek's Tomato displays. However, you can use radvd.conf and all the other manual script options that the following method uses to eventually come to a conclusion if you do some research.

This is the easiest method without using the ISP to setup IPV6 (since your ISP may have special requirements). It is with a tunnel on this method, but I agree IPV6 is better through the ISP. Hope this helps give some ideas...

http://www.dd-wrt.com/phpBB2/viewtopic.php?p=497074

Take care,

Jonathan

GorbyRulez
GorbyRulez's picture
Thanks Jondlou, that script

Thanks Jondlou, that script worked like a charm! At first I thought not but I restarted Azureus and IPv6 was running fine. I do use OpenDNS but couldn't figure out that OpenDNS instructional on the wiki page. If I set my router to "Use local DNS" everything stops working - both Internet and local network even though I had all the other settings already as you specify.

kugar
kugar's picture
GorbyRulez said: Thanks

GorbyRulez said: Thanks Jondlou, that script worked like a charm! At first I thought not but I restarted Azureus and IPv6 was running fine. I do use OpenDNS but couldn't figure out that OpenDNS instructional on the wiki page. If I set my router to "Use local DNS" everything stops working - both Internet and local network even though I had all the other settings already as you specify.

Which firware version are you using ? On which device ?

Mychu
Mychu's picture
Hi,

Hi,
does this firmware support Netatalk 2.2?

tcope
tcope's picture
Well I had not updated my

Well I had not updated my Kong firmware for about a year so I did so a few weeks ago. From what I read my result is not typical but I lost _all_ port forwarding completely! Nothing I did would help... settings, 20/20/20 hard reset, etc. I finally installed an older firmware and immediately everything started working again. Thing is, the old firmware worked perfectly. I only upgrade to see if something was improved.

Just throwing that out there.

Kong
Kong's picture
Port forwarding is working

Port forwarding is working fine on my builds, otherwise I wouldn't be able to write this:-)

Check your settings under Security->Firewall->Block Wan Requests, check all but "Filter WAN Nat Redirection"

Ricardo Oliveira
Ricardo Oliveira's picture
Hi, thanks for the build.

Hi, thanks for the build.
However there is a problem that wl1 doesn't work in the 5GHz (N mode) in wrt610n v1. Do you know anything about that ?

Cheers,
Ricardo Oliveira

Ricardo Oliveira
Ricardo Oliveira's picture
Hi great job, however wl1

Hi great job, however wl1 doesn't seem to work on the 5GHz configuration (N only). NO SSID broadcasted. If I use it as 2.4GHz it works. Do you know any reason for that ?
I'm on a WRT610n v1.

Cheers,
Ricardo Oliveira

class
class's picture
I have E4200

I have E4200
I installed this version:

http://tips.desipro.de/

Kong-Mod-E3000-USB-FTP-SAMBA3-OPENVPN

and i tested using IPERF WAN-LAN speed.
i was able to get only to 103mbit.
any idea how i can get much better speed?
on the stock linksys i got 630mbit.

i installed your version cuz i thought ill get more than 100mbit compare to the other DD-WRT's.

can you please explain me what should i try with ur firmware?

thank you for the great job man!

Kong
Kong's picture
Linksys uses fast-nat since

Linksys uses fast-nat since they don't offer all features dd-wrt offers.

In Linux, there are actually two separate types of NAT that can be used, either Fast-NAT or Netfilter-NAT. Fast-NAT is implemented inside the IP routing code of the Linux kernel, while Netfilter-NAT is also implemented in the Linux kernel, but inside the netfilter code. Since this book won't touch the IP routing code too closely, we will pretty much leave it here, except for a few notes. Fast-NAT is generally called by this name since it is much faster than the netfilter NAT code. It doesn't keep track of connections, and this is both its main pro and con. Connection tracking takes a lot of processor power, and hence it is slower, which is one of the main reasons that the Fast-NAT is faster than Netfilter-NAT. As we also said, the bad thing about Fast-NAT doesn't track connections, which means it will not be able to do SNAT very well for whole networks, neither will it be able to NAT complex protocols such as FTP, IRC and other protocols that Netfilter-NAT is able to handle very well. It is possible, but it will take much, much more work than would be expected from the Netfilter implementation.

The speed you are getting is about the best you can get with normal NAT using this router.

class
class's picture
Thanks alot for the answer!

Thanks alot for the answer! now i understand it well.
and what can you say about CTF - Cut through switching.
is it a part of Fast NAT?
im asking this because i did simple test in the Linksys firmware. tested speed of WAN-LAN with CTF ON and CTF OFF.
the results:
CTF ON:
630Mbit
CTF OFF:
110Mbit

so CTF is a part of Fast NAT?

and im guessing there isnt any version of DDWRT with FAST NAT/CTF avilable, from what you know, right?

mart
mart's picture
hi Kong, is there any

hi Kong, is there any possible to integrate with over 16 vlan trunk support in your mod? I really need trunk vlan 85 and vlan 51 for seperate iptv signal. Much appreciated.

Kamika007z
Kamika007z's picture
Hi Kong!

Hi Kong!

Thank you very much for these builds!

I'm having 1 issue so far... my WOL isn't working anymore for my desktop, when it used to work before.

I was running a build previous to 17670:17737M (E3000), but I didn't perform a wipe before upgrading to this version and I used the "dd-wrt-e3-usb-ftp-samba3-dlna-O2-v24-K26-broadcom" BIN file to upgrade my router.

Any way you could let me know if wiping & rebuilding the config would fix the issue or is this a known issue already?

Any assistance with this would be GREATLY appreciated.

EDIT/SOLVED: It turned out to be my workstation. I had to enable the option "Enable LPM" on my network adapter under device manager.

Apologies and thanks again!
-Kamika007z

Pages

Zircon - This is a contributing Drupal Theme
Design by WeebPal.