7500v2 to Support DD-WRT

41 posts / 0 new
Last post
cockroach
cockroach's picture
Update to previous post::

Update to previous post::

Known issue:  2G and 5G leds are not operational since they cannot be controlled through gpio.  Current opensource wireless driver has no support to control these leds.

If you want to revert to netgear firmware flash 'ddwrt-to-netgear-fw-R7500v2.bin' available at this link:

http://www.desipro.de/ddwrt/K3-AC-IPQ806X/

 

 

Fellblade
Fellblade's picture
I'd like to add to my

I'd like to add to my experience.

Flashing to Kong firmware was absolutely no issues.  However, I realized that for whatever reason my internet speeds dropped from 50 mgbs -> 6 - 8 mgbs, with exactly same DNS/router settings as before.  I only added MAC restrictions to my sons iPads since i could not do that with netgear firmware.

The file to revert to netgear fw is not working for me.  I have tried multiple times, each time using the webif to refas with the ddwrt-to-netgear-fw file without success, each time the firmware reflash counter starts at 300s and then around 292s or so, it says "Update Successful" reboots and is still dd-wrt firmware. 

I have no idea what could be causing issue #1 for dropping internet connectivity speed, but I know it is the firmware because I did not have this issue before, and a TPLINK router I have is giving me the full 50 mgbs down.

I'd like to reflash back to netgear fw but can't.  Therefore not sure what to do with this router until I can figure out a workaround or somehow resolve the slow speeds I am seeing with current version of kong's dd-wrt firmware.

EggPlantS
EggPlantS's picture
I was always very weary about

I was always very weary about flashing as I don't have cash to spare and this is my only gateway device. So it is not like I can use something else once the generic firmware screws it up.

By the way, I have found that you usually have to use the TFTP method when flashing back to mfg firmware and something that is always a bit scary is that there is a blob in the very begining of the firmware that tells it your MAC addresses. DDWRT usually uses generic MAC addresses and so it is fine with changing them via nvram or command line. Netgear FW on the other hand spent all its time putting little rights restriction type stuff into open source software, way to use your resource team Netgear. Back a long time ago people use to releace tools that would let you back up your original boot loaders that contained the MAC addresses, and I understand why as some ahole decided to sell licenses to use MACs even thought its a just a few bytes at an address in the boot loader, but theoretically you've already paid the license fees when you paid the company for their product, so you should have a right to use all the equipment as you've alreay paid an ungodly amount of fees taxes and tariffs 10 times over to your state, federal, and international consortiums.

The act of canginge firmware on these devices should not exempt you from the rights which you have already paid for, but these people are generally huge aholes.

Realtek is amond the worst of them. I've actually caught them sabotaging firmware so it always transmits at 1MB regardless of the initial connection and that was a commit to DDWRT. So this is the main reason. You will find programmers working for corporations loging in and making "contributions" that basically hobble or disable features in open source projects. The reason they get away with it is that usually no one understands the code anyway.

Currently the 'end user' router market is full of crap and locks and violations of GPL that no one in the corporate world is even scared of a lawsuit anymore.

The GPL violations are almost always in favor of control methods from said corporations. In otherwords they are not violating GPL by helping you use faster software they are violating it by locking you in and using scrambled binary blobs to keep you from fixing the problems which they put in there to begin with.

I would be up for an op to kill all these network engineers even in remote countries if anyone wants to go merc for a bounty killing.

So did you ever get it back to normal without the fracked up bootloader?

 

desireall
desireall's picture
I had installed kong's newest

I had installed kong's newest firmware on my new r7500v2.

And I'm in same situation with FELLBLADE, up/down speed dropped.

graph for up/down speed shows me not only my connection speed dropped

 but also for consistency. graph is showing big waves around 700mb to 500mb

 compares with netgear firms shows simple line at 900mb or higher.(on 1gigabit connection)

 It is a not good compares with my older 40 USD router

 So I tried to go back to netgear orinal firmware, but I can't. Same to FELLBLADE, too.

 feeling trapped and screwed. there is nothing I can't do in this situation. 

 Only wating kong release new firm to fix.

 Why these thing on this firm was not notified on download page fo this firm before?

 It would be known issue rather than for useless LED  malfuction.

    

park sung hun

Fellblade
Fellblade's picture
Yes, I would still appreciate

Yes, I would still appreciate some help going back to stock firmware if possible.  I don't think the image file has been updated from the descreption of folder / file directory.

Appreciate the work put into the firmware, but also hope for some help still.  (Or a new version of DD-WRT that may address performance issues some are seeing).

Thanks!

Fellblade
Fellblade's picture
Guys - I was able to spend

Guys - I was able to spend some time to revert back to the stock firmware today and everything is working normally.

It was quite tricky but was able to find some instructions on the website here that allowed me to figure it out eventually with some trial and error.

Basically you need to download TFTP .exe file if you don't have it.  Download the stock firmware from Netgear website, should be an img file.

Before you start change your router mode to a static IP and have the router address to what you want (just make sure no dupliations on your network).  I used 192.168.1.1 is what I used.  

1.  Plug router into a computer via network cable.

2. Unplug router.

3. Using a paperclip hold reset button down (keep holding).

4. Turn on router.

5. Router power LED will start to flash ORANGE.  Wait for it to start to flash WHITE.

6. Open CMD as admin.  Ping router IP.  If you can ping it, then you can run the TFTP -i 192.168.1.1 PUT <filename.img> 

7. Wait for it to say transfer successful.  If successful just wait and router will reboot itself and be back to stock firmware.  

That should work.  At least it did for me.  I had the hardest time getting the computer to find the router IP address.  But following the above procedure get it set up correctly in my case.  

I hope this helps you guys too!

jortiz12885
jortiz12885's picture
I am having the exact same

I am having the exact same issue, my 5G speeds on stock firmware were over 200Mbps now am getting 50-70Mpbs. I have tried the bin file to revert back and everytime it reboots back to ddwrt firmware. 

 

jortiz12885
jortiz12885's picture
I got it working Thanks!

I got it working Thanks! Speeds on 5G back to 200-300Mpbs 

ilkinandr92
ilkinandr92's picture
Hi, sorry to bother you, but

Hi, sorry to bother you, but is it possible to provide an updated version of firmware for R7000P?

lee.shalako
lee.shalako's picture
this was happening to me as

this was happening to me as well, i had to use the ddwrt-to-netgear-R7500v2.bin file not the FW one

Pages

Zircon - This is a contributing Drupal Theme
Design by WeebPal.