Another bricked router thread (Update: Victory! With details)

7 posts / 0 new
Last post
tetron's picture
Another bricked router thread (Update: Victory! With details)

Having spent awhile reading this forum and the dd-wrt forum I know I am probably screwed, but here's my distress signal:

I have a WGR614/L on which I had been running the  dd-wrt v24 9281 build successfully for about a year.  A couple days ago I thought I might try to upgrade to the latest dd-wrt, having read that the older builds had some known security issues.

I used the dd-wrt web interface and Firefox 3.0.6 to upload dd-wrt.v24-11604_WGR614v8_L-mini.bin as instructed by

The update page sat there for a minute and then said "update successful".  Per the instructions I left the router alone for a few minutes more, and eventually rebooted it.

At this point I theorize several possible things could have gone wrong: the image itself could have been bad, the dd-wrt update interface could be buggy, or I could have rebooted it too soon and interrupted the flash programming routine...

Anyway, I now have a (nearly) bricked router.  It responds to pings on, but no web, ssh, telnet, etc.

  • If I yank the power out and plug it back in, the power light is solid green and the 'test' light is solid amber.  No flashing
  • If I do a 30/30/30 hard reset, the power light comes back on as solid green and the test light is off, then after 20 seconds or so the test light comes on.  When I release the reset button, the power light flashes slowly once, then flickers once, then stays solid.

I've tried throwing tftp at it at all stages with no luck.

At this point I understand that I probably need to get access to the serial console if there is any hope of bringing it back from the dead.  This prospect gives me a headache, since I own neither a TTL-RS232 converter cable, a soldering iron, or even a torx screwdriver that fits the damn screws that hold it together (like Goldilocks and the three bears, I have a torx screwdiver that is too big and another too small, but I need one that is just right.)

Ironically, I just bought another wgr614 with the hopes of setting up a WPA2 WDS network, but now I don't even want to take the second one out of the box until I figure out how to revive this one...

Suggestions, tips, tricks, sympathy would be greatly appreciated.

Keith Page
Keith Page's picture
I did the same thing tonight.

I did the same thing tonight. I found if you start a tftp then hold down the reset button on a wgr614 v8 when you get to the 20 second mark and the power starts flashing it will then accept the image being sent. It seems to only accept it in a very short window there so make sure you start the tftp before teh power light starts flashing.

I recovered mine this way.

achilles's picture
yep this way it is possible

yep this way it is possible but u need to be very precise as far as that 20 second interval is concerned ....
Otherwise the option of serial cable is alwaz there ....
Also I would suggest to use IE for f/w upgrade .. I have seen some posts on this site where problem was due to firefox ....

Keith Page
Keith Page's picture
I'm not sure about the

I'm not sure about the preciseness, can you elaborate. My method is to simply start the TFTP transfer before the 20 second mark it kicks in when the 20 mark is hit. The tftp will keep hitting until that window passes by, if it's hitting it before that window it no doubt will hit it when then window comes up.

1. Hold down reset button, count.
2. About 10 seconds start your tftp transfer (assuming your tftp will run for more then 10 second before timing out.)
3. At the 20 second mark your routers power light should start flashing. At the same time you'll see the tftp transfer begin.

Now i don't know if this is cause of effect, is it flashing b/c it's started the transfer window. Or did it start the reset and open itself up to tftp? Regardless it appears to work without soldering and serial cables and all that whodo.

What would really be great if dd-wrt would not publish the bin files on their site as being compatible with this router.

tetron's picture


I was able to get to the serial console and use that to get back to the stock netgear firmware.

Here's the blow-by-blow details:

1. My starting point was the debricking article at

2. I got a TTL-232R-3V3-WE (USB to bare TTL wire end) cable from Digi-Key. I also ordered a cheap soldering iron and 11-in-1 Rachet Screwdriver from Radio Shack (the latter since it comes with T6 through T10 Torx bits and the screw size required to open the WGR614 is Torx T8).

3. I opened up the WGR614 and soldered on the leads based on the above mentioned article. I am terrible at soldering but I muddled through (there's a reason for the wisdom "beware programmers with soldering irons")

4. I am using Linux where the FTDI USB-to-Serial driver is part of the standard kernel, so plugging in the cable "just works". I used 'minicom' for the terminal program.

5. I plugged in the power on the router, and wouldn't you know it, I started seeing the CFE boot output over the serial port! This part was really amazing, since as a professional software developer I am conditioned to never expect anything to work on the first try :-)

6. Now I have some inkling of what went wrong. Here's the bricked output:

CFE for WGR614v8 version: 1.3
Build Date: Fri Apr 20 14:04:44 CST 2007
et0: Broadcom BCM47xx 10/100 Mbps Ethernet Controller
Device eth0: hwaddr 00-1E-2A-53-B4-F4, ipaddr, mask
gateway not set, nameserver not set
Loading .................................
Image chksum: 0x0E9F5A8E
Calc chksum: 0xDEF92D53
Loader:raw Filesys:raw Dev:flash0.os File: Options:(null)
Loading: . 0 bytes read
Could not load flash0.os:: Error

At this point, it is stuck at the CFE prompt. As I had suspected, it seems that it attempted to load the firmware and failed, and as a result it would neither automatically start tftpd (as it would do if there were no firmware, I assume) nor successfully boots the operating system.

7. Now I was able to follow the rest of the debricking article -- I ran "tftpd" at the CFE prompt, finally got the flashing green power light, and was able to upload the stock netgear firmware.

I hope this helps anyone else who manages to brick their router. Getting to the serial port isn't that hard, it just requires a couple of specialized tools and a willingness to try some easy soldering. Ironically, I probably spent as much on the TTL-USB cable, soldering iron and torx screwdriver as would have cost to buy another WGR614, but now I'm a lot more confident about experimenting with alternate firmwares without getting stuck again.

Happy hacking!

Peter Redmer
Peter Redmer's picture
@tetron - Really glad to hear

@tetron - Really glad to hear you got it up and running. There's a certain satisfaction that comes with bringing a brick back to life. I have definitely learned a lot by installing various firmwares, accidentally getting some brickage, and reviving with a serial cable. I've used both minicom (on Mac with MacPorts) and PuTTY to successfully TFTP.

Once again, thanks for sharing your story and hope that it helps others as well.

achilles's picture
grt tetron ... this setup

grt tetron ... this setup will surely help you in trying different 3rd party firmwares and also to get an insight of different things ....