"The Firmware Is Not Compatible With Your Router" Error

Subscriptions

Subscribe
69 posts / 0 new
Last post
mikeloeven
mikeloeven's picture
We shouldn't have to go down

We shouldn't have to go down the rabbit hole like this not everyone who uses DD-WRT wants to risk a serial connection especially when the router is under warrenty and the screws are under the sticker .....

Cyfer522586
Cyfer522586's picture
Shit i got  the same error,

Shit i got  the same error, this is a pain in the ass. I have tried everything and since 3 months now i've been fucking around that router to flash it with dd wrt. Does someone know a solution which is not too complicated??

mikeloeven
mikeloeven's picture
This needs to be resolved it

This needs to be resolved it cant be that hard to release a new initial flash packge with updated board id's and version numbers to match the genie's version check

mrdon213
mrdon213's picture
There are new Init files for

There are new Init files for Freshtomato that should work.

manicdefender
manicdefender's picture
Or you can flash a pre

Or you can flash a pre-patched version of OpenWRT which allows you to then use whatever firmware you wish to. A link to it is about half way down the page on the DD-WRT forums. Can confirm it worked on mine.

 

https://forum.dd-wrt.com/phpBB2/viewtopic.php?t=315110&postdays=0&postorder=asc&start=30

notestein
notestein's picture
Just got the router today and

Just got the router today and flashed it using this method.    But with some modifications...

 

1. Flash openwrt-bcm53xx-netgear-R8000-squashfs.chk in DD-WRT using Netgear web gui.
2. ssh into the router with
Code:
ssh root@192.168.1.1    
There is no password so you'll go right in.

3.  Plug a network cable from your existing router/cable modem/etc that provides DHCP address leases into the WAN port and use ifconfig to check until you see one of the ports pick up a DHCP address. You can do that with
Code:    
ifconfig    

4.  Assuming you get an IP and can get to the internet (
Code:    
ping 8.8.8.8    
from the ssh prompt will tell you) at this point we need to install and enable the web interface

Code:    
opkg update (had to keep rerunning to get all the packages down)
opkg install luci (had to keep rerunning to get the install complete)
/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable    
mv /etc/config/luci.bak /etc/config/luci (added by me)

5.  If that worked you can access the device with http://192.168.1.1
factory reset (added buy me)
http://192.168.1.1/start.htm (if you get the luci screen which I did)
http://192.168.1.1/index.asp (I had to explicitly add index.asp as the default was going to the Luci themed interface

6.  Go through the initial setup prompts and then flash your http://www.desipro.de/ddwrt/K3-AC-Arm/dd-wrt.K3_R8000.chk firmware. Power cycle the device and you should be able to access it via http://192.168.1.1 with DD-WRT working as expected.  Maybe should use the .bin

 

mikeloeven
mikeloeven's picture
LUCI failed to install with

LUCI failed to install with

/usr/lib/lua/luci/dispatcher.lua:247: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:247: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:144: in function </usr/lib/lua/luci/dispatcher.lua:143>

attempted a few fixes and ended up with a boot looping router. waiting on a serial cable to ship now any ideas whats going on here ?

mikeloeven
mikeloeven's picture
but THIS is exactly the

but THIS is exactly the reason kong needs to release a pached dd-wrt too many potential points of failure with a roundabout instalation method like this

Pages