Freeradius libssl version mismatch

4 posts / 0 new
Last post
Buggablah
Buggablah's picture
Freeradius libssl version mismatch

Hello,

I am attempting to use freeradius for wifi auth.  I have been unsuccessful, and when I attempted to run "radiusd -X" from the CLI to diagnose issues, I get this error:

"[email protected]-WRT:~# radiusd -X

libssl version mismatch.  Built with: 1000108f   Linked: 1000109f"

Since I am not able to start the radius daemon in diagnostic mode, I believe that the daemon is not even starting due to this error.  I went to the location of /var/log (as shown in the radius 2.conf file) to attempt to view the log file, and there was none.

Also, when I type "ps" from the CLI, there are no entries for radius, radiusd or freeradius.  Therefore, as far as I can tell freeradius is not running.

Running "Firmware: DD-WRT v24-sp2 (08/15/14) kongac"

Please help.  If I need to type anything into the CLI and post it here for help with diagnosis, please let me know.

Thank you very much for any assistance.

Kong
Kong's picture
It is fixed in upcoming 25000

It is fixed in upcoming 25000 build.

Buggablah
Buggablah's picture
Kong, you are awesome! Thank

Kong, you are awesome! Thank you!

edwinlee
edwinlee's picture
Hi Kong, I am using firmware

Hi Kong, I am using firmware version : DD-WRT v3.0-r27520M (07/17/15) kong on Netgear WNR3500L v2.

There is also libssl version mismatch for the freeradius.

libssl version mismatch.  built: 1000203f linked: 1000204f
 

Please help and much appreciated.