Howto put a modem in bridge mode from the command line?

1 post / 0 new
jrs
jrs's picture
Howto put a modem in bridge mode from the command line?

Since a few weeks I switched to a new ISP, VDSL from tele2 in the Netherlands. Cheap and much better speeds than my previous ADSL connection. So far so good.

My previous setup was a ADSL modem in bridge mode and a nice Netgear WNR3500L behind it for DHCP firewall and wireless.  Worked pretty nice.

Now I have a new modem from tele2 specially made for VDSL. It is a Comtrend CT-6373. From the menu in the browser there is no option to put it in bridge mode. It is in the manual that I found from the Comtrend website ( http://www.comtrend.com/dbase/download/CT6373_A1.0.pdf ), but it seems that tele2 has modified the firmware and ripped the bridge mode configuration screens out.

I tried using the tele2 modem, but it seems to crash sometimes on heavy load. Something I never experienced in the past. So I like to use my Netgear again...

For that I would like to switch the modem into bridge mode. It is possible to login in the modem from a shell over ssh. The shell gives me some options and I guess it should be possible to switch the modem to bridge mode this way. I just need to find out how. I have been googling a lot, but couldn't find any documentation on the comtrend shell. I found some guides about command line configuration of ADSL like this one http://uhd.no-ip.org/-=kintlevo=-/adsl_321b/Instruction_for_CLI(telnet)_dsl_321b.doc

Going through that guide I learned to play a little bit with the shell, but I couldn't figure out how to get the modem in bridge mode and I prefer not to screw things up.

typing a ?

gives me this list of available commands

?
help
logout
reboot
adsl
atm
ddns
dumpcfg
ping
sntp
sysinfo
tftp
voice
version
build
md5wpakey
vdsl
wlan
wan

The command sysinfo --help

shows that the modem is running:

BusyBox v1.00 (2010.07.07-12:13+0000) multi-call binary

and the command version shows
Board ID: CT6373-1
SW version: I431-M310TL2-C03_R06_0707

I am guessing this is a modified version of the firmware by tele2. I can't flash the router with other firmware, because there is no firmware available to customers. Comtrend seems to sell only to ISP's.

Maybe here someone knows how to put the modem in bridge mode from the shell? Any help would be appreciated.