"HTTP_WANPORT" is Invalid with Tomato

8 posts / 0 new
Last post
blackmacbook's picture
"HTTP_WANPORT" is Invalid with Tomato

I just upgraded my wgr614v8 with the tomato firmware posted from this website.  I believe it is the version 1.11.   I was able to flash the firmware sucessfully and setup to connect via pppoe att dsl.  The router was able to connect to the dsl modem and got an IP the ISP, but I'm unable to connect to the internet.  DHCP and Wirless are enabled in the wgr614.  When I'm in the administration page and try to change the password it will give me this "http_wanport" is invalid error.  I figure this could also be the cause why I'm unable to get internet.  My laptop is being assigned a correct ip, from the wgr614. 

 I also did a factory restore from the tomato menu.

How can I fix this??




FRiC's picture
For future reference, the

For future reference, the Tomato GUI expects to have values input into the fields, but some fields come with no values by default. HTTP_WANPORT must have a value (such as 8080), even if remote access is disabled.

But this should not have anything to do with inability to connect to the Internet.

SouvikGhosh's picture
Try pinging the router i.e.

Try pinging the router i.e. If it succeed try to ping any PC situated in the WAN side. Probably it will also succeed since you claimed that you have got an IP from ISP. Please check whether your DNS is working right or not.

Another thing, please configure the default gateway of you PC/Laptop as - the router IP.

jtinney's picture
A further note regarding the

A further note regarding the HTTP_WANPORT Error:

As FRiC pointed out, a value is required for this field. In my case, I did not want to enable remote access right now, I just wanted to change my password. Because I had not explored the remote access function, the field to input a port was not available to me. It only appears once you change it to HTTP or HTTPS. So, I changed it to HTTPS, put in 443 (I don't run any sites locally, so no conflicts for me). I changed the default password and hit save. Once that is done, I changed it back to Disable and hit save. This worked fine.

Hope that helps someone.

Also, as FRiC pointed out, this has no bearing on connectivity on the WAN port of the router, in my experience.

Psypher246's picture
hi, wrt to the no internet

hi, wrt to the no internet problem, which is a little more serious, there is another thread on it:

Please if anyone knows how to get the internet working I would really appreciate it.


ROY's picture
Can someone explain as to how

Can someone explain as to how the % in bandwidth add up to greater than 100% in tomato Qos basic setting page? Also, can the Qos be controlled via CLI using say busybox?

FRiC's picture
The % is maximum that a

The % is maximum that a particular class will use if no one else is doing anything, so it can add up to more than 100%.

ROY's picture
Thanks FRIC! However, let's

Thanks FRIC! However, let's say you have a scenario where you have all the classes, viz Highest to Class E. How will the % be allocated then? Even if you take the minimums, they add to greater than 100%. What happens then?

Also, how are the classes mapped to different traffics in the outbound and inbound?