ipkg or opkg ??

11 posts / 0 new
Last post
hellbound1988's picture
ipkg or opkg ??


        I have asus RT N-16 running kingkong 18050 build. I am having trouble installing optware. Which method should i use ipkg or opkg. Ipkg tutorial in ddwrt is obsolete and only supports kernel 2.4 i guess. well i want to install the optware from this feed which is fairly updated


how to proceed ? I tried installing



ipkg.conf shows these

src whiterussian http://downloads.openwrt.org/whiterussian/packages
src non-free http://downloads.openwrt.org/whiterussian/packages/non-free
src backports http://downloads.openwrt.org/backports/rc5
dest root /jffs
dest mmc /mmc
dest smbfs /tmp/smbshare
dest ram /tmp

I dont have jffs as i have a usb storage. Why it is still whiterussian ?

Or opkg will just do fine for me if someone please guide me what to do and how can i install opkg packages since there is no tutorial & i am a novice.

Kong & other gurus please respond..


hellbound1988's picture


drizi's picture
I'd also like an answer about

I'd also like an answer about this..

hellbound1988's picture
yeah i am quite surprised. No

yeah i am quite surprised. No one bother to answer any question. Is there something wrong with my question or the forum is dead ???

hellbound1988's picture
Thanks for the feedback i

Thanks for the feedback i have installed optware the rightway from the wiki. But the repository is outdated and i want to use opkg and install updated packages. Anybody got opkg working ??

hellbound1988's picture
when trying to use opkg: has

when trying to use opkg: has no valid architecture, ignoring
for all packages. I guess the source is the issue. Tried to alter it in /tmp/etc/opkg.conf but it is read-only file system. Is there a way to edit it ? Or is there a workaround ?

hellbound1988's picture
Thanks it seems to be working

Thanks it seems to be working now. But i am having some troubles installing packages. It all seems to be related with Kmod

Configuring kernel.
Configuring kmod-crc-ccitt.
/opt//jffs/lib/opkg/info/kmod-crc-ccitt.postinst: .: line 3: can't open '/etc/fu
Configuring kmod-ppp.
/opt//jffs/lib/opkg/info/kmod-ppp.postinst: .: line 3: can't open '/etc/function
Configuring kmod-pppoe.
/opt//jffs/lib/opkg/info/kmod-pppoe.postinst: .: line 3: can't open '/etc/functi
Configuring libwrap.
Configuring portmap.
Configuring libreadline.
Configuring ppp.
Configuring libncurses.
Configuring kmod-pppol2tp.
/opt//jffs/lib/opkg/info/kmod-pppol2tp.postinst: .: line 3: can't open '/etc/fun
Collected errors:
* pkg_run_script: package "kmod-crc-ccitt" postinst script returned status 2.
* opkg_configure: kmod-crc-ccitt.postinst returned 2.
* pkg_run_script: package "kmod-ppp" postinst script returned status 2.
* opkg_configure: kmod-ppp.postinst returned 2.
* pkg_run_script: package "kmod-pppoe" postinst script returned status 2.
* opkg_configure: kmod-pppoe.postinst returned 2.
* pkg_run_script: package "kmod-pppol2tp" postinst script returned status 2.
* opkg_configure: kmod-pppol2tp.postinst returned 2.

is there any workaround for this ?

sdddwrt's picture
having a similar issue. I

having a similar issue. I have 18010 and neither ipkg, opkg or ipkg-opt work for me. They all complain about /jffs directory.

Wabe, why should I enable JFFS? I am not using a usb thumb drive. I am using a hard drive connected over USB. Optware the right way says that you don't need to enable jffs for my case.

Hadji's picture
Opkg is only available for

Opkg is only available for Atheros SOC routers. The RT-N16 is a broadcom router so all pakages are architecturally incompatible.

hellbound1988's picture
well opkg supports both mips

well opkg supports both mips(atheros) and mipsel(broadcom) architectures. Many broadcom based routers supported by openwrt runs perfectly fine with opkg. Its the problem with dd-wrt kernel to insert those Kmods.

packages for broadcom based routers


waiting for full support from openwrt. Tracking the progress


unreg's picture

ipkg is broken in the current kong-mod release, an opkg doesn't work either, according to the "invalid architecture" bug.
But if you combine those two... you can get ipkg-opt working.

The common way of optware is to install ipkg-opt through ipkg (and for this you have to ENABLE jffs2 support, eaven if you have a usb drive).

To get Optware working you must:
1. Enable Jffs2 support
2.mount your USB-Drive as /opt
~ # mkdir /opt/jffs
~ # mount -o bind /opt/jffs /jffs
~ # mkdir /jffs/opt
~ # mount -o bind /opt /jffs/opt # ~ # mkdir /jffs/tmp
~ # mkdir /jffs/tmp/ipkg
~ # mkdir /opt/etc
~ # vi /opt/etc/ipkg.conf
3. Write this in /opt/etc/ipkg.conf:
src optware http://ipkg.nslu2-linux.org/feeds/optware/ddwrt/cross/stable
dest root /jffs
~ # export IPKG_CONF_DIR=/opt/etc
~ # export OPKG_CONF_DIR=/opt/etc # 5.
~ # ipkg update # ~ # opkg update # 6.
Somewhere in tmp/opkg.../lists/ should be a file called "optware".
Copy those file to /opt/lib/ipkg/lists/optware, and to /jffs/lib/ipkg/lists/optware
Note: you need to copy it just to one of these two directorys, but i dont know which one it was, so i mentioned both.
Follow the guide http://www.dd-wrt.com/wiki/index.php/Optware-ByHand , starting by "/bin/ipkg -d root install ipkg-opt"