NVRAM / EEPROM problem - router forgot LAN/WAN/WiFi MAC addresses

4 posts / 0 new
Last post
Synergist's picture
NVRAM / EEPROM problem - router forgot LAN/WAN/WiFi MAC addresses

Anybody have any advice? I've got a replacement router but don't want to end up bricking a second unit.

After using an R6400 flashed to AdvancedTomato 1.28.AT-ARM-3.5-140, it worked great for ~10 months. But after moving house, I reconfigured it for my new broadband with slightly modified settings: new wifi password, new wifi AP names, new LAN subnet range, small change of authentication settings and addition of the "router IP" for a bridged mode ADSL modem. I configured a DG834GT modem in bridge mode for ADSL2+, set to pass all traffic through to the R6400's WAN port and assign the connection's WAN IP to the WAN interface of the R6400.
Initially everything worked fine, until I went away one weekend - came back and it wasn't serving DHCP requests or letting any device on to the wifi (devices reported the password was incorrect).
Rebooted, restarted - noticed the R6400 started bootlooping. Powered off, restarted a few more times, tried a factory reset -- nothing worked.
Tried reflashing the same version of AdvancedTomato, and this is where it got interesting. I was also running Wireshark throughout, and I noticed that after this reinstall, the Netgear lost its interfaces' MAC addresses. Previously it reported a Netgear MAC (a0:04:60...) and afterwards, it would only report a placeholder 00:ff:ff:ff:ff:ff MAC for all interfaces.
I've seen this before on a motherboard whose NIC's EEPROM was faulty, and it reported all FF hex pairs. I had to replace the board to fix it as it's stored in a protected memory area.
I ended up flashing "back-to-genie" to get the router stock, then flashed Netgear Genie R6400-V1.0.0.26_1.0.14. However the MAC addresses are still lost, and various features in the stock firmware's initial setup routines (like the Test facility for a new internet connection!) are broken - the coding is apparently hardcoded to issue commands to the device using its Netgear MAC.
So is this similar failure of an R6400 a randomly unlucky EEPROM fault, or did Tomato somehow cause some gradual corruption which suddenly took hold after 'enough' changes were committed to memory?
Is erasing NVRAM after a flash not recommended with the Netgear R series routers?
If it's a known issue with these routers, is there a recommended method for restoring their MACs? They do ship with a MAC address printed on the label on their base; this matched the MAC as reported in my Wireshark cap until the device forgot who it was.
TXUSA's picture
Look here... I am beginning

Look here... I am beginning to think that there is some serious issue with the R6400s and erasing NVRAM.... seems this guy has the same issue



JPDrake's picture
I have the same exact problem

I have the same exact problem. I managed to flash stock using nmrpflash but the MAC address is still 00:FF:FF:FF:FF:FF. I tried changing the MAC addresses using telnet and nvram set but it did not work. Hopefully this can be resolved somehow.

JPDrake's picture
I should note that my router

I should note that my router functions completely normally, it's just that the nvram data (MAC address in my case and possibly some other things) is complete nonsense.