PS3 media streaming via miniDLNA doesn't work

9 posts / 0 new
Last post
ddusa
ddusa's picture
PS3 media streaming via miniDLNA doesn't work

Hi everybody,

This are my very first steps with dd-wrt and setting up the dlna service to stream media files with my PS3.

Unfortunately it doesn't work and I have no idea what could be the problem.

I am using DD-WRT Kong Mod build 16625M on Netgear WNR3500L.

My setup is as folows.

External HDD connected to my WNR3500L via USB.

File format is ext3.

The HDD is mounted on /mnt

Samba server is enabled and works proper. The file transfer rate seems to be more efficient with ext3 than with NTFS.

MiniDLNA is enabled.

Server name is "pool"

File path for pictues is "/mnt/pics/".

Update interval is blank.

DB path, I have no idea about that???

The PS3 doesn't find the media server. No matter hat I try.

Can anyone please check my setup and explain?

I am realy unfamiliar with all these stuff.

 

Best regards from Germany

Kong
Kong's picture
HI ddusa,

HI ddusa,

login into the router via telnet or ssh and run the following command:

ps

Do you see minidlna running e.g.:

/usr/sbin/minidlna -R -f /tmp/minidlna.conf

If not try to start it with the above command. If you have lots of files, then you should set the db path to something like:

/mnt/minidlna

Thus minidlna does not store the file db in ram, which causes problems if this file gets to big.

 

ddusa
ddusa's picture
I have tryed that.

I have tryed that.

MiniDLNA was not running so I started it by entering that command.

Now it works pretty good. Do you now the reason for that?

Movie streaming works very well without having any lags.

I will test with high definition content later.

Great mod you have build.

 

Many thanks!

Kong
Kong's picture
This can happen if the router

This can happen if the router thinks the drive needs a file check, if that happens the drive is still beeing checked at the time minidlna tries to start.

 

ddusa
ddusa's picture
Its a pitty.

Its a pitty.

when I swith off the HDD it seems like the router also quits all the dlna support.

I have to restart the dlna process in the command bar. Otherwise the media server is not visible the next time I switch on the HDD.

Is this a bug and possible to fix?

regards

ddusa

Kong
Kong's picture
For the upcoming release I

For the upcoming release I included minidlna startup in hotplug process, this should fix your problem as well as changing drives while the router is running.

 

ddusa
ddusa's picture
Kong,

Kong,

If there are a lot of media files on the storage, you recommend to create an db folder. I want to use the drive as a media server for music and movies therefore I use the minidlnadb folder.
I guess the problem with hotplugs is fixed in the 16830 build. What about the media scans after connecting the drive to the router?
I had a look to the data log file where I see that every time I disconnect the drive, all media files are read in again. Before that's not finished I dont see any file on the PS3.

limpysmalls
limpysmalls's picture
Been using Kong Mod for

Been using Kong Mod for awhile now. Used to have external HDD formatted to NTFS but found that HD Video would not stream without stuttering. Recently formatted Drive to ext3 and then moved all the files back on to it. it is mounted on jffs.

The problem is when I go in with my PS3 or WMP11 I get the same statement every time that their are no files on the drive but from Samba I can access them fine. I have the database for minidlna located on the drive at jffs/mindlna . I tried the above and got this response:

DD-WRT v24-sp2 std (c) 2011 NewMedia-NET GmbH
Release: 10/13/11 (SVN revision: 17670M)

DD-WRT login: root
Password:
Login incorrect
DD-WRT v24-sp2 std (c) 2011 NewMedia-NET GmbH
Release: 10/13/11 (SVN revision: 17670M)

DD-WRT login: root
Password:

#===========================================================#
# DD-WRT V24-K26 #
# Kong Mod #
#===========================================================#

BusyBox v1.13.4 (2011-10-13 18:02:49 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

root@DD-WRT:~# ps
PID USER VSZ STAT COMMAND
1 root 1236 S /sbin/init noinitrd
2 root 0 SW 3 root 0 SW 4 root 0 SW 5 root 0 SW 39 root 0 SW 41 root 0 SW 75 root 0 SW [pdflush]
76 root 0 SW [pdflush]
77 root 0 SW 78 root 0 SW 608 root 0 SW 641 root 1432 S watchdog
658 root 0 SW 715 root 0 SW 716 root 0 SW 812 root 1384 S resetbutton
913 root 1300 S telnetd
935 root 900 S dnsmasq --conf-file=/tmp/dnsmasq.conf
994 root 1308 S ttraff
1021 root 1468 S nas -P /tmp/nas.wl0lan.pid -H 34954 -l br0 -i eth1 -A
1310 root 1304 S process_monitor
1318 root 3464 S httpd -p 80
1340 root 768 S cron
1656 root 1384 S wland
1658 root 772 S udhcpc -i vlan2 -p /var/run/udhcpc.pid -s /tmp/udhcpc
1672 root 0 SW 29805 root 1552 S proftpd: (accepting connections)
29852 root 6424 S /usr/sbin/minidlna -f /tmp/minidlna.conf
29855 root 1896 S /usr/sbin/nmbd -D --configfile=/tmp/smb.conf
29857 root 5224 S /usr/sbin/smbd -D --configfile=/tmp/smb.conf
29859 root 6424 S /usr/sbin/minidlna -f /tmp/minidlna.conf
29860 root 6424 S N /usr/sbin/minidlna -f /tmp/minidlna.conf
31281 root 5348 R /usr/sbin/smbd -D --configfile=/tmp/smb.conf
31468 root 1316 S -sh
31478 root 1300 R ps
root@DD-WRT:~# /usr/sbin/minidlna -R -f /tmp/minidlna.conf
Media directory not accessible! [/Music]
Media directory not accessible! [/Pictures]
Media directory not accessible! [/Videos]
root@DD-WRT:~#

Why can I not get in? I checked the database log and it never builds the database past the outer folders? I also gave it a full day to build the database before trying to access it.

I am a Linux idiot so that may be the problem.

Kong
Kong's picture
Just checkout: http://tips