R7000 NTP does not work

5 posts / 0 new
Last post
jgrodrigueza
jgrodrigueza's picture
R7000 NTP does not work

Hello.  I decided to flash my r7000 router with Kong because I was having issues with NTP with Netgear's default firmware (I read in several forums that DD-WRT would fix that as Netgear has issues in their firmware with NTP).  Just to feed my frustration, with Kong, NTP does not work either.  If I go to Router Status tab I just see "Current Time: Not available".  If I create a file in the shared disk, the timestamps is set to 1970 (probably set to the start of Unix time as it cannot sync NTP).

I have tried several recommendations found in other threads: disabled DNSCrypt, left default NTP, set NTP server with static IP.  Nothing has worked.  I used a tool to query the NTP servers I tried and I confirmed they are working.

To discard that there was something in my network configuration or ISP blocking the NTP, I connected an old router that I had and set the NTP servers to the ones I tried in the r7000 and that one synchronized NTP perfectly.  Also, my computers are able to sync NTP if I use the same servers I tried in the r7000.

Has anyone had all this issues with NTP in both Netgear's firmware and Kong?

Thanks in advance.

jgrodrigueza
jgrodrigueza's picture
I decided to go back to stock

I decided to go back to stock firmware.  At least it sends me back to 2015 and not 1970 as Kong does.

tiweh
tiweh's picture
The issue is not a Netgear or
The issue is not a Netgear or Kong issue. Probably a device issue. If you router is located in the U.S. th following servers should work fine. Make sure The time zone is also be set. (Have always worked with my r7000 setup):
server 0.us.pool.ntp.org
server 1.us.pool.ntp.org
server 2.us.pool.ntp.org
server 3.us.pool.ntp.org

 

 

 

 

ilneill
ilneill's picture
I have just upgraded my R7000

I have just upgraded my r7000 to this version of the Kong DD-WRT firmware "DD-WRT v3.0-r32170M kongac (06/11/17)".

I have found that the NTP is working fine, and my box has the correct time. I have correctly set my time zone and simply used the Server name "pool.ntp.org".

Kind regards,

Ian

WA2HIP
WA2HIP's picture
I created a "work around"

I created a "work around" here.

 

I am running a program called "NetTime" on my computers.

 

1) set one of the computers NetTime program on the LAN to "allow other computers to sync to this computer"

2) pointed the router's time server to the LAN computer.

 

Works well until I can find a better solution