ReadyShare loses connection to attached hard drive

5 posts / 0 new
Last post
pmars's picture
ReadyShare loses connection to attached hard drive

I am running the most up to date netgear firmware on my R6400 v1 (I assume v1 since it doesn't list any version at all)

I have ReadyShare Enabled and setup with an external Hard Drive attached thru USB 3.0 front port. It works for a while but drops connection. Only way to re-establish connection is to disconnect hard drive at USB port and then reconnect. Been doing this for a few months and I'm ready to scream!! Very annoying. Basically useless. And trying to follow NetGear instructions for Access from anywhere is a complete joke. Makes no sense, cannot get it to work at all.

I am looking for advice/recommendation as to which version of DD-WRT to use for my R6400 v1 router and whether this will be a better alternative than ReadyShare.

Only other option is to buy a Synology DS216+II which is really costly!!

Thanks for any input

pmars's picture
Still hoping for an answer

Still hoping for an answer regarding better firmware for my R6400. The stock netgear firmware is still causing major problems with network attached hard drive. Is this a problem with the overall design of the router or the stock firmware? Anyone have any input ? Thanks

slash2604's picture
How do I enable ready share

How do I enable ready share on my R8500  running DD-WRT V3.0-r32170M Kongac (06/11/17), I cant connect to my 3TB seagate USB3.0 drive

Whity1967's picture
Hi pmars, talking about my

Hi pmars, talking about my experience(pain in the ass) with was was running well(2TB WD attached to front USB 3.0) when decided to update from web interface to a new suggested FW release two weeks ago and....after that flash my READYSHARE object was still visible in my LAN but inaccessible from any devices in the LAN....only from the web interface on Readycloud I was able to see the disk but considering that few minutes before the flash I was using the disk for various cronology backups of some PCs and it was my "film streaming box" for the entire LAN....I was very sick and tired!!!

So, after I've tried any personal solutions and any suggestion found on internet without success, I' ve decided to test the router with Tomato FW.
The interface is very very complete but hard to undesrtand for normal people but at the end, looking for some suggestion around internet, I've found a config as Access Point connected to my Telcom router(the one given me from my provider...a mess!) and more or less always was running well except the WiFi efficency, very slow compared to the original FW....not acceptable! Thi sis my brief experience with Tomato FW: very complete but complex for normal people, many settings and options to share hard disk in the network but a WiFi section that doesn't worked for SmartTV with the original Netgear FW was connected with the 5Ghz and run at 47Mbit with Netflix, with Tomato FW was connected at 3,6Mbit...most probably my fault but didn't found a solution :-/
The fastest way to return to have a good WiFi speed have been re-flash the original Netgear FW and restore the config backup I've made before my tests and.... suddenly the READYSHARE has been accesible from everyware imn the LAN!!!
I any case I decided to talk you about my Toamato experioence just as exampleif you are interested but most probably the solution to my READYSHARE problem the original FW....or at leat could be! ;-)

pmars's picture
Thanks for the update about

Thanks for the update about your experience. I am still having problems with ReadyShare losing connection to my network hard drive. It's been 2 more years and several FW updates later and still it drops out almost once a day. Only solution is to unplug from front USB port and start over. Unbelieveable to me that paid employees of a large corporation like NetGear can't do their jobs. These Bozo's should be able to find a solution like maybe add code that causes the router to check it's connection with the ReadyShare Drive a couple times per hour and re-establish or refresh or whatever. Why should I have to unplug the drive? They should be able to do that with software!!!