5 posts / 0 new
Last post
JFox's picture

Hi Kong / community! 

Just purchased the R7000.  Previously ran an older Linksys WRT54G v4, with DD-WRT.  What a nice upgrade, this thing is fast!  I have configured 5GHZ, N clients are connecting at 300Mbps, things are looking pretty good. 

One issue I'm having is the speed of the GUI.  Having worked with DD-WRT for years now, the performance is far worse on the R7000 with it's 1GHZ dual cores than on my old WRT54G.  I didn't see anyone else comment on that, maybe I haven't configued something correctly.  Every tab or button I client in the GUI takes 10 or more seconds to return/refresh/update.  I'm using Firefox - tried on both windows and Linux, and also tried IE on windows.  All are very slow.  

Anyway, keep up the great work, let me know if there is something I should try. 



Kong's picture
Did you try accessing webif

Did you try accessing webif with a different pc? There is definitely something wrong webif should be really fast on the dual arms and on mine I'd say it takes

JFox's picture
Thank you for the reply!

Thank you for the reply! Same issue on all PC's I try. I can get in via telnet, and I see the router is 99% idle. Tried to kill/restart the web interface by running top, killing the httpd process, then starting it again with: "httpd -h /www". Nothing works, the web UI is so slow...What could it be, is there logging I can review? I'm pointing my browser to, basic stuff. It was slow the the second I flashed the firmware.

JFox's picture
I fixed it. I turned on the

I fixed it. I turned on the syslog, and started to monitor the output of /tmp/var/log/messages by tailing it in telnet. I saw a lot of error messages that looked like this:

Apr 2 22:19:18 DD-WRT syslog: httpd login failure - bad passwd !

So, I reset my password to a different password, and clicking tabs is lightning fast now. Thanks for letting me know it should be faster, and making me think about this. (No idea why the password was off, but it's working now).

xDDWRTx's picture
Thanks for the above

Thanks for the above suggestion. I had the same slow GUI speeds. I changed the password too just to see if it would solve the problem and it did!