[SOLVED] TomatoUSB Shibby - Firmware-mod-kit

2 posts / 0 new
Last post
adrienb4's picture
[SOLVED] TomatoUSB Shibby - Firmware-mod-kit


I have a problem with Tomato Shibby and Firmware-mod-kit. When I build my firmware from sources, everything is ok. But when I run firmware-mod-kit for add my own scripts, the router doesn't start. I have this error : 

Scanning device for bad blocks


Bad eraseblock 524 at 0x000004180000
Creating 2 MTD partitions on "brcmnand":
0x000002000000-0x000008000000 : "brcmnand"
0x000004000000-0x000006000000 : "jffs2"
SQUASHFS error: Unable to read inode 0x190015b1
VFS: Cannot open root device "mtdblock3" or unknown-block(31,3)
Please append a correct "root=" boot option; here are the available partitions:
1f00             512 mtdblock0 (driver?)
1f01            1536 mtdblock1 (driver?)
1f02           30720 mtdblock2 (driver?)
1f03           29030 mtdblock3 (driver?)
1f04           98304 mtdblock4 (driver?)
1f05           32768 mtdblock5 (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(31,3)
[] (unwind_backtrace+0x0/0xf8) from [] (panic+0x74/0x1a0)
[] (panic+0x74/0x1a0) from [] (mount_block_root+0x1d4/0x298)
[] (mount_block_root+0x1d4/0x298) from [] (prepare_namespace+0x168/0x1cc)
[] (prepare_namespace+0x168/0x1cc) from [] (kernel_init+0x1c8/0x218)
[] (kernel_init+0x1c8/0x218) from [] (kernel_thread_exit+0x0/0x8)
CPU0: stopping
[] (unwind_backtrace+0x0/0xf8) from [] (do_IPI+0x114/0x154)
[] (do_IPI+0x114/0x154) from [] (__irq_svc+0x48/0xe8)
Exception stack(0xc03d3f78 to 0xc03d3fc0)
3f60:                                                       00000003 cf96aa00
3f80: c03d3fc0 00000000 c03d2000 c03f60a8 c03deb80 c03deb78 00026658 413fc090
3fa0: 0000001f 00000000 00000000 c03d3fc0 c003ebe4 c003ebe8 60000013 ffffffff
[] (__irq_svc+0x48/0xe8) from [] (default_idle+0x24/0x28)
[] (default_idle+0x24/0x28) from [] (cpu_idle+0x70/0xa4)
[] (cpu_idle+0x70/0xa4) from [] (start_kernel+0x338/0x394)
[] (start_kernel+0x338/0x394) from [<00008084>] (0x8084)
Rebooting in 3 seconds..


It's verry hard for me to find a solution for this error. 

Can you help me for fix it ?





adrienb4's picture
I found the solution here :

I found the solution here :


The "image size" in TRX header was wrong after modify by modkit. Juste change it with "hexeditor".