Switch from Lede to Voxel?

7 posts / 0 new
Last post
MrChris
MrChris's picture
Switch from Lede to Voxel?

Hello to the forum, 

I just purchased a new Netgear R7800 to replace my old WNDR3700v4. On my WNDR3700v4 I ran OpenWRT v17.01.4 for a few years and loved it for the most part (minus a few things). First thing I did when I installed my new R7800 was flash Lede v17.01.4 on it. Lede runs ok minus a few things like, ever few days I have to reboot it becuase wifi and ethernet lock up or something and it the whole damn device starts acting all wonky/flaky. I just found out about Voxels Firmware a few days ago while reading up on the R7800. Id like to try out Voxels firmware and see how it runs.

One of my main interests is to run OpenVPN Client/Server and a few other 3rd party binaries as daemons at boot such as (ZeroTier) and a few others small ones.

My question(s) is,

Since my R7800 is currently running Lede v17.01.4. What all do I need to do in order to switch from Lede v17.01.4 to Voxels firmware? Can I use the Luci WebUI like a normal firmware flash/update?

Thanks in advance

~MC

kamoj
kamoj's picture
Voxel FW is handled exactly

Voxel FW is handled exactly the same way as Netgear stock FW.

There is a fool-proof way:
https://forum.lede-project.org/t/netgear-r7800-exploration-ipq8065-qca9984/285/5

Example:

Install Windows 10 TFTP:
 
Then you have to do this with the router:
- power off
- press and hold a pin in the reset hole
- power on
- wait for power LED to stop flashing amber and start flashing white
- Release reset button
- Wait a little, the router is now in tftp-mode!
 
C:\>tftp -i 192.168.1.1 PUT C:\R7800-V1.0.2.53SF-KF.img
 
Transfer successful: X bytes in 9 second(s), 2700643 bytes/s
 
 

 

MrChris
MrChris's picture
Thank you very much for the

Thank you very much for the detailed steps. I will try here in a few.

Thanks again.

~MC

MrChris
MrChris's picture
Everything worked out when I

Everything worked out when I followed your steps. Now I'm running Voxels build. Thanks again for the help.

kamoj
kamoj's picture
Thank you for the feedback,

Thank you for the feedback, and I hope the Voxel FW will be to your satisfaction!

You can install Entware and get much functionality out from it that way.

E.g. ZeroTier can be found here:
http://www.voxel-firmware.com/Downloads/Voxel/html/entware.html

Good Luck, and please share your results!

MrChris
MrChris's picture
Wasnt sure if I should start

Wasnt sure if I should start a new thread or not. But I have found an issue thats a bit frustrating atm. Doesnt looks like its an issue so much with Voxels firmware but rather the Stock Firmware in as it is from netgear maybe.

Whenever I have Remote Managment Enabled I can not port forward https / TCP 443 to my local web server (debian 9.x running apache). Even though on the Remote Managment page it is set to 8443. I did a quick google search and found what looks like the same somewhat recent post on the netgear forums.

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7800-Issue-with-Remote-Management-and-Port-Forwarding/td-p/1539770

Im hoping there is a workaround other than disableing remote managment or changing my Web Servers https port as I do a lot of Reverse Proxing via URLs and I like that I can monitor/manage my router from my Android Phone when not on the LAN.

~MC
 

hipek_pl
hipek_pl's picture
I have never used remote

I have never used remote management option as I have never trusted such solutions...

On my previous router (tplink wr1043nd) with DDWRT I have used OpenVPN for accessing LAN and router managment, etc.

Now I'm on the R7800 with Voxel firmware and still using OpenVPN to access LAN and router and have to say that is working very well...

Unfortuneltelly Android applications from Netgear does not regognize you are using VPN and asking to enable WIFI to access router ;) but anyway you can manage router from web browser...

Zircon - This is a contributing Drupal Theme
Design by WeebPal.