Tomato and HFS+

9 posts / 0 new
Last post
getotek
getotek's picture
Tomato and HFS+

Just upgraded from dd-wrt to tomato last night everything went smooth.  Just had a general question about tomato. Is there anyone who knows of a way to get the router to mount a HFS+ formatted hard drive?

flashed
flashed's picture
Hi, in the file extras-K26

Hi, in the file extras-K26-MIPSR2.tar.gz there is "hfsplus.ko".
Good luck!

getotek
getotek's picture
So I have to flash my router

So I have to flash my router again? Do we have instructions on how to add extras like hfs? If No I'm willing to document me doing adding the feature if some has good instructions.

flashed
flashed's picture
 

 

getotek said: So I have to flash my router again? Do we have instructions on how to add extras like hfs? If No I'm willing to document me doing adding the feature if some has good instructions.

--- disclaimer: I am completely new to this. There is for sure a much better way to do it ---

 

Enable ssh in Administration/Admin access.

Download extras-K26-MIPSR2.tar.gz and extract the file hfsplus.ko to /tmp of your PC

From your PC,

$ scp /tmp/hfsplus.ko  root@192.168.1.1:

( if you are in Windows, use WinSCP)

then

$ ssh root@192.168.1.1

(if you are in windows, use Putty)

Once logged into you router,

# insmod ./hfsplus.ko

A manual "mount" command should then mount your HDD. I hope it is a good starting point.

All the settings above will not survive the reboot.

Striatum
Striatum's picture
If you have an USB disk you

If you have an USB disk you can put the *.ko files on it and add the insmod command in the Administration>Scripts>Init section (with correct path to file).

You can probably use nvram setfile2nvram to add permanently the file in nvram and unse insmod command as above (you have to locate file in nvram to set the right path).

getotek
getotek's picture
I was able to get it to work

I was able to get it to work but like flashed said it didn't survive the reboot.
the setfile2nvram stated the file was to big

Striatum
Striatum's picture
If your USB disk is always

If your USB disk is always connected, inserting the insmod command in the Administration>Scripts>Init should do it. Perhaps you could try to do:

sleep 30
insmod *.ko

If the insmod command is executed before the disk mount it can't work. Yould should look into logs after a reboot to have an idea of delay before disks are mounted.

flashed
flashed's picture
I don't get it. The disk is

I don't get it. The disk is formatted with HFS+ filesystem, how can the kernel read the hfsplus.ko file ? Isn't this a chicken and egg issue ?

Could a workaround be to partition the disk with two partitions. The first a very small partition in vfat format, where you put the "important" files i.e. hfsplus.ko. Then, the second partition is big and formatted in HFS+.

Striatum
Striatum's picture
Yes I see...I should have

Yes I see...I should have understood that your disk was the problem.

Then only solution is to reduce your HFS+ partition and to have a vfat partition only for this purpose.

http://www.macupdate.com/info.php/id/15360/ipartition ?

You can grab Gparted Live CD:

http://sourceforge.net/projects/gparted/files/gparted-live-stable/
(http://gparted.sourceforge.net/livecd.php for instructions)
Burn it on a CD, reboot, and you've got a good partitioning tool, it can reduce HFS+ partition, and create/manage vfat for example..