Unable to display page when tempting to flash Kong

5 posts / 0 new
Last post
drivel2787's picture
Unable to display page when tempting to flash Kong

Hi gents, I have recently attempted to flash the kong dd-wrt firmware and upon doing so I immediately get unable to display the webpage after flashing the initial .chk file.  Any idea why?

Subhra's picture
Have you perfomed factory

Have you perfomed factory reset after firmware switching ?? Have you properly followed the intructions ??

drivel2787's picture
Yes, I did. This isn't the

Yes, I did. This isn't the first time I've flashed a DD-WRT based firmware. I ended up having to use firefox instead of IE and try a couple times and it finally flashed. I ended up flashing back to stock because WI-FI was not stable at all. Kong said it was due to needing the broadcom firmware drivers updated. So maybe I'll try again down the road eventually. Kind of hoping they bring out Tomato firmware for the R7000 as well.

Accid's picture
Why do I only get blank pages

Why do I only get blank pages when I try to change a setting in the web interface and hit apply?

  • If you have just updated the firmware, you probably need to reset the router! See Hard reset or 30/30/30 and Reset And Reboot.
  • Sometimes the address bar shows http://routerip/apply.cgi, and no content displays. Simply wait a few seconds for the router to make the change take, and go back to the page you were on with by using browser history. Some changes also requiring waiting for several seconds while the router implements them.
  • Clear out your web browser's cache and/or try another browser.
  • This is really odd, but try turning off your firewall temporarily while you're updating the pages. A friend of mine and I were experiencing this and we disabled Symantec Firewall temporarily and it allowed us to complete the configuration. I've also seen document on the web where others have had this problem with ZoneAlarm. I'm not sure of the mechanism where the firewall is interfering with the web page content, but somehow it is.
  • This could also be a result of incompatibilities with Firefox. Try switching to an alternative browser (e.g. Internet Explorer or Konqueror) for the WebUI Management.
  • If you're on a Mac, try getting Chromium (i.e. Google Chrome for Mac). Safari and FireFox may not work at times, however Chromium worked for all my needs (including reliable firmware upgrade via web interface).

Taken from


drivel2787's picture
The problem seems to be the

The problem seems to be the browser. Make sure that you clear the cache in whatever browser your using prior to flashing the firmware. I had this same problem and that worked for me. I believe I ended up using IE, just had to do this before clearing the cache. I switched back from Kong's build because WI-FI wasn't stable enough for me. If you end up doing that, I also ran into that when resetting to stock firmware, I couldn't access the WebGUI, everyone recommended doing a reset (holding reset button 5-8 seconds upon boot) that didn't work for me. I actually had to telnet to the router and clear nvram, then reboot, and I was able to then access the WEBGUI with the default username and password. Just a heads up...