Unable to flash r6400v2

7 posts / 0 new
Last post
savnetgear
savnetgear's picture
Unable to flash r6400v2

Hello,

I have attempted to flash both Tathagata's build and Kong's build on the r6400v2 and each time it just comes back with a firmware incompatible error message. Can someone shed some light on this for me? Do I need to change the chk extension to bin and re-flash or is there an initial flash file I need to use first (and where can I get it)?  Any thoughts would be appreciated!  I have flashed several other router models to DD-WRT with no issues but can't get this one to click.

savnetgear
savnetgear's picture
Got it!!    The 8th time is a

Got it!!    The 8th time is a charm. I started over and re-downloaded all of the files, re-unzipped everything and Tathagata's build worked!  Re-reading Kong's build, I don't think it is compatible - it is under the heading of 6400/6400v2 but may be just for 6400v1. So...  if Tathagata's is the only build in the universe that works on the r6400v2 I want to shout a big thank you to him!  Got my VPN via DD-WRT up and running.

LFast
LFast's picture
Hey thanks for heads up about

Hey thanks for heads up about using Tathagata's build and it work. Thanks again

navelpluiz
navelpluiz's picture
Hi savnetgear.

Hi savnetgear.

i want to flash my R6400v2 for the first time, can you please share the steps you took with me ? 

 

I have downloaded  K3_R6400v2_18-Aug-2017.chk. Or should i use the older one K3_R6400v2_25-May-2017.chk  ?

my plan was the following but please coorect me I am wrong :

-  flash with the stock firmware  to be certain  it is in place ( but did this already couple of days ago)

- Put setings to factory default thru Genie  webGUI. ( with telnet or ssh is not possible but guess that is normal wiyh original firmware)

Then I am little confused about where ( my guess was : ftp://ftp.dd-wrt.com/betas/  ) and which  stock-to-dd-wrt /webflash to use. ( or is this not  needed).There is no netgear-R6400v2 folder  to be found .

Already thank  for even reading ,

 

Greetz NavelP.

 

OS: Main: Debian 9 , but like to play arround with all kinds of linux flavours on diff partitions.
NetGear R6400v2 -V1.0.2.52_1.0.39
Compal CH7465LG-ZG (Ziggo Connect Box)

savnetgear
savnetgear's picture
I am no expert so this is all

I am no expert so this is all at your own risk. I am running the Tathagata 25-May version and it was pretty straight forward when I actually used the correct build. So you really just want to have the stock firmware on your router set to default settings before doing this. Download and unzip the R6400v2 build from this site (downloads link) - NOT the DD-WRT.com ftp site. Make sure it is the 6400v2 version. Unzip and this will render the chk file that you will use. It is a good idea to have the netgear firmware downloaded and unzipped as well in case you need to re-flash it. Anyway, once you have the build you want, just follow the helpful links on the left of this page (how to flash DD-WRT). It is really just a matter of finding the correct place on the admin page in the stock firmware and then pointing to the chk file that you downloaded. If you can leave it on your desktop, it will be easier to find.

Hope this helps. 

navelpluiz
navelpluiz's picture
Thankz for the reply

Thankz for the reply savenetgear.  And of course even if U where a  expert , the risk is never for the messenger.. Can you please post the links again? they are not showing up to m.

FYI:  I am trying to get/help KONG  involved in releasing "proper"ly tested" build :    https://www.dd-wrt.com/phpBB2/viewtopic.php?t=312828

Thankz again,

Navel.

OS: Main: Debian 9 , but like to play arround with all kinds of linux flavours on diff partitions.
NetGear R6400v2 -V1.0.2.52_1.0.39
Compal CH7465LG-ZG (Ziggo Connect Box)

TXUSA
TXUSA's picture
You can absolutely flash Kong

You can absolutely flash Kong's R6400.chk on a R6400v2. It works nicely. The only problem with the build is that it has not been properly formatted to be accepted by the Netgear firmware. It is rather unusual for a Kong build. The workaround is to flash Tathagata's build first and then flash the Kong build on top of it (I also posted a "how-to" elsewhere in the forum. I can confirm that it works, I am using it myself.