WAN speed seriously crippled on R7000

8 posts / 0 new
Last post
shinyidol's picture
WAN speed seriously crippled on R7000

Recently moved to 1gb service from my provider, but my R7000 running either DD-WRT or Advanced Tomato appears to be a huge bottleneck. I did some tests and getting around 300Mbps when running on the R7000 versus 800Mbps when connected directly to my cable modem. I decided to try out a TP-Link AC3200 (which I'm probably going to return as it doesn't support OpenVPN) and was getting 750Mbps. So it is clear that the R7000 is doing something.

R7000/Direct Router/AC3200




Any ideas what could be going on?

Camdogrs's picture
Having this same issue with

Having this same issue with my R7500V2.  Get 900 Mbps up and down on the verizon router but soon as I go to the Nighthawk best I can get is 150 down and 930 up.

bcornett3's picture
Same here.  I have 1Gb

Same here.  I have 1Gb service, but I'm getting about 350 up/down.  If I bypass the R7000, I get around 950 up/down.

dreamdenizen's picture
You need to enable Cut

You need to enable Cut Through Forwarding. The CPU in the R7000 is only powerful enough to provide around 350-400mbps without it enabled.

Havoc's picture
And even then it only works

And even then it only works with original firmware or Shibby Tomato. Additionally, if you enable any of the 'extra features' like VPN, traffic monitoring etc you loose the high WAN speed also.


Apparrently, this has all to do with network card drivers Broadcom isn't making available, thus more or less forcing non-Netgear firmware to revert to standard drivers for the NIC, making only 100 M/b possible (at least, that's what I took from all the reading from endless forums). Really a pitty, as I also am facing low capacity internet traffic: having the possibility to download at 300 m/b, I am currently stuck with a couple of m/b due to VPN being enabled.

Thinking Ubiquiti UFS would be a good solution to replace my R7000 - anyone suggetions on that one?

samgab's picture
Ditto this. I have an R7000

Ditto this. I have an R7000 and recently upgraded to Gigabit Fibre. I was on the Factory R7000 Firmware, and was getting a max of 200 Mbps. I was complaining to my ISP about their slow internet speeds when it was supposed to be Gigabit speeds, and I checked the NIC and the ONT etc, and everything was connected at Gigabit, but still only 160-200 Mbps up or down. Then I tried Advanced Tomato, and immediately got over 300. Then I tried DD-WRT, and got about 400 up and down. So that identified the cause of the bottleneck. It's the R7000. I'm pretty sure if I get a newer, better router I'll be getting much closer to the 900Mb-1Gb. Pretty disappointing.

ror666's picture
I use Brainslayer built 41027

I use Brainslayer built 41027 for the T7000 and have 500 MB wan speed (and 50MB up)  and thats the max of my ISP. The latest Kong built didnt work for m and I only had max 250 MB download speeds. No clue if the R7000 has 1GB actual download speed as my ISP (cable) isnt there yet with those speeds. Anyways For me the Brainslayer built works fine. Perhaps an idea to test with that.

ror666's picture
Typo T7000 = R7000

Typo T7000 = R7000