WNR3500L periodically losing connection with internet

4 posts / 0 new
Last post
Redibo's picture
WNR3500L periodically losing connection with internet


I'm new, and now quite frustrated user to this forum. I've tried googling and solving this issue by the tips I found on various forums but nothing has really helped. I own a WNR3500L that I bought just before christmas. I set it up and everything worked fine, I then left the apartment and it for a trip to my family. I connected to my FTP and RDC now and then to check how things were going, and this worked well for about two weeks, then it suddenly stopped working. When I got back two weeks after that, I found that both my computers got the message "Limited or no access to internet" in Windows. I rebooted the router, and it worked fine for a few days, but after that I got the same problem every day.

Basically, what happens is that everything works fine, everything is smooth, fast, stable, you name it, even during quite heavy load, I'm on 100/100 and use it quite much at times. However, typically somewhere between 23:30-01:30,  all computers connected to the router looses the ability to connect to internet. I still reach all other computers and the router, basically everyhing within the LAN, but nothing outside. Can't ping DNS-servers, nothing. This sometimes occur between 09:00-11:00 as well, but not as frequently. So, what I've tried so far is the following:


Changed from standard Netgear firmware to DD-WRT and yesterday Tomato in one last desperate attempt, nothing helped, the same behaviour.

Added exceptions in the firewall to make sure that the router gets a new lease from the ISP every 6:th hour (12 hour lease time). Didn't help, diasble the firewall didn't help, and these problems might occour with anywhere between  12 and 6 hours left of the lease time.

Disabled the wireless network. No difference.

Deattached my FTP/Torrent-server. No difference.

Changed to level 3 DNS, as well as a few others, among else OpenDNS and GoogleDNS. No difference.

Set static IP and DNS for wired computers and disabled wireless. No difference.

Monitored the RAM and CPU using when the problems occoured.

Updated the drivers for the network cards in all computers, even tried a different network card in the FTP-server, no difference what so ever.

Tried logging using DD-WRT, but couldn't find any patterns, no strange results that I could see, it just suddenly stopped.

The only thing that works: Reboot, detach the cable from my "modem" (a "mediabox" from the fiber company), doing a manual DHCP renew in the router interface. Then it will work for about 24 hours or less before it does the same thing again.


So, any clues? I would be very grateful! Or should I just try to return it to the shop I bought it from and get another one?

With best regards

Peter Redmer
Peter Redmer's picture
Hi Christoffer--this is not a

Hi Christoffer--this is not a common problem with the WNR3500L to my knowledge. Considering you see the exact same behavior in the stock FW as well as third party FW, I'd try getting an RMA/replacement to see if that helps. If not, it could be a problem with your ISP, but that seems unlikely.

Try getting a replacement and let the community know if that helps!

lurky's picture
I havehad three now with this

I havehad three now with this exact same problem. I think there are duds from factory. My friend bought the same router from futureshop in canada the same day i did. his worked fine from the start, like i said i have had three duds... sigh.


And for the record....a quick google search shows many people with this problem and a few deleted threads at netgear.

AbYe's picture
I have been having the same

I have been having the same issue. I see the same issue posted on several forums. Internet connectivity just dies, I don't have to restart anything else just the WNR3500L router ... it does take longer now than it did previously to come back up ...

This now happens almost daily without fail. I have to power down (disconnect) and reconnect after a 20 sec countdown to get it to work. Strange!

So has anyone found a solution yet?