Would like to reflash factory firmware, but telnet does not respond

11 posts / 0 new
Last post
naphta
naphta's picture
Would like to reflash factory firmware, but telnet does not respond

Hi there

I made a stupid thing about two weeks ago. I had a fine running WNR3500L on Tomato and decided to play around a little bit. I then flashed accidentally a version of DD-WRT by Chlillifire. This runs, but is far from what I want. And: I cannot flash another firmware anymore! It runs through the steps very quickly and then in the end, nothing has changed.

Then I wanted to try this: http://www.myopenrouter.com/article/16099/How-To-Reflash-Factory-Firmwar... - but my damn router refuses the Telnet-connection. SSH works fine on the other hand. Could I "erase linux" by using SSH and continue with the tftp stuff normally? I thought I ask before I brick it completely...

Regards,

Naphta

Subhra
Subhra's picture
Yes, you can continue the

Yes, you can continue the steps by logging through ssh.
But first make sure if the process "How To Reflash Factory Firmware on the NETGEAR WRN3500L Without A Serial Cable" can be performed on the firmware you have loaded in your router or not. If not then there is possibility of bricking your router.

naphta
naphta's picture
seems that my WNR3500Lv1 is

seems that my WNR3500Lv1 is already bricked. Can't access it via TELNET, can't erase the linux via SSH and can't flash a firmware via webinterface :-(

Here what's happend in SSH:

login as: root
root@192.168.12.1's password:

BusyBox v1.11.2 (2010-11-17 12:19:18 NZDT) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
KAMIKAZE (8.09.2, r18961) -------------------------
* 10 oz Vodka Shake well with ice and strain
* 10 oz Triple sec mixture into 10 shot glasses.
* 10 oz lime juice Salute!
---------------------------------------------------
root@Router00904090001:~# erase linux
-ash: erase: not found

Built-in commands:
-------------------
. : [ [[ alias bg break cd chdir command continue echo eval exec
exit export false fg getopts hash help jobs kill let local printf
pwd read readonly return set shift source test times trap true
type ulimit umask unalias unset wait

Any ideas?

naphta
naphta's picture
As it seems that I'll need a

As it seems that I'll need a USB-TTL-Cable, I browsed through the stores and I'm surprised by the prices. Knowing probably too little, but gessing from the name, the TTL-232R-3V3 should be a cable that makes a RS-232 communication via USB. Is there any way to make this work with an ordinary serial cable? I have one of these and a serial connector as well...

buddee
buddee's picture
Your router is not bricked,

Your router is not bricked, its running openwrt. You should try to TFTP a working dd-wrt .chk file for a WNR3500L. What you will need to do is set a hardware switch in-between the pc and router, then set a static ip of say 192.168.1.8

Open up a command prompt and begin pinging the router, keep it open pinging it actively, then power off the router and power back on, when you power it back on you'll only have a split moment to catch the TFTP window, the ping prompt should let you know when it begins to respond, as soon as you get the first response via ping you need to TFTP a working .chk image to the router.

If all this doesn't work, then yes you'll need a serial connection to stop CFE and initialize a TFTP within the CFE

Subhra
Subhra's picture
Have you tried to upgrade

Have you tried to upgrade firmware from WebUI??

naphta
naphta's picture
@ Subhra: I've tried

@ Subhra: I've tried upgrading from WebUI - at least 10 times...

@ budee: Thanks, I'm going to try this tonight.

naphta
naphta's picture
...and it doesn't work when

...and it doesn't work when using a switch between my computer and the router, pinging it all the way and execute tftp as soon as it starts responding. I guess I have to go the "serial (cable) way" :-/

Thanks for your help - any further suggestions without this cable very welcome...

buddee
buddee's picture
which file are you using to

which file are you using to do the TFTP with?

naphta
naphta's picture
it's the original firmware,

it's the original firmware, called WNR3500L-V1.2.2.44_35.0.53.chk. I suppose this doesn't matter since the TFTP connection can't even be established?

buddee
buddee's picture
It does matter, but that file

It does matter, but that file in particular should work. Looks like serial recovery is about all you can do here.