XWRT-Vortex AsusWRT-Merlin on R6400v2

22 posts / 0 new
Last post
prakhar
prakhar's picture
XWRT-Vortex AsusWRT-Merlin on R6400v2

I have gotten the R7000_380.69_2 XWRT/Merlin firmware for r7000 working on the R6400v2.

So far, it's working fine and everything seems stable - including 5GHz and overall Wifi. I didn't need to make any changes to the firmware to get it to work. This is likely because from looking at both R6400v2 and r7000 specs, the 6400v2 seems like a refreshed r7000 with adjacent chips in their respective families - Think iPhone 5C vs. the iPhone 5.

How I got it working:

WARNING: PLEASE DO THIS AT YOUR OWN RISK - JUST BECAUSE IT WORKED FOR ME DOES NOT MEAN SOMETHING CANNOT GO WRONG FOR YOU.

  1. Installed Tathagata's DD-WRT build
  2. Downloaded the XWRT-Vortex AsusWRT-Merlin firmware R7000_380.69_2 from their official site
  3. Used the .chk file to prep the router from DD-WRT's firmware upgrade option
  4. Used the .trx file to upgrade to Merlin, again using DD-WRT's firmware upgrade option
  5. Once the router booted, went through the basic setup wizard
  6. Factory reset the router thrice using AsusWRT Merlin's web UI
  7. Configured the router as per requirements

Notes:

  1. The router may reboot multiple times before the web UI is accessible
  2. The boot speed *seems* a little slower compared to what I had on DD-WRT, but this may just be placebo
  3. Overall network performance is on par with stock/DD-WRT

Also, considering this worked out better than expected (so far), it may be possible to switch to the AdvancedTomato build for r7000 using DD-WRT as well. If someone tries this (again only at their own risk), please post about how this works out for you.

Best,

Prakhar

 

yecarrillo
yecarrillo's picture
Wow prakhar. This is

Wow prakhar. This is fantastic news! I just get two new r6400v2 and I wanted to get put asuswrt on them. Better if using vortex version. I will try this weekend to experiment and will come back here with news. Thanks again for sharing.

tweakradje
tweakradje's picture
Thanks for reporting and

Thanks for reporting and trying this. If this is stable the combination is gold: cheap router with awesome firmware.

Please report back after a few days about stablitity. Thanks! 

abourdon76
abourdon76's picture
Good news, guys! I have this

Good news, guys! I have this v2 hardware as well- looking forward to the reported results. I put the latest non v2 DD-WRT on my system a couple of months ago, and it worked... however, the wireless performance was horrible, especially at 5GhZ. Had to flash back to stock as a result, so hopefully this Merlin hack is stable.

abourdon76
abourdon76's picture
I tried this. Each time I try

I tried this. Each time I try to do the DD-WRT firmware from the stock firmware, i get a message saying that the firmware is incompatible. I'm using the latest stock firmware for the r6400r2, which is V1.0.2.52_1.0.39. I've tried both the r7000, as well as the old r6300 firmares with the same result. With previous Netgear firmware, I was able to upgrade to 3rd party firmware no problem. 

Is there a new step involved now, or did Netgear block the ability to install 3rd party firmware in the last stock update or two?

yecarrillo
yecarrillo's picture
Tried this on my first
Tried this on my first r6400v2 and it is now bricked.
 
Done all prakhar's steps and xvortex firmware loaded correctly. But settings do not survive after reboot. It asked user/password, wifi and connection settings every time I rebooted.
 
Then I did "back to netgear" with wrong firmware of r7000 (r7000-V1.0.3.80_1.1.38 .zip) and now my router is dead. It starts and respond to ping two times and reboot again and again. Tried TFTP and TFTP2 without sucess.
 
Be aware.

 

yecarrillo
yecarrillo's picture
Do you really did all prakhar
Do you really did all prakhar steps? Steps 1, 3 and 4 looked redundant for me at first look, but they was necessary to prevent netgear message.
All steps are necessary.
yecarrillo
yecarrillo's picture
Can you please provide me

Can you please provide me what is the board id of R6400v2? I recover my router from death but mac and s/n are a mess. 

nvram get board_id

prakhar
prakhar's picture
For some reason nvram show /

For some reason nvram show / get aren't pulling the board_id in my case. Not sure the exact reason. But I did find this on another forum, maybe it'll help:

# nvram show |grep board
boardrev=0x1601
pci/2/1/boardflags=0x30000000
boardtype=0x0646
pci/1/1/boardflags=0x80001a00
pci/1/1/boardvendor=0x14e4
boardflags2=0x0
board_id=U12H332T20_NETGEAR
size: 36946 bytes (94126 left)
pci/1/1/boardflags2=0x00108000
boardflags=0x110
pci/2/1/boardvendor=0x14e4
pci/2/1/boardflags2=0x300002
pci/2/1/boardflags3=0x0
boardnum=32

Google it once to be sure. 

prakhar
prakhar's picture
Quick update: Router has been
Quick update: Router has been stable for me with great network performance so far. 
 
To get it working, ensure that you're using Tathagata's v2 R6400 DD-WRT build to prepare the router. All steps that I've listed are needed to avoid rejection of the firmware. 
 
Overall: Switch to Tathagata's (not any other) DD-WRT build for v2 R6400 > Use the .chk file followed by the .trx file (both from the XWRT-Vortex zip) to switch to Merlin. 
 
Notes: 
You might have to reboot a few times for the router to settle. The first few times, your settings may not stick. But post that, they will. Ensure that you factory reset/clear NVRAM a few times before letting a configuration sit. 
 
Others:
  • Be VERY careful if attempting to enable SSH access. In my case, that led to a soft-brick. I could recover it easily with a 30-30-30 reset though. I haven't tried re-enabling SSH access after that. 
  • Telnet access works
 
 
 
 
 
 
 
 
nikedude
nikedude's picture
Thanks for this.   I was able

Thanks for this.   I was able to flash with this about an hour ago.  It definitely did quite a few reboots both on its own and forced, but eventually it seems stable. 

nikedude
nikedude's picture
Just a quick update.  It is

Just a quick update.  It is stable as long as I do not log-in to the router panel.  Logging in seems to restart and reset the router, clearing all settings. 

 

Also, any tips to roll it back to Tathagata's DD-WRT?  When I try and load that firmware, it does not take it. 

yecarrillo
yecarrillo's picture
As I said before, settings do

As I said before, settings do not survive reboots...

Only way to go back to stock or Tathagata's DD-WRT is using serial port connection. I learned in the hard way. Now I have done it lot of times. I will do a kind of tutorial for "serial recovery procedure on R6400v2"  on next days. 

prakhar
prakhar's picture
For me the settings do

For me the settings do survive (including when I login to the Admin UI). I wonder if it has anything to do with the fact that I changed the admin username - in retrospect, my settings didn't stick until I set my username to 'prak'. 

nikedude, you may want to try this - reset the router once more and when it asks you to setup login details, change the username from 'admin' to something else (if you've not tried that already). See if that helps? Maybe it writes settings properly only when the user management area of memory is written including the user name. 

Sounds strange, but let us know if you try this and it works.

 

 

 

nikedude
nikedude's picture
Thanks yecarrillo,  looking

Thanks yecarrillo,  looking forward to it. 

savnetgear
savnetgear's picture
What are you gaining from the

What are you gaining from the Merlin build over Tathagata's build? I have two 6400v2 routers setup for VPN use with the Tathagata firmware for several months and it has been stable. Doubt I would try this unless there is a substantial benefit. Thanks in advance.

koopatroopa
koopatroopa's picture
How did you get r6400v2 back

How did you get r6400v2 back to stock from dd-wrt? I've been trying (dd wrt interface and tftp) and have had no luck.

bigmac375
bigmac375's picture
The only reason I would want

The only reason I would want to use this is Ab-Solution. Can anyone confirm this works?

yecarrillo
yecarrillo's picture
With xvortex everything works

With xvortex everything works until reboot or power down! Once rebooted everything start again , so nothing works.

prakhar
prakhar's picture
Check my previous response

Check my previous response (https://www.myopenrouter.com/comment/42323#comment-42323). See if that helps. 

fzle8
fzle8's picture
hello,I have flash R7000_380

hello,I have flash R7000_380.69_2 XWRT/Merlin,How to back to dd-wrt

TXUSA
TXUSA's picture
I am really not sure what

I am really not sure what goes on in the mind of Netgear. The 6400v2, 7000 and 6700v3 seems to be almost identical. In fact, the 6400v2 and the 6700v3 have the same FCC ID. Oooops ! ;) I picked up a 6400v2 myself lately and use Kong's DDWRT...