R7000 Update - won't accept most firmwares

20 posts / 0 new
Last post
SAK
SAK's picture
R7000 Update - won't accept most firmwares

I've been flashing the r7000 routers for quite some time now - never an issue.  Recently I purchased a few brand new units on amazon.  These new units refuse to accept the DD-WRT Kong firmware (I tried latest 2 versions).  They even refuse to accept most of the old Netgear factory firmwares except for the 3-4 of the most recent ones.

I was able to get Tomato on there and then XWRT-Vortex.  But for the life of me I cannot get DD-WRT Kong on these new units.  I tried TFTP, I tried checking and re-writing the board_id (it was already set at the correct value).  Nothing is making the router accept DD-WRT :(

Anyone have any ideas?  This is so frustrating.

SAK
SAK's picture
I seem to now be stuck on

I seem to now be stuck on XWRT-Vortex R7000_384.8_2

I can't flash to anything else from within the XWRT-Vortex admin page.

SAK
SAK's picture
Invalid Firmware Upload
Invalid Firmware Upload
Firmware upgrade unsuccessful. This might result from incorrect image or error transmission, please check the model name r7000 and version of firmware from support site and try again.
nguilhot
nguilhot's picture
Hi SAK,

Maybe you could try flashing your router using nmrpflash https://github.com/jclehner/nmrpflash.

Regards

mrdon213
mrdon213's picture
There are NEW Freshtomato

There are NEW Freshtomato init files for this router. Try that one and let me know if it works, if it does not, a screenshot of the failure would be greatly appreciated.

SAK
SAK's picture
I tried the latest

I tried the latest FreshTomato initial firmware - freshtomato-r7000-2019.2-initial-64K.chk

It takes.  From inside there I tried to flash to dd-wrt.K3_R7000_20180531 - it acts like it is flashing - the first time it acted like it worked, but after the router rebooted - it was still FreshTomato.  The second time - I get this error: /tmp/flashEBE3Hd: Bad trx header

SAK
SAK's picture
Offering a $75 bounty if

Offering a $75 bounty if anyone can help me find a way to get these new routers to flash reliably.  This is such a headache.

I tried nmrpflash - I wasn't able to get that to work.  It always times out after uploading the firmware file.

I have one router stuck on XWRT-Vortex - can't get anything else on it.  I was successful at getting Tomato onto one router, which will fit my use I suppose...better than nothing...and on another router it won't budge from Netgear Firmware V1.0.9.34_10.2.36 - it just gives the error "This firmware file is incorrect! Please get the firmware file again and make sure it is correct firmware for this product." - no matter which firmware I try (freshtomato initial, dd-wrt, any other version of netgear firmware, vortex, etc)

mrdon213
mrdon213's picture
Do factory reset on routers.

Do factory reset on routers. (with power on use toothpick or something similar to press reset button for 10 seconds).

Then on freshtomato router try flashing full freshtomato then dd-wrt. make sure erase NVRAM is checked both times.

On router stuck on V1.0.9.34 try to upgrade to newer or older stock firmware. Then try migrating to Freshtomato or DD-WRT.

No idea about XWRT-Vortex I dont use closed source firmware, they should have method of reverting to stock.

 

Jandatec
Jandatec's picture
It seems like the the new

It seems like the the new President of Netgear is a true NICE GUY??  I spoke with a person from netgear support admin who wanted to go off the record and this has to do not only with image size but with file signatures.  They have basically done the same thing Samsung did with Android and their hardware only from a different direction.  They claim the EULA specifically says, you are just have a use license on the OS and firmware and they will not allow ANY third party anything.  I have a big problem with this and plan to get up in the NICE GUYS FACE AT THE NEXT CES/VEGAS.

Jandatec,
Thanks

mesteele101
mesteele101's picture
Come, be reasonable. There

Come, be reasonable. There are HUNDREDS if not more that have bricked their router by installing third party firmware. I don't think that Netgear should be responsible for this, and I really don'tr think you do...

mrdon213
mrdon213's picture
Hundreds if not more have

Hundreds if not more have BRICKED there routers using NETGEARS built in updater also. There is a risk no matter how a router is updated and it has to be to avoid internet threats. Read and follow instructions carefully and you too can be like the thousands that HAVE NOT BRICKED there router.

SAK
SAK's picture
The new routers will take

The new routers will take freshtomato, but still nothing else.  I've tried the resets to no avail.  I will try again when I get some new ones in.  I've been making use with Tomato - I had to get units into the field so I was able to get by.  Hopefully it runs stably.

The only problem remains is that I have 2 routers with XWRT-Vortex and can't get it off of there.  It won't take absolutely anything except XWRT-Vortex firmwares at this point.  So I would highly recommend for now until a fix is found for people to avoid flashing THAT firmware onto their new R7000s

SAK
SAK's picture
Apparently the XWRT-Vortex

Apparently the XWRT-Vortex software is illegal to use with Netgear routers.  It allegedly contains proprietary software without license.  If I had known this, I wouldn't have flashed it.  I hope I don't have 2 bricks now.  They are cool looking but expensive decorations.

Merlin says it's illegal, so I would advise everyone against using that for this reason too, not to mention you might get stuck on it.  Who ported this over for Netgear routers?  I wonder if they might know how to get it off again.

mrdon213
mrdon213's picture
Here is a link for vortex

Here is a link for vortex back to stock. I dont know if you have tried this one yet.

 https://mega.nz/#!B80j2RDR!mf-c_6SrWKodtQYCP6iw_FxyJ52XlRffkF3Nyb-41GQ

From there you should be able to flash either dd-wrt or Freshtomato.

I do not have a r7000 to test on so just doing the best I can to help.

SAK
SAK's picture
Aha - that one worked for the

Aha - that one worked for the router stuck on vortex!  Thank you, mrdon!

That router still wouldn't take DD-WRT though.  But I'm putting Tomato on it right now.

 

The other router is stuck on factory 1.0.9.34, but I'm going to keep trying resets and different firmwares to see if anything will take

mrdon213
mrdon213's picture
Good, Now for the one stuck

Good, Now for the one stuck on 1.0.9.34 there are 3 updates after that. Have you tried loading them, From stock firmware in a reset condition it should ask you to update the firmware to a newer version, Let it update if it does. Then try to flash Fresh tomato.

I will get back to you on Freshtomato to dd-wrt

mrdon213
mrdon213's picture
You should be able to

You should be able to directly Flash DD-WRT from freshtomato. This should be the link to KONG'S latest build.

https://www.myopenrouter.com/sites/default/files/downloads/dd-wrt.K3_R70...

djk44883
djk44883's picture
Have you sucsuffly installed

Have you sucsuffly installed dd-wrt?  I hade the same struggleing issue.  Installed XWRT-Vortex - got stuck with it.  Discovered "back to stock". and started over with inital flash files.  When I installed dd-wrt, it would reset with eash reboot - wouldn't save settings.  I'm not certain it ever has a complet factory reset, unless it now comes with a default wireless security turned on with a passphrase (maybe), since mine does.

I have installed fresh-tomato with no real issues, still I don't thing I should have ever left dd-wrt after many years - it doesn't really matter what it looks like.

mrdon213
mrdon213's picture
DD-WRT last time I checked,

DD-WRT last time I checked, KONG builds come with wireless turned ON and the Passphrase is the factory default one on the sticker. You should be able to directly flash DD-WRT from tomato or freshtomato. Make sure to erase nvram before and after flashing! I dont have a r7000 to verify but works on my R8000 and that part of the code is the same on both.

djk44883
djk44883's picture
Thanks for the wifi password

Thanks for the wifi password note!  I had used "stock" dd-wrt firmware on older firmware.  Yes, r7000 has default on label (duh), sorry.  Ok, so that's not an issue.   I haven't gotten back to it... every time I rebooted it would ask for new user/pass as though it was reset.

I had read some where another had a similar issue.  I had been trying to populate static leases, I know if you get a character out of place it can cause odd results.  Not to claim I know exactly what I'm doing, I've been flashing and using dd-wrt since a wrt-54g, so I have some clue.  But, yes it takes one little thing to flubed it all up 

Thanks for all your input and support!!