Wifi bridge mode enter boot loop after a week

1 post / 0 new
oztravman's picture
Wifi bridge mode enter boot loop after a week

I've been having a weird problem for a while now that's been driving me insane trying to troubleshoot.

Thet setup I have is there is a BT SmartHub2 wifi/router in the main part of the house but its signal is not strong enough to reach all areas of the basement apartment attached to the house so an extender is needed. I had been using an R7000 running dd-wrt using the 5Ghz as a Client Wi-Fi to connect and 2.4GHz as the Access Point which would work well, for about a week. On the Kong build the R7000 would start rejecting Wifi connections and need to be rebooted.  If I tried to connect to it from an iPhone it reports "Incorrect Password", if I try from Windows devices it just says Unable to connect.  I tried the latest build from the dd-wrt site and after a week the router would enter a boot loop and I'd have to reset it to defaults, once reconfigured it'd work well for a week or again.  I ran syslog on it but couldn't see anything to indicate the issue, all I could see was just before it became inaccessible it lost access to NTP servers and its time went out of sync. I thought I'd try the Merlin build but it bricked the R7000 so I plugged in an EX6200 Netgear Wi-fi extender I had lying around.

The EX6200 is configured to connect to the SmartHub2 on 2.4GHz and then serves as an AP on 2.4 and 5GHz radios. Its running the latest stock firmware. It all ran well for a week and then it started to do the exact same thing the R7000 would do. The 2.4GHz radio was completely offline, but I could see the 5GHz SSID. When I tried to connect I got the same error messages as I would when using the Kong build (Incorrect password on iOS and unable to connect on windows).  The power light was flashing green and no other lights were active. I plugged into the ethernet port but the extender would not respond to a ping. I cycled the power on the EX6200 just using the power button, it rebooted and connected to the primary Access Point and both SSIDs on it are accessible. So it'll be interesting to see if it needs to be rebooted again in a week.

Any suggestions? I found it quite bizare to get the exact same problem on these two devices, especially consdering I was running custom firmware on the R7000 and stock on the EX6200. The only thing I can think of is something is perhaps causing some sort of cache or buffer to fill up. I now have a USB-TTL cable that I used to unbrick the R7000 so tempted to try with the R7000 again and see if I can any more info using that, but would appreciate any other advice people have.  I've just loaded Tomato onto the R7000 but having trouble getting the Client wi-fi to connect so still using the EX6200 for now.