R8000 lost MAC

1 post / 0 new
lazarus2297's picture
R8000 lost MAC

So a little background..  I have been using Tomato firmware on my R8000 pretty much since I got it, but recently i would have weird issues with 2.4Ghz network just losing internet access, but 5Ghz would still be connected. The only fix was to reboot the router, and was as you could imagine bothersome..  

I tried to go back to stock, but couldn't find a method that worked, I found a back to factory flash for the R7000, and it flashed..  Long story short I found the debricking method to push a proper R8000 firmware to the machine via tftpd.  I can install pretty much any firmware version now, but the device MAC has been "deleted", and shows 00:FF:FF:FF:FF:FF:FF I can manually set the MAC from the sticker on the back, but under the "router information" display it never changes.  

Also if i flash any stock version besides V1.0.3.4 i can't set any security on the wireless network.. 

also when i flash version v1.0.3.4 and set the internet MAC it works, and tries to do a firmware upgrade but fails saying the firware is invalid. 

I know i messed up by flashing the r7000 firmware, but is there any way to get my router back.. For now i have gone back to my trusty Netgear WNDR4500..

I would love to include screenshots, but i am not sure how to post images here without having them hosted somewhere..