Setup openvpn on Voxel`s firmware on R9000

3 posts / 0 new
Last post
jrr's picture
Setup openvpn on Voxel`s firmware on R9000

Ok I am new to this sort of stuff, looks like fun and frustration.

Ok read Voxels Introduction files PDF.

Ok installed voxels firmware version R9000-V1.0.4.14HF-HW, verified, is this the correct version for stability? Or should I get the newest version? 

Ok download several OVPN configuration files for different servers. Do I need to create different folder for each configuration file? Or any other way?Or only one at a time can be loaded to router?

Ok went to create folder named /etc/openvpn/config/client, windows won`t allow /  on file names, so for now I left them as  etcopenvpnconfigclient? What to do next?

Ok kept going changed the ovpn config file to suggested by Voxels Introduction PDF from auth-user-pass to auth-user-pass /etc/openvpn/config/client/auth.txt. I did this to all 6 configuration files for each server. I believe it is ok.

Next create a text file named it auth.txt and only have my user name only on first text line XXXXXX and only password on the second text line OOOOOO, -

I didn`t Put Username: and then XXXXXX or Password: OOOOOO. I dropped a OVPN file and an auth.txt file in each folder that I was not able to name to /etc/openvpn/config/client. 

So now I will wait and see if anyone can guide me, help me with my situation.

Using Windows 10 OS system computer.


Voxel's picture
Well, I've got your message

Well, I've got your message in P.M.

Answers to what I could understand:

1. It is better to use latest version of firmware. Currently it is

2.You can use only one from your ovpn config files. So choose single ovpn file (what is better for your location).

3. You should not create the folder /etc/openvpn/config/client or etcopenvpnconfigclient under your Windows 10. You should create the folder openvpn-client on your USB stick formatted as e.g. FAT32. I.e. if your USB stick has the drive letter E: you should create the folder E:\openvpn-client and put your ovpn and auth.txt to this folder under Windows. NOTE: ovpn file and folder name should be lowercase.

See this nice instruction for details:

4.  Make sure that your ovpn config file and auth.txt stored in \openvpn-client folder are in UNIX text format but not in DOS text format. There are some online converters to convert to UNIX format e.g.


5. Insert your USB stick with \openvpn-client folder and ovpn/auth.txt files in this folder. Reboot your router and remove USB.



jrr's picture
Thank You Voxel, I did as you

Thank You Voxel, I did as you instructed.

So have a couple of more questions:

I removed usb drive and checked the usb drive, it contain an additional folder named .ReadyDLNA. I hope that this is what is left after OVPN file and auth text where installed or accepted.

I made changes to router in the following static public DNS servers.

Now I then went to enable VPN service and when I click apply the following messege pops up.

Dynamic DNS service is suggested to be used alone with vpn service.

Please make sure you will enable the Dynamic DNS service or use the static IP address for your internet connection.

So I go to Dynamic DNS service and it ask if I have service provider or not the their is a drop many with NETGEAR, and

So which way do I go, register for no-ip or dyn dynamic services.

Ok I then went to Netgear genie`s Basic, then Internet. There are 2 options under Internet IP Address and Domain Name Server (DNS) Address for Static or Dynamic?

The defaults are Dynamic From ISP for Internet IP Address and DNS Address get Automatically from ISP.

So right now I do not know how to get the OpenVPN to work or if their are seperate log files for OpenVPN, obviously I believe OpenVPN service is not functioning cause when I go to Netgear Genie, the logs doesn`t say anything about OpenVPN service?

I will await for response. Thanks for your time, your quick response and help.