Repeater bridge not working with OpenWRT

3 posts / 0 new
Last post
achilles
achilles's picture
Repeater bridge not working with OpenWRT

Hi ,

I have flashed my wgr614l with openwrt firmware .

I have tested it for wireless client bridge mode and it is working fine but I am not able to configure it as a repeater bridge.

I have edited the file "etc/config/wireless" as follows :

config wifi-device wl0
option type broadcom
option channel 5

# REMOVE THIS LINE TO ENABLE WIFI:

config wifi-iface
option device wl0
option network lan
option mode sta
option ssid home_test
option encryption none

config wifi-iface
option device wl0
option mode ap
option ssid OpenWrt
option encryption none

Now if I scan for avlbl APs for a wireless client , it shows OpenWrt as one of the SSIDs but I am not able to connect any station with this AP.

Could any body plz tell me if this feature is supported in OpenWRT and if yes where I am making mistake .

Thanks in advance,

 

 

 

 

bzing2
bzing2's picture
I suspect you problem is that

I suspect you problem is that you have not assigned the 'ap' interface to the lan! The following config is what X-Wrt suggests, I have not tried it, but it looks like it should work.

Also do you have some form of DHCP server installed on the LAN? If not then you may associate correctly, but if your client expects to get an address it will probably tell you it failed!

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'channel' '05'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'OpenWrt'
        option 'encryption' 'none'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'ssid' 'Uplink'
        option 'encryption' 'none'
        option 'network' 'lan'
        option 'mode' 'sta'

achilles
achilles's picture
OK ... but I have tried this

OK ... but I have tried this with ap assigned to LAN also .... One thing I observed is that if I keep the 'ap' interface outside bridge ... then my wireless
clients are able to access it but if I keep the 'ap' interface in bridge this does not happen .... am I making any mistake in setup ...