7500v2 to Support DD-WRT

37 posts / 0 new
Last post
cybrnook
cybrnook's picture
7500v2 to Support DD-WRT

Would someone at myopenrouter have the ability to assist Kong in getting an R7500v2? 

 

From reading is latest changelog on the K3-AC-IPQ806X repo he hosts:

"This build however prepares dd-wrt for full R7500V2 support which has two supported atheros radios"

Seems much of the gorund work is laid out, but of course he would need a unit in order to validate this and of course put the finishing touches into the code base so that they can be commited and go mainsteam.

 

I don't think the comment above means that you should run Kong's V1 firmware on the V2 router. I think it is more literlal that the V1 build is assisting in preparing for the V2.

 

I think this would be a very nice router to have DD-WRT on. The CPU is quite powerful, and the Atheros radios offer quite a bit in terms of functionality (Especially over the v1).

Tathagata Das
Tathagata Das's picture
I am working on OpenWRT

I am working on OpenWRT porting to R7500v2. As of now, Ethernet and Wireless are working.

Anybody interested in testing the FW? You need to have serial console set up to test this Alpha version.

cybrnook
cybrnook's picture
I would be open to trying

I would be open to trying this.

 

- Few questions first though, do you have any info on the pinout/breakdown of the R7500v2 and which Serial cable you used?

- I assume you are porting 15.15 CC of OpenWRT? 

- Are both 2.4 and 5.0 GHZ working?

- Is the Alpha built off of Blob's, or are the drivers off open source so that OpenWRT will have the full ability ti interact with the radio's and provide the feature set      (Like MU-MIMO, beamforming etc......)

 

(I am sure I will have more question, but thank you in the meantime)

Tathagata Das
Tathagata Das's picture
- Few questions first though,

- Few questions first though, do you have any info on the pinout/breakdown of the R7500v2 and which Serial cable you used?

This is same as R7500.

- I assume you are porting 15.15 CC of OpenWRT? 

No, I am using OpenWRT trunk. 

- Are both 2.4 and 5.0 GHZ working?

Yes. But full testing is required. You could help me there.

- Is the Alpha built off of Blob's, or are the drivers off open source so that OpenWRT will have the full ability ti interact with the radio's and provide the feature set      (Like MU-MIMO, beamforming etc......)

Possibly not because I am using Open source wireless driver. However, ath10k community will be right one to give you the answer.

 

Please let me know one place where I upload the FW.

MOCruiser
MOCruiser's picture
Hi,

Although I have heard of  *-WRT for a long time, I am new to OpenWRT and this forum in particular however.

I wonder if it's wise for me to flash this over my R7500V2's original firmware. Or is it better for me to wait till it's declared as official firmware by this website.

I dont mean any disrespect but rather being cautious in a new territory.

You see, I am lucky to inherit a R7500V2 whose software layout, in my opinion, is rather confusing and a touch buggy in some parts. Its hardware however is its strong suit. Surpringly.

This brings me to seeking alternative and better firmware for my R7500V2.

Thank you.  

updatedmike
updatedmike's picture
I'm having difficulty with

I'm having difficulty with WPS, specifically for my Wifi Extender...any thoughts?

cybrnook
cybrnook's picture
Tathagata Das, sorry it took

Tathagata Das, sorry it took so long. 

 

Here is a link to a folder on dropbox I made for you, you can upload here:

 

https://www.dropbox.com/sh/n222vnwef0zm965/AAC9ASdeo_e45ncNN6JgqNzda?dl=0

Darks
Darks's picture
Could you upload your
Tathagata Das
Tathagata Das's picture
Your link seems to be not

Your link seems to be not working. Please check.

Darks
Darks's picture
Can you check this link.

Can you check this link. Should work.

http://chomikuj.pl/Dareksa/Netgear+R7500v2

Tathagata Das
Tathagata Das's picture
Thank you for your support. I

Thank you for your support. I have uploaded the FW at following locations. File name is "openwrt-ipq806x-R7500v2-squashfs-factory.img"

- https://drive.google.com/drive/folders/0BwDYXtMamJYgSUxnQ0x6LUhyX1U

- http://chomikuj.pl/Dareksa/Netgear+R7500v2

Please let me know the test result.

ractar28
ractar28's picture
What is this image for?  I

What is this image for?  I have an r7500v2 and have tried the openvpn firmware that's posted for that router (in the downloads section, not yours) and it seems that none of the packages are available because that version of openwrt was never released (someone had posted that info but now the thread is gone).  

If this is a working openwrt that will allow for install of the openvpn client, I'd love to take a look at it.  I don't have a serial cable though.

Tathagata Das
Tathagata Das's picture
New firmware is based on

New firmware is based on trunk. So you could probably install opkg packages including openvpn.

But I didn't try it.

ractar28
ractar28's picture
Is it the same one that's in

Is it the same one that's in the downloads section from Feb 4?

Tathagata Das
Tathagata Das's picture
No. This one uses latest

No. This one uses latest kernel and trunk of OpenWRT.

ractar28
ractar28's picture
Okay, I got the firmware

Okay, I got the firmware installed.  However, I don't see my wireless settings anywhere.  Can you tell me where to find them?  I'm also getting unable to get lock on a file when trying to update the software package list, but I suspect that's because it doesn't have internet access yet.

jplee3
jplee3's picture
Wireless settings can be

Wireless settings can be found first by going to the "Network" tab then the "Wifi" sub-tab. Make sure you change the wireless channel to anything other than "auto" as well before you save/save&apply. Otherwise, you'll probably find yourself hard resetting the router

ractar28
ractar28's picture
Wow, this is frustrating

Wow, this is frustrating because i don't see version numbers.  I also am very confused by the threads.

 

To my understanding, the r7500v2 OpenWRT firmware on the downloads page is NOT this firmware (it sure doesn't look like it either), but both seem to have been created by the same guy.  I'm specifically talking about the firmware linked in this thread, not the one on the downloads page.   I don't have a wifi tab in the firmware from this thread.

 

Also, why on earth is this post titled dd-wrt, yet were getting openwrt discussed?  It makes the conversation quite difficult. 

Tathagata Das
Tathagata Das's picture
There has been some

There has been some discussing going on ... so we didn't change it. If you want, you could create a new thread.

There are two OpenWRT FW for R7500v2 -- one is based on Attitude Adjustment and is available in this site. Another is still in trial version and based on trunk. I personally shared the FW on demand basis and for that user must have serial console set up.

ractar28
ractar28's picture
How can I remove that trial

How can I remove that trial version and go back to stock?  It doesn't like the .img files I have. 

I don't see wireless in the trial version.  Do I simply need to install modules?  

Tathagata Das
Tathagata Das's picture
Where did you get the trial

Where did you get the trial FW? And trail FW does support wireless. But by default it is disabled ... you have to modify one line in /etc/config/wireless.

You could use bootloader prompt to revert back to stock FW.

bdheaton
bdheaton's picture
Loaded the image from the

Loaded the image from the Google Drive link. Initial factory firmware was v1.0.28. It boots fine, but appears to not initialize the wirless cards. I've tried TFTPing over the image and booting with with bootm/bootz. Any suggestions or is there a new trial image available?

Let me know if you'd like the full boot log. I've got a serial console setup and logging.

-Brian

-------------------------------------------

[    9.331894] ath10k_pci 0000:01:00.0: enabling device (0140 -> 0142)
[    9.332872] ath10k_pci 0000:01:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
[    9.464293] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
[    9.464325] ath10k_pci 0000:01:00.0: Falling back to user helper
[    9.479300] firmware ath10k!cal-pci-0000:01:00.0.bin: firmware_loading_store: map pages failed
[    9.661881] ath10k_pci 0000:01:00.0: qca99x0 hw2.0 target 0x01000000 chip_id 0x003b01ff sub 168c:0002
[    9.661920] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[    9.671607] ath10k_pci 0000:01:00.0: firmware ver 10.4.1.00030-1 api 5 features no-p2p crc32 d2901e01
[   11.712312] ath10k_pci 0000:01:00.0: unable to read from the device
[   11.712338] ath10k_pci 0000:01:00.0: could not execute otp for board id check: -110
[   11.717382] ath10k_pci 0000:01:00.0: failed to get board id from otp: -110
[   11.725085] ath10k_pci 0000:01:00.0: could not probe fw (-110)
[   11.732604] ath10k_pci 0001:01:00.0: enabling device (0140 -> 0142)
[   11.738530] ath10k_pci 0001:01:00.0: pci irq msi interrupts 1 irq_mode 0 reset_mode 0
[   11.874194] ath10k_pci 0001:01:00.0: Direct firmware load for ath10k/cal-pci-0001:01:00.0.bin failed with error -2
[   11.874224] ath10k_pci 0001:01:00.0: Falling back to user helper
[   11.889242] firmware ath10k!cal-pci-0001:01:00.0.bin: firmware_loading_store: map pages failed
[   11.889721] ath10k_pci 0001:01:00.0: qca99x0 hw2.0 target 0x01000000 chip_id 0x003b01ff sub 168c:0002
[   11.898120] ath10k_pci 0001:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[   11.908993] ath10k_pci 0001:01:00.0: firmware ver 10.4.1.00030-1 api 5 features no-p2p crc32 d2901e01
[   13.952317] ath10k_pci 0001:01:00.0: unable to read from the device
[   13.952344] ath10k_pci 0001:01:00.0: could not execute otp for board id check: -110
[   13.957388] ath10k_pci 0001:01:00.0: failed to get board id from otp: -110
[   13.965087] ath10k_pci 0001:01:00.0: could not probe fw (-110)
------------------------------
Tathagata Das
Tathagata Das's picture
Can you send me the output of

Can you send me the output of "ifconfig -a" command?

bdheaton
bdheaton's picture
ifconfig -a

ifconfig -a

---------------------------------------

br-lan    Link encap:Ethernet  HWaddr A0:63:91:B1:38:76
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::a263:91ff:feb1:3876/64 Scope:Link
          inet6 addr: fdaa:92c:cd20::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:128 errors:0 dropped:0 overruns:0 frame:0
          TX packets:63 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11249 (10.9 KiB)  TX bytes:6745 (6.5 KiB)
 
eth0      Link encap:Ethernet  HWaddr A0:63:91:B1:38:77
          inet6 addr: fe80::a263:91ff:feb1:3877/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:1086 (1.0 KiB)
          Interrupt:255
 
eth1      Link encap:Ethernet  HWaddr A0:63:91:B1:38:76
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:176 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21070 (20.5 KiB)  TX bytes:6751 (6.5 KiB)
          Interrupt:2
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:60 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4192 (4.0 KiB)  TX bytes:4192 (4.0 KiB)
-----------------------------------------------------------------------------------
 
# Modules are getting loaded
-------------------
root@OpenWrt:/# lsmod | grep ath
ath                    18401  1 ath10k_core
ath10k_core           223947  1 ath10k_pci
ath10k_pci             26388  0
cfg80211              229453  3 ath10k_core
compat                 13548  4 ath10k_pci
mac80211              398027  1 ath10k_core
---------------------
 
 
 
ractar28
ractar28's picture
Can you provide instructions

Can you provide instructions or a link to using the bootloader prompt to revert back?

bdheaton
bdheaton's picture
You can use the "dhcp"

You can use the "dhcp" command if you have a DHCP server combined with a TFTP server and the .bin file from the factory firmware zip configured as the boot file for the subnet. You can also use the "tftp" command to download the factory .bin file from a TFTP server.

EggPlantS
EggPlantS's picture
Can you simply post your repo

Can you simply post your repo?

I would rather build it all here locally using the trunk, that why I know that the key that gets stamped on everything will make all the ipkg compatible.

People flashing your FW will run into not being able to install any of the packages.

Can you post the differences between your 7500v2 openwrt and the openwrt trunk?

There are a lot of things I would want built in, such as the luci web server, logs, sata plugs, usb plugs, ssh, clamscan, snort, firewall builder, upnp, igmp proxy, midnight commander, nano, etc... Just things that make life a little easier.

could you post your ipq806x folder? and I will manually go through your config changes and try out the images with all the extra features I want.

husky1055
husky1055's picture
No update from Tathagata

No update from Tathagata since March 2016. So the r7500v2 has no new firmware from factory , no firmware from ddwrt and openwrt. There is plenty of support for the r7800 which has mostly the same hardware. 

Main Router: Netgear X4 R7500V2
Bridge: R7500V2
Tivo Moca: Actiontec
Repeater Bridge: Netgear X4 R7500V2

MOCruiser
MOCruiser's picture
Good news for owners of
Good news for owners of Netgear R7500V2.
 
Kong at DD-WRT has now has ported a working DD-WRT firmware for R7500V2.
 
 
 
Flash at will.
cliff344
cliff344's picture
Has anyone tried Kong's

Has anyone tried Kong's firmware?  I'm anxious, but not ready to take a chance on bricking this thing.  Any feedback?

cliff

cockroach
cockroach's picture
Yes, flashed firmware 'DD-WRT

Yes, flashed firmware 'DD-WRT v3.0-r30870M kongat (11/10/16)' successfully over factory firmware v1.0.34 into a v7500v2 Nighthawk.  Dialogue read that I was flahing older firmware; I surmise kongat's code/work is referencing (or based on v1.0.24).

Casual observations after flashing:

- faster/smoother thruput (could be the result of a cocktail or two)

- both wireless speeds/function flawlessly

- all lights function

Overall Result:  flawless installation and function - nice.  Thank you MyOpenRouterTeam!

 

 

Pages

Zircon - This is a contributing Drupal Theme
Design by WeebPal.