bricked R8500 - HELP !

5 posts / 0 new
Last post
frossie
frossie's picture
bricked R8500 - HELP !

Hi all,

i tried to flash the stock R8500 firmware from Kong dd-wrt build on my netgear R8500

Now the router loop continuosly and i don't have any type of access to it. The router responds to the ping occasionally with a ttl=100 (only 3 or 4 times).

I read that it's possible to put on it via tftp the firmware during this time but i'm unable to do it . 

 

There's any "backdoor" access or other procedure that i can try ? 

 

thank you !! 

 

mrmidnight
mrmidnight's picture
Hold the reset button for 30

Hold the reset button for 30 seconds. Then let it sit for a while, and set a static IP on your pc

frossie
frossie's picture
I tried but it seems do

I tried but it seems do nothing. My pc have a static ip. During the reset only some ping are ok (with ttl 100). the other times fail continuosly. 

 

frossie
frossie's picture
Hello,

Hello,

i was able to recover the router via serial USB-TTL cable but only with the initial stock firmware 1.0.0.28 .

Any firmware version (stock or dd-wrt) different from the initial stock brick the router.

I saved the log of both the operations (ok or KO).

Any suggestion ? any dd-wrt to test it ?

@Kong, can you help me to understand what's the root cause ?

 

LOG KO

Decompressing...done

CFE for Foxconn Router R7800/R8500 version: v1.0.4
Build Date: Fri Jun 12 11:11:06 CST 2015
Init Arena
Init Devs.
Boot up from NAND flash...
Bootcode Boot partition size = 524288(0x80000)
DDR Clock: 800 MHz
Info: DDR frequency set from clkfreq=1400,*800*
et2: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.121 (r552363)
CPU type 0x0: 1400MHz
Tot mem: 262144 KBytes

Device eth0:  hwaddr A0-63-91-DD-F1-E3, ipaddr 192.168.1.1, mask 255.255.255.0
        gateway not set, nameserver not set
Loader:raw Filesys:tftp Dev:eth0 File:192.168.1.2:vmlinuz Options:(null)
Loading: Failed.
Could not load 192.168.1.2:vmlinuz: Timeout occured
Checking crc...Loader:raw Filesys:raw Dev:nflash0.os File: Options:(null)
Loading: ... 1630736 bytes read
Entry at 0x00008000
Closing network.
Starting program at 0x00008000
Uncompressing Linux... done, booting the kernel.
pci 0000:00:11.0: [Firmware Bug]: reg 0x10: invalid BAR (can't size)
PCI: Fixing up bus 0 domain 0
PCIE1 link=1
PCIE1 switching to GEN2
PCIE1 link=1
PCI host bridge to bus 0001:00
pci_bus 0001:00: root bus resource [mem 0x08000000-0x0fffffff]
pci_bus 0001:00: No busn resource found for root bus, will use [bus 00-ff]
PCI: Fixing up bus 0 domain 1
PCI: bus0: Fast back to back transfers disabled
pci 0001:01:00.0: can't set Max Payload Size to 512; if necessary, use "pci=pcie_bus_safe" and report a bug
PCI: Fixing up bus 1 domain 1
PCI: bus1: Fast back to back transfers disabled
pci 0001:00:00.0: BAR 8: assigned [mem 0x08000000-0x085fffff]
pci 0001:00:00.0: BAR 9: assigned [mem 0x08600000-0x086fffff 64bit pref]
pci 0001:01:00.0: BAR 2: assigned [mem 0x08000000-0x083fffff 64bit]
pci 0001:01:00.0: BAR 4: assigned [mem 0x08600000-0x086fffff 64bit pref]
pci 0001:01:00.0: BAR 0: assigned [mem 0x08400000-0x08407fff 64bit]
pci 0001:00:00.0: PCI bridge to [bus 01]
pci 0001:00:00.0:   bridge window [mem 0x08000000-0x085fffff]
pci 0001:00:00.0:   bridge window [mem 0x08600000-0x086fffff 64bit pref]
PCIE2 link=1
PCIE2 switching to GEN2
PCIE2 link=1
PCI host bridge to bus 0002:00
pci_bus 0002:00: root bus resource [mem 0x20000000-0x27ffffff]
pci_bus 0002:00: No busn resource found for root bus, will use [bus 00-ff]
PCI: Fixing up bus 0 domain 2
PCI: bus0: Fast back to back transfers disabled
PCIE: Doing PLX switch Init...Test Read = fb410003
PCIE: Doing PLX switch Init...GPIO Read = 0000003c
PCIE: Setting PEX8603 UpPort to 0dB de-emphasis.
PCIE 0002:01:0000: PLX UpPort mem_base 0x20000000, mem_limit 0x21ffffff
PCI: Fixing up bus 1 domain 2
PCI: bus1: Fast back to back transfers disabled
PCIE: Doing PLX switch Init...Test Read = fb410003
PCIE: Doing PLX switch Init...GPIO Read = 00000000
PCIE 0002:02:0008: PLX DownPort mem_base 0x23000000, mem_limit 0x24ffffff
PCIE 0002:02:0008: PLX DownPort Link speed is GEN2
PCIE 0002:02:0008: PLX DownPort Link status 0x6012
PCIE: Doing PLX switch Init...Test Read = fb410003
PCIE: Doing PLX switch Init...GPIO Read = 00000000
PCIE 0002:02:0010: PLX DownPort mem_base 0x26000000, mem_limit 0x27ffffff
PCIE 0002:02:0010: PLX DownPort Link speed is GEN2
PCIE 0002:02:0010: PLX DownPort Link status 0x6012
PCI: Fixing up bus 2 domain 2
PCI: bus2: Fast back to back transfers disabled
PCI: Fixing up bus 3 domain 2
PCI: bus3: Fast back to back transfers disabled
PCI: Fixing up bus 4 domain 2
PCI: bus4: Fast back to back transfers disabled
pci 0002:00:00.0: BAR 8: assigned [mem 0x20000000-0x20cfffff]
pci 0002:00:00.0: BAR 9: assigned [mem 0x20d00000-0x20ffffff 64bit pref]
pci 0002:01:00.0: BAR 8: assigned [mem 0x20000000-0x20bfffff]
pci 0002:01:00.0: BAR 9: assigned [mem 0x20d00000-0x20ffffff 64bit pref]
pci 0002:01:00.0: BAR 0: assigned [mem 0x20c00000-0x20c03fff]
pci 0002:01:00.0: BAR 7: no space for [io  size 0x1000]
pci 0002:01:00.0: BAR 7: failed to assign [io  size 0x1000]
pci 0002:02:01.0: BAR 8: assigned [mem 0x20000000-0x205fffff]
pci 0002:02:02.0: BAR 8: assigned [mem 0x20600000-0x20bfffff]
pci 0002:02:01.0: BAR 9: assigned [mem 0x20d00000-0x20efffff 64bit pref]
pci 0002:02:02.0: BAR 9: assigned [mem 0x20f00000-0x20ffffff 64bit pref]
pci 0002:02:01.0: BAR 7: no space for [io  size 0x1000]
pci 0002:02:01.0: BAR 7: failed to assign [io  size 0x1000]
pci 0002:03:00.0: BAR 2: assigned [mem 0x20000000-0x203fffff 64bit]
pci 0002:03:00.0: BAR 4: assigned [mem 0x20d00000-0x20dfffff 64bit pref]
pci 0002:03:00.0: BAR 0: assigned [mem 0x20400000-0x20407fff 64bit]
pci 0002:02:01.0: PCI bridge to [bus 03]
pci 0002:02:01.0:   bridge window [mem 0x20000000-0x205fffff]
pci 0002:02:01.0:   bridge window [mem 0x20d00000-0x20efffff 64bit pref]
pci 0002:04:00.0: BAR 2: assigned [mem 0x20800000-0x20bfffff 64bit]
pci 0002:04:00.0: BAR 4: assigned [mem 0x20f00000-0x20ffffff 64bit pref]
pci 0002:04:00.0: BAR 0: assigned [mem 0x20600000-0x20607fff 64bit]
pci 0002:02:02.0: PCI bridge to [bus 04]
pci 0002:02:02.0:   bridge window [mem 0x20600000-0x20bfffff]
pci 0002:02:02.0:   bridge window [mem 0x20f00000-0x20ffffff 64bit pref]
pci 0002:01:00.0: PCI bridge to [bus 02-04]
pci 0002:01:00.0:   bridge window [mem 0x20000000-0x20bfffff]
pci 0002:01:00.0:   bridge window [mem 0x20d00000-0x20ffffff 64bit pref]
pci 0002:00:00.0: PCI bridge to [bus 01-04]
pci 0002:00:00.0:   bridge window [mem 0x20000000-0x20cfffff]
pci 0002:00:00.0:   bridge window [mem 0x20d00000-0x20ffffff 64bit pref]
PCIE3 link=0
futex hash table entries: 512 (order: 3, 32768 bytes)
squashfs: version 3.0 (2006/03/15) Phillip Lougher
io scheduler noop registered (default)
io scheduler cfq registered
serial8250_init
Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
console [ttyS0] disabled
serial8250.0: ttyS0 at MMIO 0x18000300 (irq = 117, base_baud = 6250000) is a 16550
console [ttyS0] enabled
serial8250.0: ttyS1 at MMIO 0x18000400 (irq = 117, base_baud = 6250000) is a 16550
brd: module loaded
loop: module loaded
bcmsflash: found no supported devices
Boot partition size = 524288(0x80000)
lookup_nflash_rootfs_offset: offset = 0x200000 size = 0x1e00000, 0x20000
found TRX Header on nflash!
nflash: squash filesystem with lzma found at block 29
Creating 5 MTD partitions on "nflash":
0x000000000000-0x000000080000 : "boot"
0x000000080000-0x000000200000 : "nvram"
0x000000200000-0x000002000000 : "linux"
0x0000003a0000-0x000002000000 : "rootfs"
0x000007400000-0x000007480000 : "board_data"
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
PPP generic driver version 2.4.2
PPP BSD Compression module registered
PPP Deflate Compression module registered
PPP MPPE Compression module registered
NET: Registered protocol family 24
GACT probability NOT on
Mirror/redirect action on
Simple TC action Loaded
netem: version 1.3
u32 classifier
    Performance counters on
    input device check on
    Actions configured
Netfilter messages via NETLINK v0.30.
nf_conntrack version 0.5.0 (3971 buckets, 15884 max)
nf_conntrack_rtsp v0.7 loading
xt_time: kernel timezone is -0000
ip_set: protocol 6
gre: GRE over IPv4 demultiplexor driver
nf_nat_rtsp v0.7 loading
ip_tables: (C) 2000-2006 Netfilter Core Team
NET: Registered protocol family 17
bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
Bridge firewalling registered
8021q: 802.1Q VLAN Support v1.8
Registering SWP/SWPB emulation handler
max nvram space = 131072
read 131072 bytes to offset 0
Key type encrypted registered
Northstar brcmnand NAND Flash Controller driver, Version 0.1 (c) Broadcom Inc. 2012
nand: device found, Manufacturer ID: 0x01, Chip ID: 0xf1
nand: AMD/Spansion NAND 128MiB 3,3V 8-bit
nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
Spare area=64 eccbytes 56, ecc bytes located at:
 2 3 4 5 6 7 8 9 10 11 12 13 14 15 18 19 20 21 22 23 24 25 26 27 28 29 30 31 34 35 36 37 38 39 40 41 42 43 44 45 46 47 50 51 52 53 54 55 56 57 58 59 60 61 62 63
Available 7 bytes at (off,len):
(1,1) (16,2) (32,2) (48,2) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0) (0,0)
Scanning device for bad blocks
Options: NO_SUBPAGE_WRITE,
Creating 1 MTD partitions on "brcmnand":
0x000002000000-0x000007000000 : "ddwrt"
VFS: Mounted root (squashfs filesystem) readonly on device 31:3.
Freeing unused kernel memory: 340K (8048b000 - 804e0000)
start service
starting Architecture code for northstar
udevtrigger[381]: parse_config_file: can't open '/etc/udev/udev.conf' as config file: No such file or directory
1970-01-01 00:00:06 main: Sanity checks succeeded
length = 0
try modules for ethernet adapters
et: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
et_module_init: passivemode set to 0x0
et_module_init: txworkq set to 0x0
et_module_init: et_txq_thresh set to 0xce4
et_module_init: et_rxlazy_timeout set to 0x3e8
et_module_init: et_rxlazy_framecnt set to 0x20
et_module_init: et_rxlazy_dyn_thresh set to 0
et0: etc_attach() failed
et1: etc_attach() failed
ET Corerev 7
eth0: Broadcom BCM47XX 10/100/1000 Mbps Ethernet Controller 7.14.89.21 (r524987)
roboswitch: Probing device 'eth0'
roboswitch: trying a 53012! at eth0
detected CPU Port is 8
roboswitch: found a 53012! at eth0
detected CPU Port is 8
PCI: Enabling device 0001:01:00.0 (0140 -> 0142)
PCI: Enabling device 0002:03:00.0 (0140 -> 0142)
PCI: Enabling device 0002:04:00.0 (0140 -> 0142)
wl_module_init: passivemode set to 0x0
wl_module_init: txworkq set to 0x0
Unable to handle kernel NULL pointer dereference at virtual address 00000000
pgd = 871b4000
[00000000] *pgd=068ff831, *pte=00000000, *ppte=00000000
Internal error: Oops - BUG: 17 [#1] SMP ARM
Modules linked in: wl(P+) igs(P) emf(P) switch_robo switch_core et(P)
CPU: 1 PID: 746 Comm: insmod Tainted: P                4.4.23-rc1 #1450
Hardware name: Northstar Prototype
task: 8789fc00 ti: 86800000 task.ti: 86800000
PC is at osl_pcie_rreg+0x5c/0x78
LR is at si_pmu_get_pmutimer+0x78/0x15c
pc : [<80211f98>]    lr : [<80202dbc>]    psr: 80000013
sp : 868019a0  ip : 868019b0  fp : 868019ac
r10: 00003a98  r9 : 89f08000  r8 : 89f08000
r7 : 872e7200  r6 : 86801a1c  r5 : 872e7200  r4 : 87a12200
r3 : 00000003  r2 : 868019b4  r1 : 00000000  r0 : 872e7200
Flags: Nzcv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
Control: 10c5387d  Table: 071b404a  DAC: 00000055
Process insmod (pid: 746, stack limit = 0x86800190)
Stack: (0x868019a0 to 0x86802000)
19a0: 868019d4 868019b0 80202dbc 80211f48 18100000 00000004 00000070 87a12200
19c0: 00000001 86801a1c 86801a0c 868019d8 80202eec 80202d50 80183664 801835e8
19e0: 86801a14 87a12200 00000000 86801a1c 89f08000 89f08000 872e7200 87a12200
1a00: 86801a4c 86801a10 80203014 80202ed0 00000001 86801a1c 87a12200 00000000
1a20: 00000003 87a12200 872e7200 00000003 89f08000 805821aa 0000083b 86801c04
1a40: 86801a74 86801a50 8020d4c0 80202fd4 872e7200 18103000 86801c08 872e7200
1a60: 87a12200 89f08000 86801a84 86801a78 8021d374 8020d490 86801adc 86801a88
1a80: 801f7024 8021d360 89f08000 8513880c 85138800 18103000 86801acc 86801aa8
1aa0: 801ed1dc 00000000 00000000 00000000 85138820 87a12200 00000008 00000000
1ac0: 00000001 00000003 0000083b 18003000 86801b64 86801ae0 8021f0bc 801f6f0c
1ae0: 86801c04 86801c08 86801b0c 00000003 00000014 00000021 ffffffff 00000001
1b00: 00000000 89f08000 00000001 872e7200 89f08000 89f08000 18034366 872e7200
1b20: 00000048 58400009 00000046 285c4e1c 80211b10 800c60b8 00000600 87a12200
1b40: 86801c04 872e7200 00000001 00004365 89f08000 85138800 86801ba4 86801b68
1b60: 8021fca4 8021e8d0 00000001 87a2ac00 86801c04 86801c08 00005000 87a2ac00
1b80: 00004365 00004365 87207800 00000000 00000000 872e7200 86801bcc 86801ba8
1ba0: 7f39df98 8021fc1c 87a2ac00 86801c04 86801c08 89f0c000 80006280 00000000
1bc0: 86801c44 86801bd0 7f36dee4 7f39df80 87a2ac00 86801c04 86801c08 872e7200
1be0: 86801c14 86801bf0 80020158 8015ff04 800201c4 000014e4 87113000 00000000
1c00: 00000000 00000000 00000000 86801c18 80020214 8002002c 7f351380 87113000
1c20: 87a2ac00 7f5e4a80 87207800 00000000 00000000 872e7200 86801cbc 86801c48
1c40: 7f3513fc 7f36de84 00000000 872e7200 89f08000 00000001 87a2ac00 00000000
1c60: 86801c88 87208d08 87208da8 000000a3 000014e4 00004365 08400000 8720b000
1c80: 86801cb4 00000000 00000000 8011a294 87a2ac68 87a2ac68 87a2ac00 7f5e3cec
1ca0: 00000000 7f5e3d20 0000000a 024000c0 86801ce4 86801cc0 8018bee8 7f3510a0
1cc0: 8058072c 87a2ac68 80580720 00000000 7f5e3d20 0000000a 86801d0c 86801ce8
1ce0: 801b6230 8018be7c 87a2ac68 7f5e3d20 87a2ac9c 00000000 00000000 7f5e41c0
1d00: 86801d2c 86801d10 801b6440 801b6150 00000000 7f5e3d20 801b63c4 00000000
1d20: 86801d54 86801d30 801b471c 801b63d0 878a9d5c 87a29eb4 86801d64 7f5e3d20
1d40: 87a8c700 805013c8 86801d64 86801d58 801b5cc0 801b46d4 86801d8c 86801d68
1d60: 801b5888 801b5ca8 7f54f770 86801d78 7f5e3d20 804f7918 85095c80 7f5f9000
1d80: 86801da4 86801d90 801b6a6c 801b57b8 7f5e4a80 804f7918 86801db4 86801da8
1da0: 8018b75c 801b69d8 86801dcc 86801db8 7f5f90cc 8018b720 804f7918 804f7918
1dc0: 86801e44 86801dd0 8001808c 7f5f900c 86801f3c 7f5e41c0 00000002 85095c80
1de0: 00000001 0000001d 86801f3c 7f5e41c0 86801e1c 86801e00 800bd91c 800c5440
1e00: 0000047f 862d3680 00000001 0000001d 0000047f 862d3680 00000001 0000001d
1e20: 7f5e41c0 87a97e10 00000000 862d3680 86801f3c 7f5e41c0 86801e6c 86801e48
1e40: 80091128 80017f84 86801e6c 86801e58 87a97c00 87a97e10 00000000 0000001d
1e60: 86801f34 86801e70 80092a8c 800910cc 7f5e41cc 00007fff 7f5e41c0 80090ac8
1e80: 80429e48 80429e20 80429e14 80429e78 8042a0a4 7f5e41cc 8d4ff95c 7f5e4318
1ea0: 86801ecc 7f5e41c0 804fd168 8042a09c 8008fff8 7f5e4208 80009e80 80009328
1ec0: 8d488740 76ed7770 00008840 00000000 00000000 00000000 00000000 00000000
1ee0: 00000000 00000000 00000000 00000000 00000000 00000000 00000000 00000000
1f00: 00000000 00000000 024002c2 0000e9ac 00000000 76f4e9bc 8d4ff9ac 86800000
1f20: 00096fc0 00000000 86801fa4 86801f38 800931c4 8009130c 8789fc00 8d081000
1f40: 0047e9ac 8d4ff524 8d4ff42c 8d490c44 003f9b7c 0040771c 00000000 00000000
1f60: 00000000 0001e5b0 0000001b 0000001c 00000015 00000000 00000010 00000000
1f80: 00000000 00096f00 00000000 00000080 800096e4 86800000 00000000 86801fa8
1fa0: 80009540 800930ac 00000000 00096f00 76ad0010 0047e9ac 00096fc0 00096f10
1fc0: 00000000 00096f00 00000000 00000080 7ef7eec4 0007c52b 0007af21 00096f00
1fe0: 7ef7ec24 7ef7ec08 0001e2f8 76fa1d3c 20000010 76ad0010 00000000 00000000
Backtrace:
[<80211f3c>] (osl_pcie_rreg) from [<80202dbc>] (si_pmu_get_pmutimer+0x78/0x15c)
[<80202d44>] (si_pmu_get_pmutimer) from [<80202eec>] (si_pmu_wait_for_res_pending+0x28/0x104)
 r6:86801a1c r5:00000001 r4:87a12200
[<80202ec4>] (si_pmu_wait_for_res_pending) from [<80203014>] (si_pmu_wait_for_steady_state+0x4c/0xac)
 r10:87a12200 r9:872e7200 r8:89f08000 r7:89f08000 r6:86801a1c r5:00000000
 r4:87a12200
[<80202fc8>] (si_pmu_wait_for_steady_state) from [<8020d4c0>] (si_pmu_is_otp_powered+0x3c/0x2f4)
 r10:86801c04 r9:0000083b r8:805821aa r7:89f08000 r6:00000003 r5:872e7200
 r4:87a12200
[<8020d484>] (si_pmu_is_otp_powered) from [<8021d374>] (si_is_otp_powered+0x20/0x2c)
 r7:89f08000 r6:87a12200 r5:872e7200 r4:86801c08
[<8021d354>] (si_is_otp_powered) from [<801f7024>] (srom_var_init+0x124/0x3f4)
[<801f6f00>] (srom_var_init) from [<8021f0bc>] (si_doattach+0x7f8/0x134c)
 r10:18003000 r9:0000083b r8:00000003 r7:00000001 r6:00000000 r5:00000008
 r4:87a12200
[<8021e8c4>] (si_doattach) from [<8021fca4>] (si_attach+0x94/0xf8)
 r10:85138800 r9:89f08000 r8:00004365 r7:00000001 r6:872e7200 r5:86801c04
 r4:87a12200
[<8021fc10>] (si_attach) from [<7f39df98>] (_2320+0x24/0x2c [wl])
 r10:872e7200 r9:00000000 r8:00000000 r7:87207800 r6:00004365 r5:00004365
 r4:87a2ac00
[<7f39df74>] (_2320 [wl]) from [<7f36dee4>] (_2166+0x6c/0x1e88 [wl])
 r4:00000000
[<7f36de78>] (_2166 [wl]) from [<7f3513fc>] (_1755+0x368/0x5b0 [wl])
 r10:872e7200 r9:00000000 r8:00000000 r7:87207800 r6:7f5e4a80 r5:87a2ac00
 r4:87113000
[<7f351094>] (_1755 [wl]) from [<8018bee8>] (pci_device_probe+0x78/0xd0)
 r10:024000c0 r9:0000000a r8:7f5e3d20 r7:00000000 r6:7f5e3cec r5:87a2ac00
 r4:87a2ac68
[<8018be70>] (pci_device_probe) from [<801b6230>] (really_probe+0xec/0x280)
 r9:0000000a r8:7f5e3d20 r7:00000000 r6:80580720 r5:87a2ac68 r4:8058072c
[<801b6144>] (really_probe) from [<801b6440>] (__driver_attach+0x7c/0xa0)
 r9:7f5e41c0 r8:00000000 r7:00000000 r6:87a2ac9c r5:7f5e3d20 r4:87a2ac68
[<801b63c4>] (__driver_attach) from [<801b471c>] (bus_for_each_dev+0x54/0xa8)
 r7:00000000 r6:801b63c4 r5:7f5e3d20 r4:00000000
[<801b46c8>] (bus_for_each_dev) from [<801b5cc0>] (driver_attach+0x24/0x28)
 r6:805013c8 r5:87a8c700 r4:7f5e3d20
[<801b5c9c>] (driver_attach) from [<801b5888>] (bus_add_driver+0xdc/0x218)
[<801b57ac>] (bus_add_driver) from [<801b6a6c>] (driver_register+0xa0/0xdc)
 r7:7f5f9000 r6:85095c80 r5:804f7918 r4:7f5e3d20
[<801b69cc>] (driver_register) from [<8018b75c>] (__pci_register_driver+0x48/0x4c)
 r5:804f7918 r4:7f5e4a80
[<8018b714>] (__pci_register_driver) from [<7f5f90cc>] (_1156+0xcc/0xd8 [wl])
[<7f5f9000>] (_1156 [wl]) from [<8001808c>] (do_one_initcall+0x114/0x1a4)
 r5:804f7918 r4:804f7918
[<80017f78>] (do_one_initcall) from [<80091128>] (do_init_module+0x68/0x1c0)
 r9:7f5e41c0 r8:86801f3c r7:862d3680 r6:00000000 r5:87a97e10 r4:7f5e41c0
[<800910c0>] (do_init_module) from [<80092a8c>] (load_module+0x178c/0x1da0)
 r7:0000001d r6:00000000 r5:87a97e10 r4:87a97c00
[<80091300>] (load_module) from [<800931c4>] (SyS_init_module+0x124/0x158)
 r10:00000000 r9:00096fc0 r8:86800000 r7:8d4ff9ac r6:76f4e9bc r5:00000000
 r4:0000e9ac
[<800930a0>] (SyS_init_module) from [<80009540>] (ret_fast_syscall+0x0/0x34)
 r9:86800000 r8:800096e4 r7:00000080 r6:00000000 r5:00096f00 r4:00000000
Code: e1d130b0 f57ff04f e1c230b0 e89da800 (e5913000)
---[ end trace 1635c8715c7e4ab4 ]---
Kernel panic - not syncing: Fatal exception
CPU0: stopping
CPU: 0 PID: 0 Comm: swapper/0 Tainted: P      D         4.4.23-rc1 #1450
Hardware name: Northstar Prototype
Backtrace:
[<8001b0c8>] (dump_backtrace) from [<8001b29c>] (show_stack+0x18/0x1c)
 r7:804e1f20 r6:60000193 r5:00000000 r4:80500edc
[<8001b284>] (show_stack) from [<8015e6f4>] (dump_stack+0x8c/0xa0)
[<8015e668>] (dump_stack) from [<8001ce7c>] (handle_IPI+0x110/0x1a8)
 r7:804e1f20 r6:00000000 r5:00000000 r4:805131a0
[<8001cd6c>] (handle_IPI) from [<80009394>] (gic_handle_irq+0x78/0x7c)
 r7:b0100100 r6:804e1f20 r5:b010010c r4:804efb14
[<8000931c>] (gic_handle_irq) from [<80009e80>] (__irq_svc+0x40/0x54)
Exception stack(0x804e1f20 to 0x804e1f68)
1f20: 86dd4240 00000000 00030826 8000a960 804e0000 804ef8e0 80424f90 804dc220
1f40: 804e1f90 804b48c8 00000000 804e1f7c 804e1f80 804e1f70 80018d28 80018d2c
1f60: 60000013 ffffffff
 r9:804b48c8 r8:804e1f90 r7:804e1f54 r6:ffffffff r5:60000013 r4:80018d2c
[<80018cf0>] (arch_cpu_idle) from [<8006a128>] (default_idle_call+0x30/0x34)
[<8006a0f8>] (default_idle_call) from [<8006a234>] (cpu_startup_entry+0x108/0x13c)
[<8006a12c>] (cpu_startup_entry) from [<80012a48>] (rest_init+0x80/0x84)
 r7:80513020 r4:00000000
[<800129c8>] (rest_init) from [<8048bcc0>] (start_kernel+0x320/0x32c)
[<8048b9a0>] (start_kernel) from [<0000807c>] (0x807c)
Rebooting in 10 seconds..Digital core power voltage set to 1.05V

dhoppy
dhoppy's picture
I realize this is an older

I realize this is an older thread, but I'm having the exact same issue.  Any firmware (stock or dd-wrt) besides the original stock netgear firmware bricks the router.