Cannot assign wl1.1 to bridge

4 posts / 0 new
Last post
myscreenname's picture
Cannot assign wl1.1 to bridge

Using DD-WRT v3.0-r28600M kongac (01/03/16)

Have previously set up guest network on dd-wrt for several 3700 & 3800s - all successfully - using The guide is for a single virtual wifi interface, but it's trivial to extend it to both 2.4 & 5 bands (on the same guest network) on the 3700/3800s.

Just flashed my newly purchased R8000 with the above and, after setting up wifi, configured for guest wifi using the same as I've done before (as per above).

As there are 3 radios, I've got 3 virtual interfaces and I assign them all to bridge br1. All have different SSIDs.

wl0.1 & wl2.1 are assigned no problem and work just fine.

wl1.1 isn't able to be assigned no matter what I try. Assigning it under :"Assign to Bridge" lets me set it up, but it never appears in the bridging table and it cannot be used. Troubleshooting to date:

- Remove wl0.1 and wl2.1, and make wl1.1 the only interface on br1. No go. So it's not a limitation of 2 interfaces.

- Create a new bridge (br2) and assign it there. No go.

I note that it's the 2.4Ghz band that has the problem while both the 5s are fine, although this could be unrelated.

wl0, wl1 & wl2 all work just fine and dandy.

Any ideas?



waise's picture
i have used that build, mine

i have used that build, mine was working without wireless security and upgraded to DD-WRT v3.0-r29020M kongac (02/04/16) still same i followed the intruction on 

Guest Wifi Setup DD-WRT

Here comes a short guide on how to setup a Virtual Guest AP. In build 23020 I added an option to isolate guest wifis from local network. This along with my fix for unbridged vifs allows to setup a guest wifi with only a few clicks. The following image shows theWireless->Basic Setup page. In order to create a virtual access point, for your guests, click on Add in Virtual Interfaces section. Now fill out the details for this guest wifi.  The labels in red give you a short explanation what these settings are for.



Once you are done go to Wireless->Wireless Security, choose your encryption scheme and password for this guest wifi. Next step is to enable DHCPD for the guest wifi. Go toSetup->Networking and add another dhcp server for the guest network as shown in the following image.



myscreenname's picture
Thanks waise; I'll try that.

Thanks waise; I'll try that.


DocDragon's picture
Sorry, if this is a necropost

Sorry, if this is a necropost, but my problem is the same as above. So I thought starting a new thread wouldn't make much sense.

I'm using a NETGEAR R6400 and plus Kong's 33675M firmware (11/03/2017). On this note, I never used a DD-WRT firmware before.

I followed Kong's instructions ( step-by-step multiple times including doing factory resets to wipe out my old entries, but none of my android devices were able to connect to the public wireless network that I was trying to create. I always get an error message "Failed to obtain IP address." What am I doing wrong? My YouTube search only revealed old videos using older DD-WRT f/w.

Setting up a guest network with NETGEAR's GENIE firmware was obviously no issue since the router was using MY private network address(es) (192.168.1.x) -- which I wanted to avoid. But setting up an isolated network with a different address (192.168.2.x) didn't work.

I haven't tried Tomato yet because there's no official KRACK fix.

I'd appreciate any help! Thank you!