Cannot UPGRADE DDWRT on R6250 - please help!

8 posts / 0 new
Last post
bovine
bovine's picture
Cannot UPGRADE DDWRT on R6250 - please help!

Hello all!
 
First post here, please be gentle.
 
I have netgear R6250 running DD-WRT v3.0-r28444 std (12/05/15).
 
And for the life of me, I CANNOT get it to upgrade to newer version!
 
YES I HAVE FOLLOWED THE UPGRADE GUIDE EXACTLY!
 

 
I have tried https://www.myopenrouter.com/download/dd-wrt-netgear-r6250-kong-mod-updated-06-27-2016
 
and also https://www.myopenrouter.com/download/dd-wrt-kong-mod-netgear-r6250-04-19-2016
 

 
This is what happens:
 
I go through the process, hard reset 30-30-30 etc.
 
Select new .chk file as above. It starts flashing, with a 300 second
countdown timer. After about two seconds, this disappears and I get a
"cannot connect" message in firefox.

(can still ping ok)
 

 
It then stays in this flashing state, with the "netgear" logo flashing every few seconds on the router.
 
It takes a full 15 minutes before anything happens - after 15
minutes,the router resets...I follow the guide, power off, 30-30-30
again etc.
 
Create new password, log back in and hey guess what - FIRMWARE IS STILL
DD-WRT v3.0-r28444 std (12/05/15)! . (yes cleared browser cache!!).
 

 
Any and all ideas welcome!
 
Many thanks!

beardrinksbeer
beardrinksbeer's picture
are you hard wired to the

are you hard wired to the router when trying to upgrade?

fuck all of you

erictamflys
erictamflys's picture
I am also experiencing the

I am also experiencing the exact same problem as bovine.  Unable to upgrade to a newer firmware.
Netgear R6250, DD-WRT v24-sp2 (06/06/14) kongac

I have tried the reset process. And experience the same issue, load the new firmware, 300 second timer starts, and after 2 seconds, it just stops and nothing happens...

Any suggestions or links to follow?

Thanks

Mastec
Mastec's picture
In order to upgrade to the

In order to upgrade to the latest DD-WRT KONG version you need to be using DD-WRT KONG firmware, not regular DD-WRT.  You CAN NOT upgrade DD-WRT with DD-WRT KONG Mod.  Yes, both are the same but at the same time slightly different.  The easiest way I know to upgrade is to go back to the Netgear firmware and then load KONG onto your router.  KONG installs right over Netgear.  I wish I could point you to instructions how to get Netgear back on your router to help you out.... Sorry.

Differences between Kong and BrainSlayer builds are:

-Builds receive additional testing before upload

-Builds can be upgraded through commandline tool ddup (currently only northstar).
 See: ddup --help

-Builds and packages are cryptographically signed in order to verify authenticity

-Builds sometimes contain hotfixes that are not yet included in regular builds until
 a universal solution has been developed

-Builds contain a tool called bootstrap that installs a package manager called opkg
 in order to install additional features.

For future reference, you can find the latest KONG updates here --> http://desipro.de/ddwrt/K3-AC-Arm/

appleknight
appleknight's picture
i cant even log into my

i cant even log into my router!

Mastec
Mastec's picture
Have you tried a 30/30/30

Have you tried a 30/30/30 reset?  With the router powered on press and hold the reset button (Broken toothpick works best) on the back for 30 seconds, while still holding the reset button unplug the router for 30 seconds and still holding the reset button, plug the router back in while still holding the reset button for another 30 seconds?

If the router lights don't shut off within the first 30 seconds of the initial press of the reset button your router might be bricked.  If it's till under warranty you can send it in for an RMA exchange.  All you have to pay is under $20 for shipping & handling.  I had to do this with 2 routers after trying to get Brainslayers DD-WRT version loaded.  When I received the new routers I installed Kongs Mod 5 minutes after unboxing them.  IMHO, Kongs Mod makes these R6250's run so much better than anything else out there.

 

Good luck.  Hope you get your router working.

Роберт Шотланд
Роберт Шотланд's picture
Compatible dd-wrt upgrade? I

Compatible dd-wrt upgrade? I have an R6250 with DD-WRT v3.0-r27365M (06/18/15) kongac

Is this compatible with new kong firmware, or do I have to revert to stock Netgear firmware first?

Роберт Шотланд
Роберт Шотланд's picture
Upgrade successful to dd-wrt

Upgrade successful to dd-wrt.K3_R6250_06_30_2015.chk no problems encountered.

Unfortunately, post-upgrade, and configured as WAP, wireless clients still do not get IP addresses via DHCP from gateway router, a Microtik hEX Lite, Ethernet Clients acquire addresses normally.I'm trying to determine the DD-WRT settings to fix wireless DHCP. I'm Following the DD-WRT Wiki for setting up an AP to the letter, but no joy. The only unique setting in our network is that it is a /23.

I wonder how far the DHCP exchange is getting - discovery, offer, request, or acknowledge. I was hoping not to have to trace the UDP packets. Anybody else have this problem?