Cant access manual configuration on KWGR614

4 posts / 0 new
Last post
davidmhodgey's picture
Cant access manual configuration on KWGR614

Hi there, I'm getting really annoyed with the KWGR614.

 I can't access any of its settings. When I browse to its IP, I get two options:

1. Walkthrough

 2. Advanced

So I click advanced, then next, but nothing happens. I've tried this in konquerer and firefox. I thought, ok maybe its a brower problem. So,i tried it on a windows PC in firefox and ie, same problem! argh!

unfortunately everything i go to on the router redirects to this setup wizard. I've tried reseting it, power cycling it etc. I've even tried running the setup from the windows pc, but it gets to the same point and problem.

has anyone else encountered this? or, does anyone know if its possible to flash it with a firmware that actually works?

thanks a billion for any help.


davidmhodgey's picture
Hello. Thanks for your reply.

Hello. Thanks for your reply. Yesh the problem is definitely with the router. The page that displays the form with the radio checkboxes contains some dodgy javascript, resulting in errors being thrown up in both IE and Firefox. Because of this the javascript submit isn't working.

 I spent ages on the phone to netgear last night who adivise that the problem is "with my javascripts" and suggest I reinstall them. Hah! He then went on to tell me that he's "not a computer expert". 

 Very frustrating. 

 Anyway, thanks for your reply. But I'm certain there's going to be no solution to this other than to return it and stay away from Netgear in future

SouvikGhosh's picture
This seems to be a Java

This seems to be a Java script related problem... Can you please let me know the exact error message. This can be found from your browser. If you are using Firefox , the Java script console should show you the ERROR.

davidmhodgey's picture
That's what I thought as it

That's what I thought as it uses JS to submit the form. Unfortunately it doesn't throw up any JS errors. I've got firebug and it's reporting no problems either. From looking at the source, I can get the page it's trying to submit to and browse there, unfortunately it's expecting some POST and so all I get is a dodgy HTML timer thing that counts to 100 then does nothing.

I should mention that I'm a web developer so I've tried a fair few cheats to get it working. looking at the source of this router is shocking. I don't understand why there's so much crap in the page when all it needs is 2 radio checkboxes and have a submit button.

Aaaaanyway, thanks very much for your reply. But I've sent the router back to the supplier and bought a Linksys one instead, which works wonderfully. I would have persevered with the netgear but the attitude of netgear support annoyed me so much that I wasn't willing to make any more effort to get it working.

Thanks again