Changing Board ID on Charter Edition R6300V2 with DD-wrt firmware

9 posts / 0 new
Last post
jason123x's picture
Changing Board ID on Charter Edition R6300V2 with DD-wrt firmware

Hi there

I have the Charter / Spectrum Eidtion R6300V2 Router

I installed the dd-wrt-K3_R6300V2CH.CHK


I would like to chang ethe Board ID so I can truly have a stock version no related to Charter / Spectrum at all and be able to update firwmare as needed.  I enabled telnet using Telnetenable.exe utility and that seems to work (no Send Failure 10057 anymore), then with Putty, I start a session and it asks for credentials.  The ones I selected when I installed the new firmware are the default (admin / password) and it's not accepting this.  I get a "Incorrect login credentials" or something to that effect from the DD-WRT prompt.


Is there a different set of credentials for accessting telnet on this firmware?'

I can login to the router using web browser fine with these credentials (admin / password)


jason123x's picture
Ok, I figured this issue out.

Ok, I figured this issue out.  The Telnet credentials are root and password (or whatever password you selected when you setup the DD-WRT...


Now, i got through Telnet using PUTTY, and ran the following commands:

burnboardid U12H240T00_NETGEAR  (this command resulted in burnboardid not recognized)

I typed:

nvram set board_id=U12H240T00_NETGEAR (this worked)


Then I used the DD-WK... to flash my unit with the stock V1.0.4.2....


all went well, but now I can't access the Configuration Interface ( or even after full reset and 30/30/30

Have I bricked it? I am able to connect to wireless and I can see it's ipconfi parameters, it seems to be responsive, but no webserver access.

jason123x's picture
Ok... I figured it out ... I

Ok... I figured it out ... I feel like I'm running my own post! :)

So I learned that  burboardid is a stock firmware command - I had to re-enable telnet after putting the sock firmware (telnetneable.exe) and then I was able to Telnet into the router.  Type command burnboardid returned the stored ID and I had it entered incorrectly.  I fixed it using the "Burnboardid U12H.... above and rebooted..


reboot again

and Voila.. I have a Stock unit running stock code and no reference to Charter or charter / spectrum firmware.


Thank you all! hmmm.. yeah

TXUSA's picture
So... to sum this up... you

So... to sum this up... you have to run the stock firmware, then change the board ID, then you are free to do whatever afterwards ?

Zband's picture
The following is how I got

The following is how I got into my r6300v2CH router.   I was able to turn the router into a non Charter router with the process that I went through.

You have to make sure that Telnet is installed and functioning on Windows or Linux system that you are using.  I used a Windows 7 Home Premium system.  

Once Telnet is on your Windows 7 system go to the following website : and download the command line program nte.exe under the executable kit and put it in an accessible directory. (You must know how to use command line for the program and telnet)  Go to the directory where nte.exe is and execute the program.  It will give you instructions on what to do.  This program is for the enabling of telnet in the router. (This was the only way that I could get telnet to function on my system.  Putty didn't work.  It would give me the same problem over and over about how the login was incorrect. nte.exe fixed this problem.)  After following the instructions and executing the program properly you should be told at command line that the program has enabled telnet in the router. 

Open cmd.exe (I ran it as Admin just to make sure of the following)  from command line type in Telnet to activate Telnet.

Telnet will expect you to type something like the following

                                       o 23    - this is the routers IP address and port 23

Assuming all is going well for you, your command line interface will change to a # symbol. 

Then type in the following that is also listed in one of the above posts:

                                          burnboardid U12H240T00_NETGEAR  

                                nvram set board_id=U12H240T00_NETGEAR

To my understanding the above are commands for the router to change the ID of the router which will then allow you to flash new firmware.  When the two router commands have been executed you can get out of telnet and go back to the router interface through your web browser and flash the firmware that you need to.  For me I my first flash was to firmware 

                                            stock V1.0.4.2....

after that I installed the most recent version of DD-WRT to my router and it works perfectly.


After Thoughts:

I just posted this information to add to what others had here in this thread as I wanted others to see another option for getting into their router.  I tried a lot of the above mentioned methods including using PUTTY and none of them would work.  After a day of ripping out my hair as I had never used Telnet or PUTTY before I found the website above and used it to solve my issues with flashing DD-WRT to two r6300v2 Charter routers.  They both work great and I am tickled to once again have routers with DD-WRT on them.



madmax7766's picture
i register to this site just

i register to this site just to say thank you very much i searched for solutions no one give r6300v2ch owner a good solution..but yours info was to easy to follow & it worked ..changed to normal r6300v2 ..thanks again

neosimago's picture
I had to use telnetenable to

R6300V2 Charter Notes

I had to use telnetenable to get telent working on a R6300v2 Charter edition to change the boardid. The link I used is here:

This link was also very helpful flashing with tftpd once the boardid was converted, otherwise only the kong dd-wrt-K3_R6300V2CH.CHK file would flash for the initial flash with tftpd.

Mercury113's picture
I changed the board id with

I changed the board id with the linux version of telenetenable but I still cannot update my firmware through the browser interface, and I have tried every firmware for my model charter netgear r6300v2 from OPENWRT, DD-WRT, MyOpenRouter, Netgear default firmware. I've also tried the TFTP method with TFTPD-HPA/TFTP-HPA, setting my address to static, and trying to put the file to my router at while doing every single method of turning off and 30/30/30 my router. The file ends up timed out.

What other options to I have to force my firmware to change? My router isn't bricked or anything, works fine, but I want to use DD-WRT to turn it into a wifi adapter and this is proving far harder than I expected once I learned that it was a charter varation, those bastards.

Mercury113's picture
Figured out a solution to my

Figured out a solution to my problem, I erased the firmware first and than used the TFTP method to recover to another firmware.