Checking crc...Invalid boot block on disk

4 posts / 0 new
Last post
Albatorsk's picture
Checking crc...Invalid boot block on disk



I've gone done something stupid. I have a WNR3500Lv2, and so I decided to try DD-WRT. Well, mostly because I wanted SNMP, but as it turns out, the builds available on this site doesn't include that. So, as my next step, and this is when I did something really dumb, I flashed the Tomato firmware from this site through the DD-WRT Web GUI flashy-thing. After that, my WNR3500Lv2 was stuck after rebooting in a blinking green power LED.


So, I got my self a TTL-USB serial cable, and hooked it up. As it turns out, it simply booted into tftpd by itself, so I really could have just tried sending a new image by tftp without getting the TTL-USB cable, but how was I supposed to know?


Anyway, as I try to flash a new image, apparently nothing really happens. Well, of course the image is uploaded, but then not much else. No programming going on, as far as I can tell. Immediately afther the image is uploaded, it returns to TFTPD reading.


So, for some stupid reason, I tried flashing using "flash -noheader : flash1.trx" and sending the DD-WRT image, and lo and behold, instead of just returning to "reading:" after the image is sent, it actually said it was "Programming..." Wow, "progress" I thought. Well, as it turns out I've just made the situation even worse.


Now, no matter what I try, I just get "Checking crc...Invalid boot block on disk" and the regular "Start TFTP Server" "Reading ::" and of course also the network interface messages, so I can still reach it over the network.


Is there anything I can do besides throwing out this router and get a new one? Can it be salvaged? Please help!


Thank you!

Subhra's picture
Try to flash Stock Firmware

Try to flash Stock Firmware for WNR3500Lv2 as guidelines provided in this article.

Albatorsk's picture
Thanks. Unfortunately, I've

Thanks. Unfortunately, I've already tried that. After uploading the image through tftp it just returns the Image ID and Board ID (I believe, I'm not exactly sure but something very similar. I'll check later tonight), and then "Reading ::", and then it sits there forever. I've waited for over an hour after doing that and then did a 30-30-30 reset. Still no go.

What should be returned after breaking with CTRL-C, starting tftpd and uploading an image? Should it say it's programming, or should it simply print out "Reading ::" once more after the image is uploaded?

Albatorsk's picture
As it turns out, my tftp

As it turns out, my tftp client was set to send in ACSII mode instead of binary. I thought I'd made sure it wasn't, but obviously I didn't. Changing the transfer mode to binary (octet) transfer mode did the trick!