"Clean JFFS2" not working in latest Kong build

1 post / 0 new
david.woodward's picture
"Clean JFFS2" not working in latest Kong build

I just updated to the latest Kong build (06-30-2015) last night and noticed there were still files on the JFFS2 file system from the past install (despite having loaded stock, reset to factory defaults, reset button, loading new firmware, dry-rinse-repeat).

The first way I noticed the files were still there was because a script I have to SCP files back to the router after firmware wipes/updates failed on a few files due to some odd "I/O" errors.  Then I noticed the files it failed to copy were still there despite the I/O errors.  Then I noticed there were some other files there from the previous firmware that I hadn't even tried to load back.   So, clearly they were never removed during any of the resets.

So, I went through the web interface/GUI and selected the "Clean JFFS2" option.  Saved.  Applied Settings. Rebooted. And, the files were still there.

So, I tried an "Apply settings" without a save.  Still there.

Reset to factory defaults.  Still there.

Finally I tried the old 30-30-30 reset that I always used on my old Linksys router when stuff went wonky. Still there!

I eventually just manually wiped out all the files and reloaded them at which point I didn't encounter any I/O errors during the SCP process.  But, I'm still a little leary that the JFFS2 files system is broken somehow.

Is anyone else having this issue?