DD-WRT and other packages

9 posts / 0 new
Last post
lzep1968
lzep1968's picture
DD-WRT and other packages

Hi,

 

Just bought a WGR614L router and got DD-WRT running just fine on it.  I noticed that the standard WGR614L DD-WRT firmware available is the 'mini' version, which does not include all the packages I'd like to use -- mainly, I want OpenVPN support.

 

I've been reading through how to use the ipkg utility to install other OpenWRT packages, but after enabling JFFS2 and cleaning the volume, I get "cannot create directory /jffs2/usr: Input/Output Error" when trying to update the packages, even though I have 700k showing as free.

 

Does anyone know how to install OpenWRT packages with ipkg on the WGR614L, or alternately, does anyone know if the newest v24 "VPN" version DD-WRT for Broadcom chipsets will work on this model router?

Thanks in advance for any info...

lzep1968
lzep1968's picture
Hmm. No one else has tried

Hmm. No one else has tried to use the JFFS volume? You can't even write anything to it, even though it's listed as (RW)...

SirSpammenot
SirSpammenot's picture
I just tried!  No Joy.

I just tried!  No Joy.

Also, I think openVPN can no longer be installed this way according to the DD-WRT wiki page on in stalling openVPN.  Not giving up, for posterity...

<pre> 
jfields@SuSEMe:~/Documents/moko> ssh root@192.168.1.208
DD-WRT v24 mini (c) 2008 NewMedia-NET GmbH
Release: 08/08/08 (SVN revision: 10152M)
root@192.168.1.208's password:
==========================================================
 ____  ___    __        ______ _____         ____  _  _
 | _ \| _ \   \ \      / /  _ \_   _| __   _|___ \| || |
 || | || ||____\ \ /\ / /| |_) || |   \ \ / / __) | || |_
 ||_| ||_||_____\ V  V / |  _ < | |    \ V / / __/|__   _|
 |___/|___/      \_/\_/  |_| \_\|_|     \_/ |_____|  |_|
                       DD-WRT v24
                   http://www.dd-wrt.com
==========================================================
BusyBox v1.11.1 (2008-08-19 01:18:45 PDT) built-in shell (ash)
Enter 'help' for a list of built-in commands.
root@DD-WRT:~# mount
rootfs on / type rootfs (rw)
/dev/root on / type squashfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
ramfs on /tmp type ramfs (rw)
/dev/mtdblock/4 on /jffs type jffs2 (rw)
root@DD-WRT:~# cd /jffs/
root@DD-WRT:/jffs# ls -la

drwxr-xr-x    1 root     root            0 Sep  2 00:10 . drwxr-xr-x   16 root     root          153 Aug 19 08:28 ..

root@DD-WRT:/jffs# touch biscuit

touch: biscuit: Input/output error

root@DD-WRT:/jffs#
</pre> 
killianfr
killianfr's picture
Hi ^^

Hi ^^

Same problem here, I really don't know what to do :s

I tried a "stopservice jffs2" and mount it by hand but I can just get a "mounting /dev/mtdblock/4 on /jffs failed: No such device" error.

I've seen the ipkg configuration, it seems we can use the ram instead (problem : reboot = changes lost, yes, but it's better than nothing... ^^), but even with that it wants the /jffs folder to be writeable...

blackmacbook
blackmacbook's picture
Non of the firmwares from dd

Non of the firmwares from dd-wrt, regardless if the firmware named "wgr614" will work. You will brick it, flashing green power light. DD-WRT appears to be stale mate in fully supporting wgr614 as they are focusing more on the soon to be released dd-wrt v2 SP2. Current version is dd-wrt v2 SP1. I bet dd-wrt will have full support of the Linksys WRT54G2 before we see any light of day for the wgr614v8.

The modded dd-wrt from this website is probably only 85% complete, LED lights, specially the power and others do not light up.

killianfr
killianfr's picture
Yes but we're not talking

Yes but we're not talking about LEDs :P (I think the power one and the test one are just "inverted")

I don't understand why it can mount 3 partitions, but not the last one. It looks it doesn't recognize it.
Maybe the jffs2 support wasn't included in this version of dd-wrt ?

SirSpammenot
SirSpammenot's picture
I must admit I am new to DD

I must admit I am new to DD-WRT so not 100% sure where my expectations should be. I am using a laptop to WiFi and cable to v24 SP1 and all functions are working so far, except ipkg and stuff already mentioned in this thread.

my LEDs:
Power: No light
Check mark: Orange
WiFi: Green
Internet: Orange
1,2,3,4: Green when in use.

killianfr: I show a process loaded for jffs. Some support has to be there to load the module. Is all present? How to test? Hmmm

root@DD-WRT:~# ps | grep jffs
   67 root         0 SWN  [jffs2_gcd_mtd4]

blackmacbook: You know something you are not telling? :)
You have carnal knowledge of compiling DD-WRT? Any tips?

I have a small interest in getting a version with features I like, with pscan, stat and a few more busybox commands. And of course openVPN support. Making a virtualbox image that can compile firmwares sounds like a good idea to me. Easier to share.

killianfr
killianfr's picture
Well, there's jffs2 support,

Well, there's jffs2 support, forget what I said ^^

I've succeded mounting the jffs2 volume by hand (I just forget to "insmod /lib/modules/2.4.36/jffs2.o" before the "mount -t jffs2 /dev/mtdblock/4 /jffs"),
but there's always that stupid "Input/Output" error.
And because the root fs is read-only, no logfile available :S

Maybe the jffs2.o module was not re-compiled for the netgear WGR614v8, I think we'll have to wait if we can't do it... :s
(I tried to re-create a DD-WRT image for about 6 hours, but there's always a small error ^^)

FRiC
FRiC's picture
Can't you use the DD-WRT

Can't you use the DD-WRT version with VPN already compiled in?