DNSMASQ bug in Tomato Shibby build

1 post / 0 new
renda's picture
DNSMASQ bug in Tomato Shibby build

Sometimes I use the video-on-demand feature provided by my Sony internet TV to watch favorite contents. A few weeks ago this feature no longer worked any more, the TV set could not connect to ssm1.internet.sony.tv to fetch the content updates. 


After consulting Sony techman, I realized the problem was caused by the DNS part of my router's firmware. The router's firmware was updated to Tomato Shibby build 119, in which the DNSMASQ module was updated to v2.70. For convinience purpose, I added a custom DNSMASQ configuration entry like "address=/tv/192.168.xx.xx", unfortunately, in the buggy DNSMASQ version, this caused ANY domain name ended by ".tv" (e.g. "ssm1.internet.sony.tv") to be incorrectly resolved to local IP 192.168.xx.xx.


By change the configuration line to "address=/mytv/192.168.xx.xx", the problem has been worked around, but I think there's something wrong with the new DNSMASQ codes.


Thanks for your concerns.