Firmware Availability for Netgear R7800

20 posts / 0 new
Last post
michaelbonetti
michaelbonetti's picture
Firmware Availability for Netgear R7800

Hello,

Has anyone successfully used any open firmware on a Netgear X4S R7800?  I tried OpenWRT from http://www.myopenrouter.com/download/r7800-openwrt-firmware but it didn't work for me.  I'm mainly looking to set up my router as both a VPN client and server if possible.

Has anyone else had any luck with this router?

Thanks in advance!

Mike

 

 

 

 

Sayan Mukherjee
Sayan Mukherjee's picture
Could you please mention the

Could you please mention the problems except the VPN Client and Server?

VPN Server and Client is not included in the feature list of the firmware you mentioned.

 

In my setup, R7800 OpenWRT firmware( http://www.myopenrouter.com/download/r7800-openwrt-firmware ) is working fine overall.

michaelbonetti
michaelbonetti's picture
Thanks for the reply, I

Thanks for the reply, I should have been more specific.  When I loaded the R7800 OpenWRT firmware my router went unresponsive.  The power LED would blink at 1 second intervals and the wired ethernet port LED was lit where I was connected.  I could ping the router at 192.168.1.1 but could not telnet or ssh using PuTTy.  I tried holding reset button for 30+ seconds and I tried power cycleing several times always with the same result.  I ended up TFTP'ing the official firmware back on to get me back online.  Any idea what I could be doing wrong.

Let me also mention this is the first time I have tried using an open firmware on my router and thought this would be a good place to start.  Any pointer sould be greatly appreciated!  So far it has just been me and Google :)  

As far as VPN server/client that is just something I would like to have if any firware included those features, not specifically R7800 OpenWRT.

 

Thanks!

darkjacky
darkjacky's picture
I tried flashing my R7800 as

I tried flashing my R7800 as well and I got the blinking light. (This was on the 27th of January.) I flashed back the official firmware and tried again. Same result.

So there seems to be a bit of a problem there. Probably 2 hardware revisions.

 

If you manage to flash yours please let me know.

Thanks

cameronwilby
cameronwilby's picture
What version firmware were

What version firmware were you running prior to flashing OpenWRT?

I have also been unsuccessful with flashing OpenWRT onto the R7800. I'm going to try flashing official 1.3.0 first before flashing OpenWRT for the heck of it and see if that makes a difference.

I was able to flash back to official firmware by doing the following:

- Connect to the router via Ethernet Cable
- Set IP Address to 192.168.1.2
- Set Mask to 255.255.255.0
- Set Gateway to 192.168.1.1
- Enter the following into Terminal (OSX)

tftp 192.168.1.1
tftp> binary
tftp> put R7800-V1.0.0.40.img

This restored things back to normal for me. At least I have a way back when the router no longer operates :)

I find it strange that Netgear markets using something like OpenWRT for this router when it's not quite supported yet! 

Sayan Mukherjee
Sayan Mukherjee's picture
The OpenWRT firmware for

The OpenWRT firmware for R7800 is working fine in my set up.

Could you please give me the Hardware ID (if possible). Or you may also provide me the Stock Firmware link that you are using.

I will try to investigate if there is any issue related to hardware revisions.

 

Can anyone give me the details to simulate the issue?

Sayan Mukherjee
Sayan Mukherjee's picture
The firmware I am using is

The firmware I am using is currently not shown in the download link. The firmware has changed in the download link.

The current firmware is giving me the same issue in my setup.

Peter Redmer
Peter Redmer's picture
Hi everybody,

Hi everybody,

There was an issue with the original image. The current download (OpenWRT-R7800_20Jan2016.img) is the correct one and should resolve these issues.

If any of you discover issues with that build, let Tathagata and I know.

 

PaulC
PaulC's picture
I just tried upgrading a

I just tried upgrading a R7800 with the current download (OpenWRT-R7800_20Jan2016.img, MD5: 32c7a4b7aaf34933d995fbaf38c8085f)  and the router is unresponsive afterwards.

I have a steady red power light, and a steady white light that corresponds to eth1 (which is connected to a gigabit switch). No indication of a WAN link. Same setup was working fine running 10.0.0.40 on this router, which I've only had a couple of days.

I haven't tried to reflash it back to the official 10.0.0.40 image. Frankly I'm not sure I want to go back - the official Netgear firmware was completely underwhelming, compared to the Asus RT-AC87U running the RMerlin firmware I was running (and have returned to).

If I can't get a reasonably current OpenWRT on there, I'll be returning it. Which would be a shame, I like the hardware, but I'm disappointed by the official firmware, especially on a premium product. Maybe I should just find some (non-Broadcom) hardware that OpenWRT Chaos Calmer already officially supports.

- Paul

shev
shev's picture
Yeah in the same boat,

Yeah in the same boat, absolutely nothing out there for this router.  I like the hardware and got a good price but its pretty bare on advanced features.  I was actually able to get the current WRT release to work but its 12.09 which is quite old, and 5ghz wifi radio wouldn't activate.

PaulC
PaulC's picture
You've gotten further than me

You've gotten further than me, Shev. I pulled the Netgear GPL code for 10.0.0.40, but it won't even build scripts/config:

cc -DKBUILD_NO_NLS   -c -o conf.o conf.c
cp zconf.tab.c_shipped zconf.tab.c || bison -l -b zconf -p zconf zconf.y
cp lex.zconf.c_shipped lex.zconf.c || flex -L -Pzconf -olex.zconf.c zconf.l
cp zconf.hash.c_shipped zconf.hash.c || gperf < zconf.gperf > zconf.hash.c
cc -DKBUILD_NO_NLS   -c -o zconf.tab.o zconf.tab.c
In file included from zconf.tab.c:157:0:
zconf.hash.c:159:43: warning: ‘kconf_id_strings_contents’ is static but used in inline function ‘kconf_id_lookup’ which is not static
 #define kconf_id_strings ((const char *) &kconf_id_strings_contents)
                                           ^
zconf.hash.c:226:44: note: in expansion of macro ‘kconf_id_strings’
               register const char *s = o + kconf_id_strings;
                                            ^
zconf.hash.c:219:26: warning: ‘kconf_id_hash’ is static but used in inline function ‘kconf_id_lookup’ which is not static
       register int key = kconf_id_hash (str, len);
                          ^
zconf.hash.c:175:26: warning: ‘wordlist’ is static but declared in inline function ‘kconf_id_lookup’ which is not static
   static struct kconf_id wordlist[] =
                          ^
cc   conf.o zconf.tab.o   -o conf
zconf.tab.o: In function `zconflex':
zconf.tab.c:(.text+0x22f5): undefined reference to `kconf_id_lookup'
zconf.tab.c:(.text+0x2447): undefined reference to `kconf_id_lookup'
collect2: error: ld returned 1 exit status
<builtin>: recipe for target 'conf' failed
make: *** [conf] Error 1
 
Still being frustrated, I haven't attempted to fix what's broken yet. But knowing it can be fixed is helpful :)
 
Agreed, 12.09 lacks the useful stuff added in 14 & 15. Though looks like QC/Netgear has provided prebuilt packages for some proprietary stuff like QC's version of fq_codel.
 
If the lack of 5GHz support is intentional, that's very frustrating.
 
- Paul
morkdub
morkdub's picture
Does anyone know if the

Does anyone know if the latest release of OpenWRT (v15.0.5.1) can be successfully used for the R7800? At the moment there's nothing to indicate that.

 

I've checked the release notes, but it's not listed in the "Support for new devices" section:

https://forum.openwrt.org/viewtopic.php?id=63415

 

However, there appears to be a NETGEAR reference that previous issues mentioned above were resolved?

http://www.snbforums.com/threads/openwrt-firmware-for-netgear-r7800-offi...

 

Also, which download branch will it follow? Some quick research discusses Qualcomm hardware with an ARMv7-A microarchitecture:

https://wikidevi.com/wiki/Netgear_R7800

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/x4s-vs-r7000/td-...

https://en.wikipedia.org/wiki/ARM_Cortex-A15

PaulC
PaulC's picture
The R7800 firmware is based

The R7800 firmware is based on OpenWRT 12.09 (Attitude Adjustment) that Qualcomm Atheros forked and has added significant amount of code to support their hardware acceleration features in the silicon. Much of it is proprietary, and only provided in binary form, which could cause problems trying to move to 15.05 unless you work for Qualcomm.

As far as I know, Qualcomm has said nothing about 15.05, if or when.

I've built the 'GPL software' tarball that Netgear has provided, and installed it on my X4S.

I put the Netgear tarball up on github, here: https://github.com/paul-chambers/netgear-r7800

For now, I've just unpacked Netgear's tarball, made sure it builds/installs/runs, then pushed the source to Github. I haven't made any changes yet, too busy with other things. At some point, I'll get some time to hack on it. First thing will be to disable that silly 'telnetenable' nonsense. No idea why they put effort into that rather than simply enabling dropbear.

From make meunconfig, Target System is set to 'QCA IPQ806X', Target Profile is 'Qualcomm-Atheros SDK Retail Profile'

I've heard that OpenWRT engineers are reluctant to support hardware acceleration, since every vendor does it in radically different ways. However, QCA has taken a nice approach that maintains the standard linux low-level networking APIs, while still offloading the performance-critical stuff to hardware. If true, then supporting the hardware packet processing acceleration provided in the IPQ806x series in OpenWRT 15.05 may not be so hard. Some info here:

http://people.netfilter.org/pablo/netdev0.1/slides/IPQ806x-Hardware-acce...

- Paul

morkdub
morkdub's picture
Unsure if it matters that

Unsure if it matters that much, but I just noticed Netgear released v1.0.1.28 for the R7800.

http://kb.netgear.com/app/answers/detail/a_id/30470

Here's the source code link:

http://www.downloads.netgear.com/files/GPL/R7800-gpl_src.tar.bz2_V1.0.1....

I'm still very interested in Netgear's reference to the "known issue" being resolved, the updated notification message on this site, and if they'll continue using the OpenWRT v12.09 line.

I'm also short on time these days, but I might be able to play with this latest Netgear tarball in a couple of weeks. I can at least do some test firmware build deployments since they don't take long and see what happens.

PaulC
PaulC's picture
The 'known issue' was that

The 'known issue' was that the file initially made available on MyOpenRouter for the R7800 was mangled, and a few users had to recover their routers after uploading it. The resolution was to simply upload a 'good' version of the file. AFAIK, that's the long and the short of it.

I'll update the github project with the contents of the 1.0.1.28 tarball sometime in the next few days:

https://github.com/paul-chambers/netgear-r7800

dissent
dissent's picture
Uploaded 12.09.1 version from

Uploaded 12.09.1 version from this site and it works, though LEDS don't work as intended, only power (orange) and switch LEDs are working. To enable wifi you have to reset device twice: 1st with reset button and then from web interface.

Tried to dig in a bit and found that because of some access permissions in fs, several points can't be accessed leading to failure executing them some startup scripts, i.e. pwrctl and LED. 

Could it be solved somehow or is it just me with broken LEDs and such?

 

btw, any idea if current trunk openwrt build for D7800 can be flashed even without wireless support?

ColeJJones
ColeJJones's picture
I love my R7800 X4S with

I love my R7800 X4S with DDWRT! http://www.desipro.de/ddwrt/K3-AC-IPQ806X/

My current firmware reads DD-WRT v3.0-r30080M kongat (06/30/16) on my DDWRT webpage

PaulC
PaulC's picture
The latest DD-WRT build is

The latest DD-WRT build is here:

http://download1.dd-wrt.com/dd-wrtv2/downloads/betas/2016/12-15-2016-r30...

I've been running DD-WRT on my R7800 for a while now. Updates have been coming out every few weeks. Despite being labeled as beta, It seems to be stable and performs well, despite not taking advantage of all the hardware acceleration the platform offers.

- Paul

cyris69
cyris69's picture
I know this is bringing up an

I know this is bringing up an old topic but how to I flash the factor-to-ddwrt.bin file? When I upload to the R7800 as you would any other stock update it just says incorrect file returning to previous page.

 

I'm running stock still as I bought it maybe a month ago 

Router Firmware Version

V1.0.2.20

machasm
machasm's picture
You need to flash with this