"This firmware file is incorrect!" R6300v2 For DD-WRT

Subscriptions

Subscribe
38 posts / 0 new
Last post
BarakaAka1only
BarakaAka1only's picture
"This firmware file is incorrect!" R6300v2 For DD-WRT

Hello everyone!

Well i just gotten my R6300v2 router US version which have currently this firmware installed 

V1.0.3.6_1.0.63CH

For some reason i am unable to install the DD-WRT firmware on it. To be honest i am new to this DD-WRT scene. I've tried all versions for my router model of DD-WRT which is only two that i've seen, The Kong/K3 one and the Tathagata Das one and no lucky i just keep getting :

This firmware file is incorrect! Please get the firmware file again and make sure it is the correct firmware for this product.

I am not sure what is wrong but i really need some help on this! The only thing i can install is the original firmware named "R6300v2-V1.0.3.6_1.0.63CH.CHK" which was obtained here : ftp://downloads.netgear.com/r6300v2/chnas/ 

and yes i have looked at http://www.desipro.de/ddwrt/K3-AC-Arm/ and none of them work either... and yes i have reseted the router, cleared settings, even cache etc on my end as well as trying on 3 other computers and no luck all connected by ethernet 

I'm not sure the current DD-WRT's are not for the chnas version or what?

Any help on this will be appreciated!

-Baraka 


Accid
Accid's picture
Back to basics

Back to basics
try a 30/30/30 reset and turn the router off after the last reset for 5 minutes.

BarakaAka1only
BarakaAka1only's picture
Yeah, i found somewhere to do

Yeah, i found somewhere to do that, and that didn't help at all :S

Kong
Kong's picture
I just looked at the R6300v2

I just looked at the R6300v2-V1.0.3.6_1.0.63CH.CHK build and this one has a different header, thus new variant.
The question is whether it has different configuration/init params as the regular R6300V2. I can only heck if I get a nvram dump. Not sure if telnet enable works on this unit or if you can only get the dump trough serial console.

If it is the same, then it is a small change in the code to also add support for this unit.

BarakaAka1only
BarakaAka1only's picture
Kong said: I just looked at

Kong said: I just looked at the R6300v2-V1.0.3.6_1.0.63CH.CHK build and this one has a different header, thus new variant. The question is whether it has different configuration/init params as the regular R6300V2. I can only heck if I get a nvram dump. Not sure if telnet enable works on this unit or if you can only get the dump trough serial console. If it is the same, then it is a small change in the code to also add support for this unit.

Interesting, thanks for replying Kong, well i am not sure how to even do telnet enabling, i have looked at this http://wiki.openwrt.org/toh/netgear/telnet.console and tried it but i can't get it to work as it "send failed: 10057" and "Connecting To 192.168.1.1...Could not open connection to the host, on port 23: Connect failed" i also don't have a serial console to do it :(. But i am willing to try anything to help, if you could do a small change to the code to see what happens that will be great.

Kong
Kong's picture
I think the best would be if

I think the best would be if you get a cheap USB-TTL adapter from ebay, this will make it easy to dump info and do some advanced stuff with it. The adapter is only a few bucks and on the R6300V2 there is already a pin header + it is very easy to open up the case. So not an easy task to hook it up.

GAHelm
GAHelm's picture
FWIW - I seem to recall

FWIW - I seem to recall reading on the Netgear forum that the firmware release he is using from Netgear is specific to the product sold in China.

BarakaAka1only
BarakaAka1only's picture
Kong said: I think the best

Kong said: I think the best would be if you get a cheap USB-TTL adapter from ebay, this will make it easy to dump info and do some advanced stuff with it. The adapter is only a few bucks and on the R6300V2 there is already a pin header + it is very easy to open up the case. So not an easy task to hook it up.

Any idea which USB-TTL Adapter that works/to get? I've never done anything like this and i have been looking around and my version haves only a hardware revision : hardware version R6300-2CHNAS ----> U12H240T70_NETGEAR  while the hardware version r6300v2 ----> U12H240T00_NETGEAR.

I don't know if that changes things for you...

kamaaina
kamaaina's picture
You would want something

You would want something equivalent to this, check eBay as well but make sure it's 3.3v and a decent chip with proper drivers for your system.

chiner
chiner's picture
Unfortunately, I have run

Unfortunately, I have run into the same issue as BarakaAka1only with the CH version.

I just amazon prime'd the TTL cable that kamaaina suggested. I will report back once I figure out how to do a nvram dump... please provide any helpful tutorial links if anybody has them handy.

chiner
chiner's picture
delete

delete

chiner
chiner's picture
Okay, I think I got this

Okay, I think I got this sorted out... I've never gotten this deep into a router before, so lmk if something is missing or incomplete.

boot log: http://pastebin.com/ATj3jXGk
nvram.bin: http://s000.tinyupload.com/index.php?file_id=78325355624482284065

I tried copy/pasting the nvram.bin, but the file is full of a bunch of weird symbols. Is this correct, or did I slip up somewhere? I used "cat /dev/mtd1 > /tmp/nvram.bin", and then I copied this to my usb stick.

Also, one little trick I used for the serial connection was these guys to interface between the board and serial converter so that I didn't have to cut a perfectly good cable and lose the female adapter.

rftech
rftech's picture
the ch in the end of the

the ch in the end of the firmware revision is a special revision for "charter communications" most likely something in the firmware so it can be updated via the WAN port as I have heard that we will be able to update a customers router firmware remotely so customer service can handle it over the phone.

Daviel
Daviel's picture
I have this same firmware

I have this same firmware number V1.0.3.6_1.0.63CH. I bought the router used from amazon.com. I contacted Netgear support and this is what they said:
"Based on the firmware of your device, we were able to identify that your unit is not a retail product. This type of unit is engineered / customized based on the needs of an Internet Service Provider which is charter and can only be obtained through them. We cannot revert the firmware since this is engineered by the ISP configuration."

I also found this info on this forum: http://www.dd-wrt.com/phpBB2/viewtopic.php?p=903699

"Charter probably has their own board_id assigned. If the firmware you are trying to load doesn't match then it won't work. The board_id for the R6300v2 is U12H240T00_NETGEAR. If you can SSH or telnet into the router you can get the board_id by entering "nvram get board_id", no quotes of course. There have been success stories of folks that have changed the id via telnet or SSH and then doing the update on routers not supported but having same hardware. Specifically successfully done on the AC1450. I would wait and see if kong has any input before trying that.

If you do decide to change the id I would keep a record of the Charter id in case you need to revert."

Hope this helps. I still haven't been able to change the firmware at all though. If anyone figures it out, please let me know. If not, I'll probably just return it and buy a new one.

kiper
kiper's picture
you can not telnet into the

you can not telnet into the router i have tried for 2 days charter has blocked it so i presume serial connection is the only way.i havent tried using the wan port yet only the lan ports ill try again via the wan it is a charter box be careful of what you buy online you can look at the botom or somewhere for the wifi name and it will show mycharterwifixx-2g and 5g if it shows this you were sold a unit that was stolen from charter.while it works fine you cannot upgrade firmware or use netgear genie on it.which is why i will change the board id and put stock netgear firmware on it just so i can use the netgear genie and the genie app on my phone.good luck cracking/hacking this version you can pick up an ac1450 for $60 on ebay and telnet to change the board id as they are the same router just differnt firmware they have the same board.i may have to do this and return this router to charter and save $5 a month lol

Daviel
Daviel's picture
I have this same firmware

I have this same firmware number V1.0.3.6_1.0.63CH. I bought the router used from amazon.com. I contacted Netgear support and this is what they said:
"Based on the firmware of your device, we were able to identify that your unit is not a retail product. This type of unit is engineered / customized based on the needs of an Internet Service Provider which is charter and can only be obtained through them. We cannot revert the firmware since this is engineered by the ISP configuration."

I also found this info on this forum: http://www.dd-wrt.com/phpBB2/viewtopic.php?p=903699

"Charter probably has their own board_id assigned. If the firmware you are trying to load doesn't match then it won't work. The board_id for the R6300v2 is U12H240T00_NETGEAR. If you can SSH or telnet into the router you can get the board_id by entering "nvram get board_id", no quotes of course. There have been success stories of folks that have changed the id via telnet or SSH and then doing the update on routers not supported but having same hardware. Specifically successfully done on the AC1450. I would wait and see if kong has any input before trying that.

If you do decide to change the id I would keep a record of the Charter id in case you need to revert."

Hope this helps. I still haven't been able to change the firmware at all though. If anyone figures it out, please let me know. If not, I'll probably just return it and buy a new one.

kiper
kiper's picture
you can not telnet into the

you can not telnet into the router i have tried for 2 days charter has blocked it so i presume serial connection is the only way.i havent tried using the wan port yet only the lan ports ill try again via the wan it is a charter box be careful of what you buy online you can look at the botom or somewhere for the wifi name and it will show mycharterwifixx-2g and 5g if it shows this you were sold a unit that was stolen from charter.while it works fine you cannot upgrade firmware or use netgear genie on it.which is why i will change the board id and put stock netgear firmware on it just so i can use the netgear genie and the genie app on my phone.good luck cracking/hacking this version you can pick up an ac1450 for $60 on ebay and telnet to change the board id as they are the same router just differnt firmware they have the same board.i may have to do this and return this router to charter and save $5 a month lol

TXUSA
TXUSA's picture
I am pretty sure it is not

I am pretty sure it is not Charter's fault. Netgear has changed the telnet access on its newer routers, so the "traditional" Windows exe no longer works (I am pretty sure that was what Netgear wanted in the first place). There are modified scripts floating around though (think google) where clever minds have adjusted the parameters to enable telnet. And supposedly they work... I have yet to try.

newbreedsoftware
newbreedsoftware's picture
any update on how to remove

any update on how to remove the V1.0.3.6_1.0.63CH firmware and use Netgears bone stock 1.0.3.30 firmware?

sp33dk1ngp1n
sp33dk1ngp1n's picture
I am also interested in a

I am also interested in a solution...

sp33dk1ngp1n
sp33dk1ngp1n's picture
Figured it out. Here's how it

Figured it out. Here's how it works, briefly. Connect serial over USB cable to proper pins on your r6300v2 board (you have to flip it over and there's no mistaking the uart pins). Get an ash prompt (busybox) over serial and
# burnboardid U12H240T00_NETGEAR
Then reboot sending ctrl-c until you get CFE prompt. Send "tftpd" to the prompt to start the tftp daemon, it should display "Reading:". Send firmware over tftp client. I used K3_R6300V2_1-Jul-2015.chk. If you changed the board id, you'll see "Programming..." and some other messages followed by a reboot. Let it reboot, until it stops scrolling shizz. Then just put that thing back together and boom you got  some nice DD-WRT goodness. 

TXUSA
TXUSA's picture
I ended up flashing the "Kong

I ended up flashing the "Kong" DD-WRT on my Charter branded 6300v2 (noticable by the blue stripe on the bottom front)... and it works ok. It tricks the update into thinking that the board ID from Charter is correct... the update is painless. Look for the "CH" addition in the filename. It is easier than changing the board ID, although changing the board ID opens the door to more DD-WRT and stock netgear firmware options (I haven't seen the CH firmware updated in quite a while).

TXUSA
TXUSA's picture
is there ever going to be an

is there ever going to be an update on your 6300v2 CH firmware ? I only see the "regular" 6300v2 being updated.

TXUSA
TXUSA's picture
Are there any more updates

Are there any more updates for the CH (Charter) 6300v2 firmware on your end ?

thekiosk
thekiosk's picture
Hi Dude, 
Hi Dude, 
Here is my story, it may help answer your question. 
1. I've got R6300v2CH from amazon and initiate to DD-WRT by http://www.desipro.de/ddwrt-ren/K3-AC-Arm/Initial/dd-wrt.K3_R6300V2CH.chk >>>> No problem, it look good. 
2. I've moved from DD-WRT initiate version back to stock ROM version R6300v2-V1.0.4.2_10.0.74 >>>> No problem, it look good. 
3. I've tried to move from stock ROM version R6300v2-V1.0.4.2_10.0.74 to DD-WRT by using http://www.desipro.de/ddwrt-ren/K3-AC-Arm/Initial/dd-wrt.K3_R6300V2CH.chk >>>> No problem, it look good. 
4. At this point, you can upgrade your DD-WRT to any version!!! 
 
What I try to tell you is "IF your router is Charter ISP version, you have to follow http://www.desipro.de/ddwrt-ren/K3-AC-Arm/Initial/dd-wrt.K3_R6300V2CH.chk to initiate DD-WRT" 
 
^__^
icfi
icfi's picture
I had the same problems with

I had the same problems with my R6300v2 (Blue) Charter Router from amazon.
To cut to the chase, what I found as a solution in downloading http://www.desipro.de/ddwrt-ren/K3-AC-Arm/Initial/dd-wrt.K3_R6300V2CH.chk is to use a different Browser other than Edge.
I have Win10 and to get this file to download so that I could flash it, I used Opera. It did work!
TheKiosk is absolutely correct in using this file to do the "Initial Flashing " for this Router.
Try this and I'm sure it will save you from some frustration in trying to do the " Initial Flash".

jamesfo0
jamesfo0's picture
use telnetenable

use telnetenable

run command

telnetenable 192.168.1.1 ROUTERSMACADDRESS admin password

then use putty to connect to telnet 192.168.1.1 port 23

type command 

burnboardid U12H240T00_NETGEAR

then type command

nvram set board_id=U12H240T00_NETGEAR

then you should be able to update your charter netgear R6300v2CH from 1.0.3.6CH to the standard V1.0.4.2 and then install DD-WRT for R6300v2

jamesfo0
jamesfo0's picture
I was able to convert my

I was able to convert my R6300v2CH to a standard R6300v2 using this method changing the board id. No serial cable is needed although if you brick it or go into a reboot loop like I did installing dd-wrt for R6300v2CH its totally necessary to have one.

XeoNoX
XeoNoX's picture
got the charter version

got the charter version R6300v2 router to upgrade.

1) i reset to router defaults

2)i flashed from the netgear router's WEB GUI the file dd-wrt.K3_R6300V2CH.chk

3)then from the DDWRT web GUI i flashed the official R6300v2 fimrware from netgear site called R6300v2-V1.0.4.8_10.0.77.chk

4) i waited about 3 minutes (do not wait less than 3 mins, has to be 3 or more mins to let router reboot), after the 3 mins i unplugged power from router and plugged back in power and when the router powered up after about another 3 mins i hit the RESET BUTTON to reset everything. 

5) congrats your now running latest official R6300 v2 firmware from netgear.

 

 

 

XeoNoX
XeoNoX's picture
theres no edit button. so to

theres no edit button. so to clarify step # 4, what i meant was i wated 3 mins after flashing the official netgear firmware,  then i unplugged the router and waiting and ADDITIONAL 3 mins after pluggig power back in. so thats 6 mins total. waiting time affter having to wait 3 mins two times.

fixingstill
fixingstill's picture
Thank you. It works perfectly

Thank you. It works perfectly.

Pages