Firmware Update for ZIGGO WNR3500v2 Routers

3 posts / 0 new
Last post
konrad.holl's picture
Firmware Update for ZIGGO WNR3500v2 Routers

After spending almost a day trying to replace the firmware on a ZIGGO branded WNR3500v2 I'll just let you know my findings in case anyone may need it. It all comes down to one byte in the firmware file.

After enabling telnet and erasing linux, the WN3500v2 was still alive (not bricked):

  • Power LED blinking green
  • ping gets replies
  • Uploading firmware files with tftp works great, taking about 2 or 3 seconds

But: After uploading the firmware nothing happens. I tried:

  • 30-30-30-10-10 reset
  • Repeated uploads
  • Renaming the firmware file
  • Running tftp immediately after router boot

Well, after some further (I some case frustrating) research I found this forum thread:

ZIGGO Users:

ZIGGO seem to have their own board identifier (apparently written on the board) which must be matched when a firmware is uploaded. Edit the firmware file using a HEX Editor (I used HxD, ) and find the string starting at offset 0x28:


Change it to (modifying only one byte at offset 0x30):


And save the firmware file.

Now upload the modified file using tftp and you're set after a few minutes.

Hope that helps,


Dirk123's picture
Thanks Konrad,

Thanks Konrad,

you helped me a lot with that issue - worked perfectly.



Sebastian-St's picture
Hi Konrad,

Hi Konrad,

I found this post by a search of problems flashing ziggo branded Netgear piece. The Router didn't get into TFTP Mode. What might i have done wrong? The other questiion is, is it possible to install all kinds of firmware (original netgear wnr 3500; open wrt?). It would be nice i you would contact me private.

Best regards from Detmold