getting Dynamic DNS working on a tomato router behind a Verizon FIOS router

2 posts / 0 new
Last post
armyofda12mnkeys
armyofda12mnkeys's picture
getting Dynamic DNS working on a tomato router behind a Verizon FIOS router

Hey all,

I been running KODI on my amazon Firestick by connecting it not to my regular Verizon FIOS/Wireless Actiontec router, but instead to my NETGEAR WNR3500L wireless router which is running Tomato firmware (and that tomato router is connected to my Verizon Router.

I setup this separate router so I can have the firestick/KODI go through an Amsterdam VPN . So its slower than regular connection.

For my other computers/laptops on the network, I connect directly to the Verizon Wireless router.

###########

The above setup works out great... But now I want to setup DDNS and Port Forwarding on the Tomato router... so I can use like a Dynamic DNS service like no-ip.org and Remote Desktop to my desktop box via TCP port 3389.

But I realized even though I set this DDNS and Port Forwarding stuff up on the Tomato router, it doesn't matter as outside the world can't reach the Tomato router (only the Verizon Router which won't know how to forward that RemoteDesktop request).

Is there a way to setup so requests to myusername.no-ip.org on the Veritzon ActionTec box get routed to the Tomato router (which then has the settings to appropriately forward to my static ip box ... without using like a DMZ setup.

I went to the Port Forwarding section of my verizon box (192.168.1.1) and setup to forward to the IP address of the Tomato router (192.168.0.1) for the port 3389.
I also tried forwarding to my box directly which has a static ip (192.168.0.2) set via Tomato as the Port Forward ip in Verizon Port Forward settings and still doesn't work. Any idea what to set to get this to work?

PS I'm testing via 'telnet myusername.no-ip.org 3389' and also my Android Phone's Remote Desktop app with no response. Telnet does say 'Trying ##.##.##.##.##' (my WAN public IP address so I know Tomato's DDNS settings are working to send up the public WAN i.p. to no-ip.org (set via the 'External IP Address Checker every 10minutes' setting) so it can resolve the IP when contacting the host ... 

But it doesn't actually get forwarded correctly and connect I think.

 

Thanks,

Ari

armyofda12mnkeys
armyofda12mnkeys's picture
Some additional info:

Some additional info:

When i do ipconfig on my desktop box, I see the Default Gateway is the ip of the Tomato router (192.168.0.1).

Yet if log into the Verizon Router, it says the Tomato Router's IP is 192.168.1.191. I also tried that as the port forward ip instead of what I thought was the IP i should use 192.168.0.1, and didn't work as well with that IP.