getting error "can't resolve symbol 'cfsetspeed'

2 posts / 0 new
Last post
amitsekhon's picture
getting error "can't resolve symbol 'cfsetspeed'

I am running an application(uses serial port for comunication) on wrt54gl using openwrt.But i wanted to use it on wrt310n as its only supported by ddwrt.So i tried to run on wrt310n with ddwrt(v24std) but when i run that app i get "can't resolve symbol 'cfsetspeed'.I have coped my app to jffs partition.I have an another e3000 router so i loaded it up with latest kong build for e3000 and i copied my app to the jffs partition and when i tried to run...boom....just ran fine.So i am wondering what could be missing on ddwrt (std) or inother words what can i add to ddwrt std so that i can run my app on wrt310n.Thanks a lot for taking your time....



Subhra's picture
As far my knowledge concerns,

As far my knowledge concerns, I can say that this is an indication that linker is unable to find the symbol in any of the libraries it is told to link.

The problem may caused by a number of reasons. Better solution is to compile the source code of concerned application in your target distribution and then use it.