Has anyone tried AdvancedTomato on the R8000?

13 posts / 0 new
Last post
LloydV's picture
Has anyone tried AdvancedTomato on the R8000?

Appears to now be available https://advancedtomato.com/downloads/router/r8000.



laprius's picture
Nice pickup! Downloaded and

Nice pickup! Downloaded and going to give it a flash tonight. Sadly Shibby didn't work at ALL for me on my R800 - an agonising day spent flashing, thinking it was bricked, then reflashing...and repeating...looks pretty cool. I'll report back if it installs nicely!

laprius's picture
Bummer...same issues.

Bummer...same issues. Flashing was fine and looked like it was going to work until I saved pppoe settings for my ISP. Router did unexpected reboot and looped until I unplugged DSL modem. Plugged modem back in after reboot and was okayish except didn't seem to be reflecting connection status properly and some changes caused the same reboot/bootloop issue. Shame, I really liked the interface and have been a tomato/Shibby fan for a long time.

Nullity's picture
How did you go about flashing

How did you go about flashing AdvancedTomato onto the R8000?  I've been wanting to do this, but the download page is missing the "initial" flash file that is required by other builds/devices.  I didn't know if the author forgot to put it on the page, or maybe it just isn't needed for the R8000, or possibly you just flash the Shibby "initial" file, then AdvancedTomato.  In any case, I've been reluctant to try it, because I can't find details on this anywhere, and I didn't want to end up bricking this expensive router.

Could you please detail how you did it?

laprius's picture
No point really I'd totally

No point really I'd totally avoid for the time being - seems there's an inherent issue with Shibby/Tomato for a lot of R-series routers that means if you have an active WAN cable plugged in on reboot, it will bootloop until the WAN is unplugged. There's also random reboots too. If you want to follow I'd suggest keeping tabs on Shibby's issue page:


Once it's fixed there it will trickle through to AdvancedTomato, but Shibby's a busy person and might take a while.


dauhee's picture
Stay clear of this folks. I

Stay clear of this folks. I flashed tomato-R8000-AT-ARM7-3.4-140-AIO-64K as per instructions. Wifi mysteriously buffers at random times, making it look like somebody is pulling the wan cable, while wifi signal is strong. I put this on hoping it would get better coverage on my house than the stock which it does marginally but at the price of awful buffering.

The irony of it is, I have WRT on a 20Eur TP-Link router that has greater coverage and is more reliable. So my R8000 which costs 200Eur more is actually inferior.

dauhee's picture
FYI, I tried tweaking

FYI, I tried tweaking settings such as channel width 20/40, preamble to long etc as suggested in some posts on optimization but nothing stopped the buffering. I also upped the power to 80 for signal strength, did the usual position altering of antennas etc

Excellent work by Shibby, but just not ready for prime-time in my opinion. R8000 is dissapointing. At least on tomato there isn't the security dubious capability to connect in remotely via netgear account.

R8000in802's picture
Yes, I did it! My R8000 is up

Yes, I did it! My R8000 is up and running. The 30/30/30 reset button procedure is very important. I thought I bricked it, but was saved after the 30/30/30 reset. Also, allow router to set for 3-5 minutes after reset/flash/reset before you continue. Finally, yes there is an initial file then bigger flash file.

First file: R8000-1.28.AT-ARM7-3.5-140-initial-64K.chk
Second file: R8000-AT-ARM7-3.5-140-AIO-64K.trx.

Find files here: https://advancedtomato.com/downloads/router/r8000 

R8000in802's picture
How do I know if I have the

How do I know if I have the buffering problem? I flashed version 3.5-AIO-64K. Maybe it's fixed now? I do seem to have some trouble with Chromecast.

sgarrand's picture
Is anyone stuck on 100 Mbps

Is anyone stuck on 100 Mbps for all LAN ports? I have 300 Mbps but I'm limited to 100 by the router. Wireless is pulling ~270+ Mbps.

prox's picture
I have a fiber connection and

I have a fiber connection and before flashing I was pulling just about 1GB on a LAN port and 350MB over Wifi.  Now?...on a LAN port I cant pull more than 400MB...Wifi about 25MB.  Stay clear of this firmware if you care about bandwidth.

siqueira's picture
Hello All,

Hello All,

I was using Tomato and my router had to be rebooted every 24h or so. Besides, it wasn't reaching the full spped of my internet. Then I decided to flash Advanced Tomato (3.5-140). First I reversed to factory firmware (latest version) w/o any problem. I tested internet speed and it reach the full download I have contracted. Then I followed the instructions to flash the basic AT firmware, which worked fine. The last step was to flash AIO 3.5-140 Adv.Tomato. After I did it, the router entered in an endless reboot. It's looping. I just can't access anything in it. I tried a hard reset, but it still keeps rebooting.

I need help to understand what happened and how to fix it.

Thanks in advance,


prongato's picture

I had the exact same experience on my R8000.  I followed the well estabilished guide to interface via USB/Serial cable and access the header on the mainboard of the router. https://www.myopenrouter.com/article/how-set-serial-console-netgear-r8000 I had an extra 4 pin connector from building PCs and used that to connect to the Tx Rx and ground pins.  I soldered that to a simple phono jack (tip and ring) and drilled a 1/8" hole on the rear of the router for mounting the jack.  I purchased this cable to use via USB and Putty on a windows PC.


There are other ways to interface with the serial header on the mainboard but I wanted a more permanent solution for debricking my router, in case I run into issues in the future. 

This is the write-up where I got the instructions to use a phono plug for a solution that will make it possible to interface the serial connection without having to take your router apart every time: https://www.myopenrouter.com/article/how-debrick-or-recover-netgear-r7000-r6300v2-or-r6250-wi-fi-routers

I hope this helps!  Please let me know if you have any other questions.