Internet speed problem

8 posts / 0 new
Last post
KeithK's picture
Internet speed problem

I want to setup a whole home VPN (planning to use PIA). I have a R7000 I am not using since changing ISP's recently, so I figured I would start by flashing it to the latest kong dd-wrt firmware. Looks like I did that successfully, admin page comes up and works normally, I can connect via ethernet and wifi and get to the internet.

The issue is the speed. If connected to the R7000 my speedtests are all about half of what they are if I connect directly to the ISP modem (always testing like for like, same maching getting its cable moved, or same machine switching from one routers wifi to the other, etc). Is there something I'm missing in the R7000 dd--wrt software I'm missing that explains why I'm at half speeds?


KeithK's picture
After sitting on the phone

After sitting on the phone with my ISP I was finally able to rule out double NAT being the problem. I have NAT turned off on the ISP router now, but it didn't make any difference.

This is a gigabit connection, so my next question for Netgear tech support tomorrow is whether this router can even support those speeds I guess (it's either call them or reflash it back to default to test).

Beyond that, maybe it's the router getting choked down having to do NAT over software because its dd-wrt now? Anyone have an R7000 running in gateway mode with dd-wrt on it that is getting above 450mb in a speedtest? That's where my wired cap is, where that same wired device tests at 950 through the ISP router directly. Wireless cap is ~300, where that same wireless devices tests at 350 through ISP router directly.

epsilonkore's picture
My R8000 also runs at half

My R8000 also runs at half speed now. I have gigabit to my house, and with the Netgear firmware I could regularly hit 950Mbps, with DD-WRT (KongMod March 2017 edition) I cant make it above 450Mbps. My network performance tools show that DD-WRT is providing a MUCH smoother (fewer spikes and valleys) compared to the Netgear Genie firmware, but it doesnt even make it to half the speed.  My wireless is also less, but right now my main focus is to get the wired connection back to full speed.

killerdevildog's picture
So i was having this problem

So i was having this problem also. Tried both tomato and DD-WRT. What i found after hours of research is DD-
WRT cant hanndle these speeds. As far as tomtao there is a option in advanced miscellaneous called CTF(Cut through Forwarding). This fixed it for me. let other know if it worked for you. Im usung the newest Tomato AIO by shiby currently.

deathdealer35's picture
that makes sense i was using

that makes sense i was using stock and was able to pull in 1gb, tomato i was able to pull in 1gb, ddwrt seems to be capped at 450


i found tomato to be unstable, would drop my internet often

killerdevildog's picture
I had alot of problems with

I had alot of problems with tomato wireless on AC. I changed country to US scaned for channel not being used. Then i increased tramit power seems to have fixed it. Was your problem on wired also?

bgram's picture
I have dd wrt R7000 with 100

I have dd wrt R7000 with 100/6mbps  ISP, when I use PIA vpn my speeds go down to 20mbps/6mbps. looks like no drop on upload speed but downloads are pretty slow. Any suggestions ? I see some commenst on using Tomato but is it stable ?

FuShiLu's picture
I'm going to suggest trying

I'm going to suggest trying another provider for your VPN. Seems to be a theme around here. You have neutered your ISPs modem right??!!!!