iPhone Remote App

7 posts / 0 new
Last post
clockwork's picture
iPhone Remote App

I recently replaced my Apple Airport Basestation with a WNR3500l using the Tomato Firmware on it.

Since that, I used to have the problem that I can't use the Remote App on my iPhone anymore to remote my iTunes.

Strangely this Problem appears only on LAN.
If my iPhone is connectet to the Wireless of my Tomato and my computer with iTunes on it is also connected to the Wireless LAN, everthing will work fine.

But as soon as I connect my Comuter thrugh an RJ45 LAN Cable on my Tomato, the Remote App wont find my iTunes anymore.

iTunes will find my iPhone so I am able to type in the 4 digits passcode to connect, but after it the iPhone loads and loads and loads but wont be able to connect successfully.

It looks to me that Tomato blocks some protocols on LAN but not on WLAN.

Has anyone an idea?

Jishnu's picture
Its because every app like

Its because every app like that requires the computer to be on the same wireless network. I am sure the app would stop working if you tried to control iTunes after connecting to a different wifi connection. It would also not work if you are on the same wireless ENTERPRISE network. I remember I could not get it to work when I live in the dorms. I think all these apps like Remote, vlc, HippoRemote(or whatever its called, I dont have it anymore) all use Virtual Network Computing (VNC) to control compuer applications.

clockwork's picture
Thanks for your answer but I

Thanks for your answer but I think the problem might be an other..

Before my Tomato Router I used to have an Apple Airport Extreme Basestation as I wrote above.
And with this one, I never had such a Problem. Neither when my Computer with iTunes on it was on LAN nor on WLAN.

wiseadam's picture


I would verify that your ports are open and that your firewall is not blocking the contact between the two. Also, make sure there is not a switch between the router and the wired computer.

If it works on the same machine wireless and not wired, something is set either on the machine disrupting the LAN connection, or the LAN settings on the router. If you are using Windows 7, verify the network is set to Home and not Public for the LAN

clockwork's picture
thanks for your help guys

thanks for your help guys

i just flashed a newer version of tomato on my wnr3500l (build 53 now, previously build 52) and everything works...

Striatum's picture
clockwork said: thanks for

clockwork said: thanks for your help guys i just flashed a newer version of tomato on my wnr3500l (build 53 now, previously build 52) and everything works...

You should consider flashing build 54, build 53 was very buggy and isn't even present in TomatoUSB archives (it shouldn't be here on Myopenrouter site), and build 55 should soon come:


rustbat's picture


"Same problem. I'm running itunes under win 7.

Here's what I did to fix the problem. Basically you need to create a new exception in your firewall to allow itunes UDP communication.

control panel>system & security>Windows firewall.
Advanced settings>inbound rules
New Rule> Program > browse to C:\Program Files (x86)\iTunes and pick itunes.exe
Allow the connection>next>next
Give it a name like iTunesUDP.
Now click on your new rule "iTunesUDP" and select properties.
Click the protocals and ports tab.
under protocal type select UDP.

That should do it.

Let me know if it worked for you. "

I created two of these, one for UDP and one for TCP. Some users reported that both are needed to make it work