Kong Mod Update build 17600

50 posts / 0 new
Last post
Kong's picture
Kong Mod Update build 17600

Here is a new build based on dd-wrt 17600.

Kong Mod Info: http://www.myopenrouter.com/article/23842/DD-WRT-Kong-Mod-Info/

Only little changes compared to the last release.


  • run on mount script executed after automount is finished
  • fix router not responding anymore if wan was set to disabled
  • fix display mW instead of dBm
  • add some delay for slow responding usb devices


  • Fixing Belkin F7D4302 crash by creating a build which includes latest dual radio drivers.

Recommended builds for WNR3500L/Asus RT-N16/WRT610N V1/V2:


MD5SUM: cf78c15b6f2f3eec3ff92a9070bdbba8


MD5SUM: 539fd0723c836ed04d2fabda9ae9f842

Same as above but including latest wireless driver, needed for Belkin F7D4302 (can also be used on WNR3500L/Asus RT-N16/WRT610N V1/V2):


MD5SUM: 183695fa01d3dbb5a9e5a6dcbfc8b62b


MD5SUM: fcddf726f54707d62fff494da953c7dc

eTaurus's picture

I haven't updated to the latest two builds and now I'm wondering about a few things:
1. Using my RT-N16, what's the new wireless driver offering above the old one? Is it considered stable?

2. What's the recommendation concerning Optware? Now that your build has a working automount feature the only thing I need is Optwares watchprinter functionality, commands like blkid and fdisk and Samba 3.5. How do I get the same functionality without Optware?

3. Should I decide to stop using Optware, how can I deactivate it without deleting the partition (it takes a vast amount of time to repartition a 1 TB disk over USB 2.0 and I don't know anyone having a PC with eSATA connection)? If there is no alternative to delete the partition, how should I partition my drive?

As usual many thanks for your work, Kong!


zoomlink's picture


I am in the same boat, I am afraid to make the leap given all the issues being reported.

As for disabling OTRW, all you need to do is issue the following commands:

cd /opt
rm -r *

This should wipe out everything under /opt but leave the directory intact.


THANK YOU! for all the testing you are doing and reporting back to us so quickly.

Some comments about OTRW:

I think Frater's work brings a lot of key functionality that can be accomplished by anyone through the packages from the ipkg-opt repository, BUT, the REAL contribution that he shared with everyone was that he thought it through, tested all these separate pieces together and made sure they worked cohesively by ensuring they start in the right order and can be managed as services.

I am fairly confident that with Kong's mod, we could disable the following services in the OTRW collection (subject to Kong's validation and testing like MadRocker is doing]:

1. Automount (including swap)
2. Fixparts
3. Fixtables ?
4. Samba [smbd, nmbd, swat]

I think we could probably put some of the angst to rest if Kong was able to tell us if his builds are addressing what each of the following OTRW services does.

That could help us decide what we can turn off and we can opt to leave on or turn off.

I am a little perplexed by a couple of comments from MadRocker about the latest build regarding a connection between OTRW and WiFi getting unbridged and as result diabling internet access.

Here is the list of services that I have under OTRW:

Service: factconfig (/opt/etc/init.d/S00factdefault) Great for after fw upgrades.
Service: named (/opt/etc/init.d/S09named) disabled
Service: xinetd (/opt/etc/init.d/S10xinetd)enabled
Service: dbus (/opt/etc/init.d/S20dbus)enabled
Service: automount (/opt/etc/init.d/S35automount)enabled
Service: reloc_syslog (/opt/etc/init.d/S40relocate_syslog)enabled
Service: pixelserv (/opt/etc/init.d/S45pixelserv)enabled
Service: soundmodules (/opt/etc/init.d/S45soundmodules)enabled
Service: portmap (/opt/etc/init.d/S55portmap)enabled
Service: unfsd (/opt/etc/init.d/S56unfsd)enabled
Service: zabbix (/opt/etc/init.d/S70zabbix) disabled
Service: lighttpd (/opt/etc/init.d/S80lighttpd)enabled
Service: pound (/opt/etc/init.d/S80pound) disabled
Service: samba (/opt/etc/init.d/S80samba)enabled
Service: vlighttpd (/opt/etc/init.d/S80vlighttpd)enabled
Service: kaid (/opt/etc/init.d/S85kaid) disabled
Service: asterisk (/opt/etc/init.d/S90asterisk) disabled
Service: nzbget (/opt/etc/init.d/S90nzbget) disabled
Service: transmission (/opt/etc/init.d/S90transmission) disabled
Service: fixtables (/opt/etc/init.d/S94fixtables)enabled
Service: stophammer (/opt/etc/init.d/S94stophammer)enabled
Service: asiablock (/opt/etc/init.d/S95asiablock)enabled
Service: birmablock (/opt/etc/init.d/S95birmablock)enabled
Service: twonky (/opt/etc/init.d/S95twonky) disabled
Service: watchprinter (/opt/etc/init.d/S95watchprinter) disabled
Service: worldblock (/opt/etc/init.d/S95worldblock) disabled
Service: openvpn (/opt/etc/init.d/S97openvpn) disabled
Service: ovpntap_yourvpn (/opt/etc/init.d/S97ovpntap_yourvpn) disabled
Service: siproxd (/opt/etc/init.d/S98siproxd) disabled
Service: stophack (/opt/etc/init.d/S98stophack)enabled
Service: backupessential (/opt/etc/init.d/S99backupessential)enabled
Service: ushare (/opt/etc/init.d/S99ushare) disabled

KONG: Maybe you can start chipping at this list and tell us either of the following:

a) My builds take care of what Service X(Y,Z) is/are doing... or
b) My builds do not address what Service X(Y,Z) is/are doing

Just my inspirational contribution this Sunday :)

Kong's picture
Okay I'm looking at:

Okay I'm looking at:


it says automount is obsolete.

-Bash -> My builds busybox have LFS, so not sure who needs this
-Pixelserv-> Privoxy in my openvpn build is more powerful, but if you want minidlna then you don't have privoxy:-(
-samba only needed if you need features that are not compiled in the included samba

Fraters OTRW I think is an intermediate solution for dd-wrt and broadcom devices. The better and proper way would be to work on a optware repository that works with dd-wrt and include the link to it in the ipkg conf included in dd-wrt. The problem with current optware repositorys is, that the packages were compiled with a non dd-wrt toolchain and therefore not always work correct and require hacks etc.

zoomlink's picture
All good points. Kong I

All good points. Kong I looked in the link you provided and could not find where it says that automount is obsolete, however, I agree given your built-in automounting.

I am saving to get me another RT-N16 for testing only. I have a hard time testing because the RT-N16 I have is my main router / mediaserver / fileserver.

If I screw it up, I will get seriously punished by the family. :)

Kong's picture
@zoomlink, hehehe I also just

@zoomlink, hehehe I also just have one (WNR3500L) unit, thus I try to avoid bad code in order to keep my wife quiet and a couple of tricks help in order to test things without the need to flash each time.

A second unit of course would make it much easier, but on the other hand, my builds are better tested than dd-wrt builds. If I break features I use myself I'll notice right away:-) So basic things like dyndns,pppoe,wireless always work.

scififan68's picture
Hey kong, The wireless is

Hey kong, The wireless is working great in this release so far(6 hours)! Even my signal quality has improved. I will see how long this lasts. Thanks for the good firmware :)

eTaurus's picture
[email protected]:~# free

[email protected]-WRT:~# free
total used free shared buffers cached
Mem: 124416 30640 93776 0 2812 11680
-/+ buffers/cache: 16148 108268
Swap: 0 0 0

Do I have to stop some Optware scripts?

[email protected]-WRT:~# blkid
/dev/sda1: LABEL="Optware" UUID="34c10774-b975-49ae-bba2-62a78acd686a" TYPE="ext3"
/dev/sda2: UUID="782393bc-d9bf-4e4a-b492-ce76485f67e5" TYPE="swap"
/dev/sda3: LABEL="Lagerhalle" UUID="f4a29634-9c89-83c2-3344-13108ea6dd2a" TYPE="ext3"

Or do I have to name the swap partition?

Kong's picture
Hi eTaurus,

Hi eTaurus,

what disk is this, how is it connected?

Do you get any output with this command:

ls -la /dev/scsi/host0/bus0/target0/lun0/

eTaurus's picture
It is a 1 TB hard disk

It is a 1 TB hard disk connected through an USB hub.

[email protected]-WRT:~# ls -la /dev/scsi/host0/bus0/target0/lun0/
cannot access /dev/scsi/host0/bus0/target0/lun0/: No such file or directory

I have /dev/scsi/host5/bus0/target0/lun0

Kong's picture
OK, do you see any messages

OK, do you see any messages in /tmp/hotplugs?

eTaurus's picture
[email protected]:/# ls -la /tmp

[email protected]-WRT:/# ls -la /tmp/hotplugs
4 -rw-r--r-- 1 root root 422 Jan 1 1970 /tmp/hotplugs

zoomlink's picture
Question - what is the nvram

Question - what is the nvram variable for hiding your SSID?

Mine would be blank on metageek inSSIDer but for some reason started showing up as an intermittent value... blank, mangled garbage and then the clear SSID and back to the same loop.

Kong, wondering if you have addressed on your builds the claims that diabling SSID broadcast is broken.

I am still running 17140 Kong DLNA + OVPN(installed mannually) until this coming weekend.

Kong's picture


I meant rather:

cat /tmp/hotplugs



never ever used the feature to hide the ssid, since hiding an ssid is a completely useless feature and has been even a security risk in the past. If you want to really hide your ssid you have to make sure the signal stays inside your rooms:-)

eTaurus's picture
[email protected]:~# cat /tmp

[email protected]-WRT:~# cat /tmp/hotplugs
start_hotplug_usb devicepath /devices/pci0000:00/0000:00:04.1/usb1/1-2/1-2:1.4
start_hotplug_usb devicepath /devices/pci0000:00/0000:00:04.1/usb1/1-2/1-2:1.3
start_hotplug_usb devicepath /devices/pci0000:00/0000:00:04.1/usb1/1-1/1-1.3/1-1.3:1.0
Reading /dev/scsi/host5/bus0/target0/lun0
Skipping ..
Skipping .
Skipping disc
Processing part1
Processing part2
Processing part3
Done reading /dev/scsi/host5/bus0/target0/lun0

I'm not that much of a Linux user to know all the commands. ;)

Kong's picture
Ok, this looks pretty good

Ok, this looks pretty good already, it trys to mount all 3 partitions.
Can you show me the output of:

/usr/sbin/disktype /dev/scsi/host5/bus0/target0/lun0/part2

Just a note: it takes at least 15s until partitions from one drive are mounted. So if you ran free right after you connected the drive you might have not waited long enough. But we will see what Filesystem the above command reports for your swap partition.

eTaurus's picture
[email protected]:~# /usr/sbin

[email protected]-WRT:~# /usr/sbin/disktype /dev/scsi/host5/bus0/target0/lun0/part2

--- /dev/scsi/host5/bus0/target0/lun0/part2
Block device, size 125.5 MiB (131596288 bytes)
Linux swap, version 2, subversion 1, 4 KiB pages, little-endian
Swap size 125.5 MiB (131596288 bytes, 32128 pages of 4 KiB)

No, it was several minutes after reboot that I decided to check if Swap is mounted.

Kong's picture
Hmmm, looks ok, should have

Hmmm, looks ok, should have been mounted.

Lets try if you can manually activate swap, by running:

/sbin/swapon /dev/scsi/host5/bus0/target0/lun0/part2

after that check if free reports a swap.

eTaurus's picture
Doesn't work. No output after

Doesn't work. No output after /sbin/swapon /dev/scsi/host5/bus0/target0/lun0/part2 and no mounted swap.

Kong's picture
Then there must be something

Then there must be something wrong with the partitioning/formatting.
How did you create that swap partition? Did you manually create it using fdisk, if yes, did you run mkswap?

eTaurus's picture
I can't recall if I ran

I can't recall if I ran mkswap. I only know that there is something wrong with the sector borders.
It seems that I have to repartition the disk again. The only problem is that I don't have enough space for my data. And repartitioning via USB 2.0 takes so long time.
Which how-to should I read to do it right the next time? Maybe I'm going to use my 80 GB disk for Optware and Swap and the 1 TB for data only.
Thank you for trying to help!

Kong's picture
Not sure if http:/

Not sure if http://partedmagic.com/doku.php can fix it now, but it would be worth a try. However you can use it to partition the other drive.

Kong's picture


hmmm in the code it says default power for RT-N16 is 17. For the rest it says 71.
Since my builds sets 40 as default. I'll change this to 40. 40 is pretty much the max I recommend, this will always work even if your are located in sunny areas:-)

Tonight I'll test umounting via SES Button.

Oseias's picture
After erase nvram, the

After erase nvram, the password config screen is bugged. I had javascript problem when submit username and password .The var:
F.next_page.value = Info.htm;
"Can't find variable: Info"

I think the correct way is:
F.next_page.value = "Info.htm";
After alter it in firebug, I can submit without problem.
I using ddwrt/dd-wrt-usb-ftp-samba3-vpn-O2-v24-K26-broadcom.bin

Best regards.

Kong's picture
Hi Oseias,

Hi Oseias,

thanks for letting me know, I think this got broken with the latest changes in http://svn.dd-wrt.com:8000/changeset/17670 by dd-wrt folks and it seems like this just got fixed : http://svn.dd-wrt.com:8000/changeset/17672

Currently compiling new builds, probably in 30min I can push them to the ftp.

Done fixed builds are up.

val532's picture


Sorry I'm french and i'm not good in english.

I have a probleme with your firmware, I have a two HDD in one case and dd wrt saw only one disk and not se second.

On my compurter i saw the two disk, i havent any Raid option, is just like two HDD conected on a USB hub.

eTaurus's picture
Hi Kong,

Hi Kong,
I reformatted swap with gparted, chose to activate the partition as swap and now it is working.


val532's picture
Thanks for your repli.

Thanks for your repli.
But for me only one drive is recognized i have only one host on /dev/scsi/.

Kong's picture
If you only have one /dev

If you only have one /dev/scsi, do you have 2 luns? Check:

ls -la /dev/scsi/host0/bus0/target0/

does it report lun0 and lun1?

val532's picture
no just lun0 the chip of my

no just lun0 the chip of my case is a SIL5744 whit two sata port and one usb and one Esata

stevepier's picture
Hi Kong,

Hi Kong,
i'm in big trouble.. after updating to 17600 dlna i cannot enter anymore control panel. I cannot change password. I did a 30-30-30 reset but nothing changes.
I tried to telnet but it cannot recognize any password...

Have you some idea?

Thanks in advance steve