Kong mod weird DNS issues

1 post / 0 new
russellr's picture
Kong mod weird DNS issues


This isn't a question - I'm making a note in case someone else has this problem.

I loaded the latest Kong mod for my R7000 (around 23rd Dec 2015) and it seemed to work OK.

However, 2 annoying problems existed:

  1. My Chromecast could be contacted on the Wifi network, but the iPad's "Cast now" button never appeared.  I probably spend 8 hours trying to get this to work, without success.
  2. On my desktop computer (wired), I'd get random long delays accessing GMail and google.com and google.com.au.  Google calendar wouldn't work reliably at all.  I tracked the problem down to DNS resolution.  Google domain names just wouldn't resolve reliably.  However, everything worked OK via my iPad on the WiFi network.  Go figure!

I probably wasted 3 days working on these problems.

Eventually I just loaded the standard DD WRT firmware (the latest) and all problems are solved.

Maybe I forgot to reset to factory defaults at one point where I was supposed to do that, but I defintely did it *after* loading Kong mod firmware.

Anyway, happy with DD WRT!