Kong R8000 DD-WRT build is here!!!

22 posts / 0 new
Last post
OpenMehRouter
OpenMehRouter's picture
Kong R8000 DD-WRT build is here!!!
btbill
btbill's picture
I have been using it now for

I have been using it now for about 2 weeks and all was fine. Now WiFi is intermitent with constant problems of wifi just stopping.

 

It does not impact wired devices

 

 

bob

btbill
btbill's picture
And I have also noticed the

And I have also noticed the router is crashing now. Dropping connection even on wirted devices. I'm rolling back to DD-WRT firmware for Netgear R8000 Based on revision 27261 which seemed to be reliable as my wife goes nuts the amount of times we loose the internet as a result of this firmware.

 

Shame, I am sure it will get fixed though

bob

btbill
btbill's picture
I have noticed that itcrashes

I have noticed that itcrashes the wifi when a new device come in to range. In the case where this router is my android handset or my wifes android handset. It couild be coincidence?

 

R8000 telnet login / SSH login

and just a thought as this drove me mental, when trying to use telnet to wipe the NVRAM factory reset the router using the browser login. Reboot, when you go back in after the reboot, using the browser, and are promted to change the password leave the password as password (you should retype password in to the password bit not just leave it as it wont let you do this) and then enable SSH or telnet. Quit the browser....

Then use telnet (I used putty for this) and you log in with username: root (yes 'root' regardless of what it said in the above) and password for the password

Too weird but it worked I have my sanity still

bob

tal69
tal69's picture
R8000 Frimware:DD-WRT V3.0

R8000 Frimware:DD-WRT V3.0-R27775 kongac (09/07/15)

 

Have reset to factory defaults numerous times and setup from defaults...

 

The AP Radios seem to work much better in this build but there is an issue assigning a virtual interface for WL1 (2.4 Ghz) Radio. After Virtual Inteface added it will not show up in the current Bridging table.  The SSID shows up as a browseable Wif network but clients cannot authenticate to Wifi AP.

VLAN1 is for wired LAN and WLAN 0,1,2. VLAN3 is for virtual WLAN 0.1, 1.1, 2.1.  This allows an independant DHCP Server to configure separate networks for VLAN's.  One Network is for VLAN1 and one network is for VLAN3.  VLAN3 is for Guest Network and isolates traffic from LAN.

I can bridge WLAN 0.1 and 2.1 (5Ghz) to VLAN3 and both work.  Only 2.4 GHZ vWLAN is not working.  Has anyone seen this?

Talmage D. Holt

tal69
tal69's picture
This issue is resolved by

This issue is resolved by erasing NVRAM after upgrade...

 

Once the NVRAM is erased run upgrade again and use the reset to defaults option.  Then proceed to setup router.

 

Build 27950M resolved all of my problems.  Radios, Virtual WLAN's for isolated Guest Network, VLAN Trunking using WAN Port (WAN Port added to switch) creating internal WiFi Access Point behind Firewall/Router.

Talmage D. Holt

tal69
tal69's picture
The latest Build I have

The latest Build I have installed and verified is 28000M.  Results below are using this build via link in first post.  

 

Word to the wise:

1. Reset to defaults in Netgear firmware, reboot.  2. Flash to Kong's DD-WRT, reboot.  3. Reset to defaults in Kong's firmware, reboot.  4.Erase NVRAM, reboot.  5. Reflash to Kong's firmware, reboot.  6. Setup router.  7. Apply Settings, reboot.  8. Backup firmware settings.

I have used settings and upgraded 27775M -> 27950M -> 28000M.  If any degradation or quirkiness remains my suggestion is to begin at #3 and do not restore settings, just set up the flashed build manually.  I am now several weeks into these three builds and they have been very very good, and very, very stable.

 

I am using R8000 as access point.  It has seperate VLAN's for internal Private Network and WiFi Guest network.  They all work...

 

Here is an example of throughput using Comcast 100/20 Service with NetBurst. On Both 5Ghz Radios upstairs from AP I am getting below results.  Not quite as good on 2.4Ghz (Neighborhood pollution) but close to 100Mbps.

Kong's Builds have gotten better and better on this device and really unleashes performance and possibilities.  I hope he begins tuning up a build for R8500.  That device should be amazing if the same quality DD-WRT Build is created by Kong...

Talmage D. Holt

btbill
btbill's picture
I have now gone back to the

I have now gone back to the factory firmware. as an example of why. With my intel compute chip I got 4-6 megs download which was very erratic sometimes dropping as low as 1 meg or less. Not enough to support streaming Tv especially in HD. WiFi would also unexpectively just stop and router would need reboot.

Now I have gone back to the factory firmware I get over 20megs and in some cases 27megs to the compute stick with everything exactly the same except the firmware.! 

Sorry, but the wifi performance of all the DD- WRT builds I have tried dont come anywhere near this.

I have also had my router running for 11 days now and it has not randomly turned off the WiFi an required a reboot at all. It just works now and works rather better. OK a few features are missing but WiFi is key and if it is unreliable this is not an firmware option.

 

bob

Absoluteg
Absoluteg's picture
Could someone walk through

Could someone walk through how to reset/clear/erase/reset for the R8000?  I have read artilces on how standard steps don't apply to ARM devices and can cuase issues.  I have read and i have tried a 30-30-30 reset on this device and it has now affect?  Could someone explain the steps for the R8000, i don't want to brick or break the device.   At the moment i have some stability issues using a build from KONG earlier in Oct 15 and i would like to reset and clear stuff out and apply my configuration manually.  Problme is that i'm not 100% sure how to do any of the procedures for the R8000.  Any help would be greatly appreciated!

bwired
bwired's picture
same here

same here

back to original firmware :-(

guestnetwork on diff  ip range was not passible, users could not login

also very unstable

lavallelaabs
lavallelaabs's picture
Me too - tried for 4 hours

Me too - tried for 4 hours but no joy, reverted back to factory firmware

NetMonkey79
NetMonkey79's picture
 

 

Just upgraded to DD-WRT for R8000, Kong release V3-r28500.
 
Attempting to add guest network, DHCPD and a new bridge however where there should be references to wl0, 1 or 2 depending on what network your looking at there is none. Looking at the system status page all my wireless devices show they are either connected to eth1, 2 or 3 depending on what radio i have them connected to. shouldn't this say wl0, 1 or 2 for wireless and eth0, 1 2 or 3 for wired devices?
 
I have confirmed that in the wireless setting they do state wl0, 1 or 2. When i attempt to create a new bridge (br1) and assign to it the drop down does not reference wl interfaces at all. Only entries in the dropdown are: eth0,1, 2, 3, VLAN1, VLAN2 and Bond0.
 
Am i missing something?
bwired
bwired's picture
yes you missed a lot, read

yes you missed a lot, read the above, this firmware is even not worth installing

lots of problems, take the original

Eternalx
Eternalx's picture
Yeah I used the march 2016

Yeah I used the march 2016 kong build and it started crashing on its own over time I reverted back to stock netgear firmware til I find a build worth putting on. :)

gizbug
gizbug's picture
How is the stability with 

How is the stability with 

"Kong Mod" NETGEAR Builds Updated 2016-09-09

 

Does Kong Mod support CTF? I have gigabit internet now, and I've heard that it does NOT support CTF, which would affect my gigabit speed (Stock and Tomato Shibby do I believe).

 

 

BoDEAN

Solarfinder
Solarfinder's picture
I didn't see CTF support when

I didn't see CTF support when I installed and configured it. Once I got through some of the strangeness of the configuration (multiple save/updates per section), I did see some serious improvement over stock gbit.

I run multiple ps4's, xbox one, android, win, linux, and mac in my house and I have seen a measurable increase on my throughput. The biggest increases were on large and medium sized video and image transfers, as well as plex 20mbit streaming.

I am a liytle nervous at the flakiness the ui exhibited during setup, however so far I am quite pleased.

 

mohbandy
mohbandy's picture
I have been running this mod

I have been running this mod for over 6 months. Am currently running the June 2017 update. I had to go back to stock firmware. Since using this firmware, I have has wifi connectivity issues. I have 4 devices that simply fail to authenticate over wifi using WPA2 personal. The final straw was when my phone would connect over wifi but my wife's would not. Same brand/model and I can't get hers to connect. Stock firmware fixed my issues, but I lost the dd-wrt goods :(

BigShowJoe
BigShowJoe's picture
I'm having very similar

I'm having very similar issues.  The 5ghZ radios are working fine but the 2.4ghZ radio is very sketchy.  If I make any changes to it, I have to do a full router reboot for them to really take effect.  If I disable security, things connect and work fine.  Adding security back and nothing will connect until reboot.  After that, speeds are half of what they should be.  

 

Please share the stock R8000 firmware file.

FuShiLu
FuShiLu's picture
I’m running the R8000 test

I’m running the R8000 test version, much better but wifi issues still exist. Speed is the largest. 

FuShiLu
FuShiLu's picture
To be clear that is with the

To be clear that is with the new wifi patch, and I asdume attempts to fix things stored in the test folder. 

riosra
riosra's picture
Jumped to the latest firmware

Jumped to the latest firmware rev from the June 2017 release. This latest update breaks WPA2 Enterprise. I cannot connect via wifi.

Any help would be appreciated as I do want to implement the latest security fixes... if not, I'll roll back.

 

Thanks!

 

FuShiLu
FuShiLu's picture
Try the test folder version.

Try the test folder version.