Netgear DG834N Bricked - Any Ideas?

3 posts / 0 new
Last post
cbtg2006's picture
Netgear DG834N Bricked - Any Ideas?
Hi guys. Firstly, just wanted to say hello, I'm new to the forums. And secondly
to apologise, for rather than contributing on my first post, I am asking for help.

I was trying a F/W update on my router and it 'ditched' part way
though. After coming back to the router 20 minutes later the device was doing
nothing - LEDs static etc. A power off/power on has resulted in a flashing
power led (green/red) and nothing else.

 I cannot ping the router on the LAN interface, I have tried setting a
static MAC entry to use the recovery utility but this fails also. The recovery utility detects no devices.I have been
reading some info on JTAG and then came across the following article on this

This led me to look for the serial interface on this router. It would appear
there is a UART interface as detailed here:

What are the chances of a similar procedure working? The pin layout is
different, only 4 pins as in the imaged above.

Thanks in advance - any help / suggestions greatly apreciated. Smile



listamlet's picture
I was wondering if you ever

I was wondering if you ever managed to flash the firmware- i'm having the same problem.

Thanks for your help,


Petertj's picture
Hi, I had the same problem

Hi, I had the same problem and was not given any suggestions by Netgear that worked. This did:

1. The only light lit up other than the # of the RJ45 port used was the On light. This was flashing red and green alternately around twice every second. The router should be reset by holding in the 'reset' switch on the back of the unit for 20 seconds then, while continuing to press the reset switch, power up the unit by inserting the power cable. After a further 20 seconds release the reset switch. Now verify that the lights are as per the second sentence of this solution (above).
2. The correct firmware update for the router was obtained from the Netgear support web site. The file name is dg834n_1_02_08.img.
3. The router recovery utility file called was downloaded from the Netgear site.
4. As per the instructions contained within the recovery utility the firmware image was added to the directory/folder and after checking that 1. (above) had been caried out to put the router into a receptive state the utility was run.
5. This failed because the PC used to run the utility was Windows 7.
6. The procedure was then run again from 1. to 4. using a PC running Windows XP SP3.
7. This restored the router to it''s correct state by erasing the eePROM and installing the firmware update identified in 2. above. The correct state was identified by the lights being both green and lit up as expected.
8. From this point on it was necessary only to restore a back up of settings for the router to function correctly. Or, if no backup then re-configure from scratch.